[RESPONDED] Fingerprint reader fails to scan my fingerprints

I’m using Fedora 37 Workstation (upgraded from Fedora 36), and I’ve never been able to add a fingerprint. The settings app responds when I place a finder on the reader (the fingerprint icon changes color), but nothing happens. When I remove my finger, it often says “Place your finger on the reader again.”

I just tried the script to clear the fingerprint storage in case that was causing an issue, but still no dice. Any help is appreciated.


1 Like

How long are you holding your finger on the reader? The UI is a bit strange - I had to hold my finger on it until the icon changed back from being blue, then do it again a number of times (there was no prompt to do this).

Hmm, I’ve held it on for up to 30 seconds before. I just tried doing about 10 lifts and presses in a row, and then I got a message saying the fingerprint device was disconnected, and now I’m getting a message at the top of the window saying the device is already claimed by another process.

On Fedora 37, vanilla installation, this will usually work just fine. It’s not uncommon to need to move your finger around a bit to get it working, but I’ve never had any issues with it.

@Ben_Gifford I am having exactly the same symptoms. Did you manage to get it working and how ?

I never did get it working. I tried just now, and it seemed like it successfully enrolled my fingerprints for the first time. When I logged out and put my finger on the reader to log in, however, it immediately said something about not recognizing it as a registered fingerprint and removed the fingerprint data and the option to login that way. After using a password to log in, it’s now failing to enroll my fingerprints again.

I just managed to enroll my right ring finger in the GUI settings. I paid special attention to placing the center on my fingerprint pattern onto the reader.

I tested it and I was able to unlock the lock screen

Tried to enroll other fingers with the same idea but it failed.

Okay, let’s try this for Fedora 37. Must of this may already be done, please do so anyway.

Install the needed packages

sudo dnf install fprintd fprintd-pam

NEW - Make sure to complete the following.

sudo gnome-text-editor /usr/lib/systemd/system/fprintd.service

At the bottom of the file, add:


Now Save the file.

Restart the service

systemctl restart fprintd.service

Enable fprintd even if it was enabled

systemctl enable fprintd.service

Now let’s enroll from the terminal, so we can see the specific errors if any.


if it errors out, revisit

systemctl status fprintd.service

then paste back the results of the bottom portion which will have your errors.

1 Like

So the enrollment worked fine, but I’m not having any luck logging in via the fingerprint reader. It keeps saying it’s failing to match a fingerprint on record.

Glad enrollment went well. I’d check verify to make sure it is recognized:


Logging in is super sensitive and can time out asking for a password. Finger placement is very sensitive. So it may take a few tries to get a good read.

When trying to verify my print from the terminal, the experience is similar.

Using device /net/reactivated/Fprint/Device/0
Listing enrolled fingers:

  • #0: right-index-finger
    Verify started!
    Verifying: right-index-finger
    Verify result: verify-no-match (done)

When I run fprintd-verify again immediately after this, I get the following error:

Using device /net/reactivated/Fprint/Device/0
ListEnrolledFingers failed: GDBus.Error:net.reactivated.Fprint.Error.NoEnrolledPrints: Failed to discover prints

1 Like

I’ve been using this appimage to address issues like this. I’ve also reached out to the creator to better understand how it works. Basically it clears the fingerprint device and gets it “unstuck”. It’s supposed to be including in libfprint from what I was told, but it may not be there yet.

This seems promising so far and worked after one attempt!

1 Like