[RESPONDED] Framework 13 AMD Linux slow WIFI

Today it way the first working day for my brand new Framework pc! Everything seems to work fine but I have this issues with being really slow on wifi.

As you can see the Macbook on the same location show a different speed.

Upon investigation I found:

So I’ve tried

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

but it dosent seem to work

Any suggestions?


  • Pop!_OS 22.04
  • Framework laptop AMD 13
1 Like

Hi @Fabrizio_Anichini

have a look here:


1 Like

Welcome to the community!

Just a quick note, we do not test against Pop, we test against Ubuntu 22.04.3 and Fedora 39 using our install guides.

In looking at your details, you appear to be connecting to 5 GHz which is fine.

Let’s do this.

  • Test this again with a live USB of say, Fedora 39. It will closer match the “newness” of Pop, but will be with a tested distro. Despite missing the updates that come with a dnf update, it will be pretty close to what we might see with Pop.

  • Verify you’re on the latest BIOS - you should be on 3.03. Even running live, dnf should allows you to “install” the needed package to RAM for the live session.

  • If you are still seeing slow speeds, back on your Pop install, we could verify you’re set to the correct region with sudo iw reg get

  • Let’s also verify that your power save is actually off:

iw dev | awk '/Interface/{iface=$2} END{system("iw dev " iface " get power_save")}'
  • Which brand/model router are you connecting to? Is it wifi 6E or older?
1 Like

I’ve tried Fedora 39 and the network speed was good ( at least the same as my MacBook).

I also tried the pop shell and because now is fixed for gnome 45 now I have fedora 39 as main OS.

Probably I’ll try again running Pop when the new Cosmic will be release. In case I’ll refer to this thread as a guideline


Just making sure I am following, did you try the suggestions above? Appreciate you trying Fedora, but we also need to know if you’re on the correct BIOS and what the power save status is?

iw dev | awk '/Interface/{iface=$2} END{system("iw dev " iface " get power_save")}'

That said, certainly worth trying Pop to see if there is different behavior, but, the difference may be something that is a bug that needs to be reported for Fedora.

1 Like

Update: The update indicated here for the slow wifi with the mediatek card, is available on Fedora. Please make sure you are fully updated.

1 Like