[RESPONDED] Higher idle power consumption after resume from s2idle

Yeah definitely didn’t work. I think we should wait out the solution to the L1SS problem first. This is more likely to be the root cause.

1 Like

Cool. Thanks a lot!

Just interested in the topic: I’ve recently had the feeling that after some/many hours of usage my fw13’s idle power consumption might be higher, so the title of this topic felt like a possible explanation. So I repeated the same test.

I’m running Ubuntu 24.04 with latest kernel 6.8 from repos (31-generic), desktop is gnome with many extensions and I run the same command as the OP on alacritty. I get 3.4W before suspend and around 3.8W after suspend.

My kernel cmdline: root=****** ro splash quiet vt.handoff=1

I get the same first 3 changes: both mediatek wifi and nvme ssd (different model from Sabrent/Phison) are affected in the same way.

But in my case 08.2 is not D3 never, even after boot before resume. I get this both after and before suspend:

00:08.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 14eb (prog-if 00 [Normal decode])
	Subsystem: Device 0006:f111
	Capabilities: [50] Power Management version 3
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
1 Like

Thanks, this reaffirms it’s an issue with L1SS.

I’ve been tracking similar observed behaviour through the last few kernels. The variance in battery draw from fresh boot vs after a couple of days without a reboot and multiple sleep cycles - this thread has been super helpful in confirming i’m not insane.


So something you can experiment with doing to confirm it’s L1SS is to use setpci to manually change fields that have changed and then check if that helps the power consumption.

Can you guys try 6.9? There are two interesting commits that might help the L1SS issue.

Done. It seems like the problem is solved!? :partying_face:.

Had several suspend cycles today and the idle power consumption stays at about 3,3 - 3,5 W what is until now only the case before the first suspend of the system. Hopefully the problem is finally gone…

1 Like

That’s great news!

1 Like

Same thing observed here. I just tried 6.9.0-363.vanilla.fc40.x86_64 and doesn’t observe the idle power consumption difference before and after suspend (triggered by amds2_idle.py) anymore. Using lspci, I am not observing the L1SubCtl1 discrepancy as well. :confetti_ball:


This is the commit that should be the reason it’s fixed.