[RESPONDED][MT7922] Wifi slow to start on boot

Hi all!

I bought Framework Laptop 13 AMD (Ryzen 5) batch 9, and I installed Manjaro (Arch Linux).
Everytime I start the laptop, the wifi interface is slow to start (maybe 2 minutes). When loading, I can’t see the interface using the Network Manager (it shows nothing, the same thing as if I had no wifi card).

When I turn on from sleep, it works great! It’s just when I boot the computer. It does this since the first install of the computer.

Do you have any ideas why?



Hi @Harfeur

Welcome to the community :slight_smile:

can we check what’s happening under the hood with journalctl -b 0
And copy/paste the output here. Also have you tried if it’s just a Manjaro issue or hardware issue by running latest Fedora 39?

cheers! :slight_smile:

Hi @Loell_Framework!

Here’s the logs from the journal : Framework logs - Pastebin.com
I haven’t tried using Fedora, but I will try tomorrow to run a Live CD.

Thanks :slight_smile:

Thanks for the logs @Harfeur , will check. :slight_smile:

I’m seeing NetworkManager on KDE having some error? which may impact wifi connection.

Let us know if this can be replicated on Fedora 39 or in Ubuntu 22.04.3

I’ve tried and the wifi works great in Fedora.
I’ll try to check NetworkManager with KDE problems. I didn’t had this problem with my older computer using the same OS.

FWIW this is the same behavior as reported here Unstable and unreliable WLAN RZ616/MT7922 [FW13 AMD DIY] - #18 by ouaibe

Do you have similar messages in your dmesg ?

I’m running Manjaro and had the same behavior for about a week. After a fresh boot, it would take about 2 minutes before wifi would come up, but recovery from sleep or hibernate was fine. As of Wednesday, it now starts properly. It could be kernel-related: my system just updated to 6.6.8. It’s also possible there was a network manager update, but I haven’t checked.

@ouaibe The issue is completely reproducible, so I don’t think the cause is the same as you reported.

I have everything up-to-date and I have the kernel Linux 6.6.8-2. The problem still occurs.
I’ve tried using the kernel Linux 6.7.0rc6-4 and I still have the problem.

What are your kernel settings? Mine are: quiet splash resume=UUID=XXXXXX udev.log_priority=3 amdgpu.graphics_sg=0 rtc_cmos.use_acpi_alarm=1

You can find them in the line GRUB_CMDLINE_LINUX_DEFAULT in the file /etc/default/grub.

Mine are:

“quiet splash apparmor=1 security=apparmor
udev.log_priority=3 mem_sleep_default=deep

I haven’t changed them since well before the wifi started acting strangely.

Same issue here

1 Like

This problem started re-occurring for me. I figured out how to fix it this evening.

Per the recommendation on the Arch Framework wiki (WiFi Performance on AMD Edition), I switched NetworkManager to use iwd as the back-end. It was pretty trivial to do.

  1. pamac install iwd
  2. Create /etc/NetworkManager/conf.d/wifi_backend.conf with the following:

  1. Remove existing NetworkManager profiles by deleting *.nmconnection in system-connections directory (You’ll need to re-create them in NM after you restart)
  2. Reboot, then reconnect to your network to re-create the profile under iwd.

My instructions may be imperfect and your mileage may vary. Follow the directions on the arch wiki.

My wifi now comes up instantly and connects to the local network.


Still not working for me :cry:
I also tried using networkmanager-iwd, but still the same problem. I checked, and it’s using iwd properly, but the problem seems to be the NetworkManager because I can start iwd using CLI when the computer starts.
This line from NetworkManager is taking too much time to appear compared to the previous log line :
24/01/2024 08:59 NetworkManager <info> [1706083178.8423] manager: (wlan0): new 802.11 Wi-Fi device (/org/freedesktop/NetworkManager/Devices/3)
What could happen ?

Weird. The iwd change completely fixed it for me. My wifi now comes up immediately.

If I just restart the computer, it works. But if I shut down then start, it doesn’t works…

Weird …

Good catch! I just confirmed the same behavior (even with iwd)–I rarely shut down my laptop, so I didn’t notice.

Hibernate and reboot–wifi starts immediately.
Cold boot–wifi takes about a minute to start.



Still not working on kernel 6.8…
Does anyone have news?

I think the culprit for long wait on boot is this patch: 0038-mediatek-pci-reset.patch - aur.git - AUR Package Repositories I worked around it by simply lowering PCIE_RESET_READY_POLL_MS to 16000 milliseconds in drivers/pci/pci.c and it works fine for me.

1 Like

Is there any workaround that doesn’t involve rebuilding?

Installing a kernel package which does not contain that patch also works.

1 Like