[RESPONDED] Power management & keyboard failure issues when plugged into AC

I have been using my 12th gen DIY Framework for ~2-3 months now and it has recently developed a very strange problem. If I am using it and plugged into AC power, it will occasionally go into a little fit that does the following:

  • Automatically suspends the machine every ~30s or so
  • Disables the keyboard (but the trackpad still works)

I have tried hard rebooting and this issue will persist into grub even. Removing the power cable will resolve the issue.

I tried updating the the beta bios using fwupd, but that did not resolve issues. I think this started around the time that I updated grub-efi-amd64 (ubuntu-based distro) along with shim-signed, but nothing in there looked too dangerous.

Have other people run into something similar to this?

Hi @hobosteaux , welcome to the framework community, may we know what Ubuntu based distribution you are using and what version? might be distro specific, thanks.

Yeah, of course! This is with ElementaryOS 7. I poked through dmesg and didn’t see much during the time unfortunately (also hard to do without a keyboard). Let me try an external keyboard next time and see if that works.

Kernel: 5.19.0-35-generic #36~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC

Thank you!

Sounds like a faulty acpi handler.

Very familiar to [RESOLVED] Laptop suspending to s2idle every 30 seconds

I suggest to check the system and acpi logs to find out what happens.

1 Like

@Anachron thank you for sharing almost i am facing the same issue.