[RESPONDED] Touchpad issues: dead spots, not always registring clicks made with little force

I have certain issues with my touchpad. They are not covered in the official support articles.

  1. Every now and then, my touchpad seems to have some dead spots. A dead spot is almost like a circular zone, seemingly no more than 5mm across in which the touchpad doesn’t register touches at all. In effect, this means that if I drag my finger over a dead spot in a straight line, the cursor goes straight at first, then at the dead spot, it curves around it (or stops completely if I go directly through the center of the spot) before continuing the straight line. It reminds me of a picture of a black hole curving spacetime. I can’t click in these zones either. These spots seem to appear randomly in different locations, then disappear after a short while.
  2. My touchpad doesn’t always register physical clicks. Specifically, when the click is made with just enough force to get it to depress with a click sound, a little more force is necessary to actually register the click. After reading the official support articles, I tried pressing down hard on the bottom center of the touchpad, when seems to have fixed it (for now at least) as of five minutes ago. This did not fix the prior mentioned dead spot problem, which still manifested after.

I’m curious if anyone else is/was having these issues.


trackpad track pad touch pad deadzones dead zones deadspots

I think I’m seeing something similar tbh, have only just tried the “push hard in the middle” thing, but it doesn’t seem to help. I’m on a 12th gen batch 4, running Ubuntu 22.10.

What’s your details? 11th/12th gen? Which batch? Which OS and version?

I have problem number 2 on a daily basis. Pressing hard in the middle will usually fix it for a few minutes, but the problem keeps coming back.

It does not appear to be a driver issue. All features work perfectly (multi-touch scrolling and gestures, tap to click, cursor movement). It is only the physical click that is inconsistent.

I have never experienced the dead zone issue. I’d recommend contacting Framework support. I should do the same.

Hi @Starlight,

Hi ,

The best approach is to open a support ticket so we can help get this resolved for you. Since our support staff focus on resolving issues of this nature in a ticket form, this is going to be the recommended course of action.

1 Like

was this issue resolved?

Hi @Tbhgfd

The op for this thread was asked to open a support ticket. Are you having issues and if so, we’d need details on OS, version, hardware, etc.