[RESPONDED] Try to install Clear Linx from USB on Framework 16

Maybe one of you got Clear Linux running on FW16 and help me out.
I got stuck here:

The following message appears on USB boot screen with no further action:
EFI stub: Loaded initrd from LINUX_EFI_INITRD_MEDIA_GUID device path
EFI stub: Measured initrd data into PCR 9

BIOS options changed:
Secure boot switched off

Tried to boot different images of clear Linux with different kernels (all from 2023+) without success:

Other distributions that have booted successfully:

System Parameters:
USB tool: ventoy-1.0.97
Laptop: Framework 16 (AMD Ryzen™ 7 7840HS + AMD Radeon™ RX 7700S)
Firmware/Bios 03.02
SSD: Samsung 980 PRO 1TB
RAM 2x: Kingston FURY Impact SO-DIMM 32GB, DDR5-5600, CL40-40-40, on-die ECC (KF556S40IB-32)

Try “normal” way - put ISO directly to USB and check will it work.

I flashed the ISO directly onto a different USB stick using Etcher (balenaEtcher-1.18.11-x64.AppImage).
The display message remained the same as described above and doesn’t continue the boot.

then it must be something else…

P.S.: I 'm not sure if Framework supports BIOS legacy boot mode, but if it does and if you try boot ClearLinux to it, but not UEFI mode, it will not work, IIRC.

I am not aware of any Bios legacy option:

I tried booting the Clear Linux installer out of curiosity and got the same result as you, load kernel and init and hung there. They just have a broken installer iso.

The installer worked without any problems on my second PC (AMD CPU and GPU).
I installed the SSD there and after the successful OS installation installed it back into Framework 16.
Works perfectly so far.

Clear Linux is a designed for Intel sort of deal last I heard. This may help, though.