[RESPONDED] Ubuntu 20.04.4 LTS on the Framework Laptop

Wrote something to workaround the AX210 on startup so I won’t have to think about it whenever the linux-firmware package updates. To only get the AX210 workaround run only that individual state like sudo salt-call --local --file-root="$(pwd)" state.apply framework-laptop.intel-ax210-workaround. Or you could just copy the service file out of it and install it manually.

EDIT: Now it also does hibernation / hybrid suspend however read the note before using it.
EDIT2: Now it also configures mem_sleep_default, installs tlp and explains what the heck Salt is and why it’s used instead of Bash scripts.

1 Like

A_L Thanks for the info on upgrading the kernel on Mint. It seems to have worked for me and only took a couple of minutes.

Quick longer-term update on Ubuntu 20.04.3 LTS

For the Mate flavor, just observations as I find them…

Broadly speaking everything is good, a few small issues that I haven’t got around to sorting out.

  1. Occasional power-off on attempt to resume from suspend, not sure what the root cause of this is, could be hardware, software, or bios.

  2. WiFi signal strength (according to the UI indicator) in my apartment is meh. (1930’s brick house, heavy plaster walls, 70$ dlink wireless router, intentionally using the 5ghz…) . Although in practice it seems perfectly usable and plenty fast (I am no networking guru, output from “watch -n1 iwconfig” below):

wlp170s0 IEEE 802.11 ESSID:“Skye-fi”
Mode:Managed Frequency:5.2 GHz Access Point: 78:98:E8:5E:EE:67
Bit Rate=260 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:on
Link Quality=41/70 Signal level=-69 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:79 Missed beacon:0

  1. Screen coating seems to get dirtier quicker than I would like, may look into a screen protector in the future

  2. Unresponsive touch pad sometimes on resume, 95% sure this is OS related, as suspend/resume (by closing the lid) solves this and everything is fine, or firing up the external mouse. This issue has been commented on before on this forum somewhere.

And the good:

  1. I am continually impressed by the rapid charge time of my Framework, and the battery life is absolutely fine.
  2. For my use case: the 2 USB-C, 1 USB-A, and storage expansion card have been sufficient (I use a logitec bluetooth mouse)

Disable PS2 emulation in the BIOS to get rid of this problem. Downside is if you use and OS that does not understand HID, like Windows Setup, you will have no touchpad at all. Alternatively you could use the suspend workaround from my salt formula.

Thanks for linking that up. That should improve the LTS installers’ experience significantly. :smiley: I won’t bother with testing it on 21.* series and instead will upgrade to 22.04 early and prepare it to work with it. Ideally during the beta stage, time allowing.


Another update having daily driven my Framework with Ubuntu 20.04.3 for about 4 months:
Still all good. The updates/tweaks from lightrush’s saltstack were GREAT in particular battery life on stand-by.

The fingerprint reader now works with the latest fprintd from focal-updates , namely 1.90.9-1~ubuntu20.04.1 . Updated formula to use the built-in packages. If you’ve already ran the formula, pulling the latest and running it again will purge the prebuilt packages and install the Ubuntu-supplied ones.

WiFi also works without workaround with the latest kernel that just came into the update channel. The formula has been updated to remove the old workaround in case you ran it before. Same as with the fingerprint reader, pull the latest and re-run.

@Skye_Leake you can update the original post to say that WiFi and fingerprint reader workarounds are no longer needed as long as you get the latest updates for Ubuntu 20.04.

1 Like

I concur @lightrush , I just upgraded my 20.04.3 system to the 5.13 kernel and now the wifi works without the need for the workaround. great news for getting a near turn-key LTS solution now. 22.04 is a few months away, but many might want to stay with 20.04 until a point release of 22.04 comes out.

1 Like

Yeah, exactly. That’s why I’ll maintain this supporting both 20.04 and 22.04 till 24.04 is out.


DisplayLink on Ubuntu 20.04.3 LTS


This resolved my issue all my issues related to fingerprint

20.04.4 LTS just released, anyone tested it yet?

I have confirmed that 20.04.4 LTS works smoothly out of the box. WiFi, fingerprint reader, and PSR all work with no manual workarounds required.


Are sure about this? It was necessary a few months ago when they updated to Linux 5.13. I guess I’ll try enabling it.

EDIT: Seems like it works. I don’t see tearing after enabling it. I guess something got update between the first release of the 5.13 kernel and now.

EDIT 2: Nevermind. I still got the same partial screen update artefact during alt-tabbing as before with PSR enabled just now. Will keep the workaround for now.

@nrp I saw the guide for Ubuntu 20.04 and it looks great except for the mic jack workaround.

A better practice for modifying the behavior of kernel modules is to add a file in /etc/modprobe.d/ instead of editing an existing file. Modifying package-installed files will trip the package manager upon package upgrades into asking the user for manually choosing what to do with that file. If the user is applying the workaround by “just following instructions”, chances are they won’t know what to do when the APT asks them what to do with alsa-base.conf later on. Adding a separate file avoids that and encapsulates all needed changes into its own, hopefully well named file. Upgrades are easy and so is removal as it boils down to deleting the file.

That and also I think (almost certain but it wouldn’t hurt to double-check) the user has to run update-initramfs -u once they touch anything in /etc/modprobe.d/ as that needs to be backed in the initramfs.

I tried to comment there but my community login didn’t work.


Does 20.04.4 also “just work” when starting from Ubuntu Server as a base?

I’m still seeing tearing having added i915.enable_psr=0 to my kernel params. I actually thought it was fixed until I started scrolling this page, then I could see it again! I’m on Ubuntu 20.04.4 (batch 9 laptop), Linux dove 5.13.0-37-generic #42~20.04.1-Ubuntu

The only other thing I’ve found doesn’t work is sound through HDMI. And (minor issue) I disabled the light sensor as it seemed to keep making minor adjustments that I perceived as flicker.

Thanks, interested in Ubuntu 20.04 instead of later version since some features in Ubuntu 20.04 is good for me (for example, Firefox driver version).
As for the guide ,

Tried to create an account and then guess have to wait at least a couple of hours before continue.

We really want folks on 22.04.3 with the OEM C kernel as we need to laser focus our support efforts.

If you need this specifically, tag me here and I will send you the PDF of of the doc in a DM.

Note: Any support will be redirected at using 22.04.3 as we do not test against this release any longer.