[RESPONDED] Ubuntu 22.04 on the Framework Laptop 13

I had noticed that setting because I’ve had a laptop in the past that had a BIOS setting for whether the Fn keys act as Fn or media keys by default, so I thought to check for a similar setting here. That cntrl - Fn setting just switches the fn button with the ctrl button that’s next to it to simulate the layout of other keyboards. Has no effect in this case.

2 Likes

Don’t know how this happened, but after trying a few other distros with the same results and coming back to Ubuntu, fn lock works now?

1 Like

I can’t get my fingerprint reader to work. Does anyone have the same issue?

systemctl status fprintd:

● fprintd.service - Fingerprint Authentication Daemon
     Loaded: loaded (/lib/systemd/system/fprintd.service; static)
     Active: active (running) since Wed 2022-12-07 10:52:58 CET; 10s ago
       Docs: man:fprintd(1)
   Main PID: 54020 (fprintd)
      Tasks: 6 (limit: 38089)
     Memory: 1.7M
        CPU: 75ms
     CGroup: /system.slice/fprintd.service
             └─54020 /usr/libexec/fprintd

Dez 07 10:52:57 vanguard systemd[1]: Starting Fingerprint Authentication Daemon...
Dez 07 10:52:58 vanguard systemd[1]: Started Fingerprint Authentication Daemon.
Dez 07 10:52:58 vanguard fprintd[54020]: libusb: error [udev_hotplug_event] ignoring udev action change
Dez 07 10:52:58 vanguard fprintd[54020]: libusb: error [udev_hotplug_event] ignoring udev action change

And the syslog says:

Nov 14 10:39:58 vanguard systemd[1]: Starting Fingerprint Authentication Daemon...
Nov 14 10:39:58 vanguard kernel: [  663.357249] usb 3-9: reset full-speed USB device number 4 using xhci_hcd
Nov 14 10:39:58 vanguard dbus-daemon[952]: [system] Successfully activated service 'net.reactivated.Fprint'
Nov 14 10:39:58 vanguard systemd[1]: Started Fingerprint Authentication Daemon.
Nov 14 10:39:58 vanguard fprintd[7236]: libusb: error [udev_hotplug_event] ignoring udev action change
Nov 14 10:39:58 vanguard kernel: [  663.649311] usb 3-9: reset full-speed USB device number 4 using xhci_hcd
Nov 14 10:39:58 vanguard fprintd[7236]: message repeated 3 times: [ libusb: error [udev_hotplug_event] ignoring udev action change]
Nov 14 10:40:04 vanguard gnome-shell[7251]: polkit-agent-helper-1: pam_authenticate failed: Authentication failure
Nov 14 10:40:15 vanguard fprintd[7236]: parse fingerlist error
Nov 14 10:40:15 vanguard kernel: [  680.889743] traps: fprintd[7236] trap int3 ip:7f26d9448ccf sp:7ffd49bc6400 error:0 in libglib-2.0.so.0.7200.1[7f26d9409000+8f000]
Nov 14 10:40:16 vanguard systemd[1]: fprintd.service: Main process exited, code=dumped, status=5/TRAP
Nov 14 10:40:16 vanguard systemd[1]: fprintd.service: Failed with result 'core-dump'.

@Oliver_Guhr please try:

sudo apt --purge remove fprintd libpam-fprintd

reboot

then

sudo apt install fprintd libpam-fprintd

I just got my laptop and installed Kubuntu 22.04. I ran sudo apt update and sudo apt upgrade with Ethernet but I don’t appear to have any Wi-Fi connections available. lshw -C network shows Wi-Fi though:

  *-network                 
       description: Network controller
       product: Wi-Fi 6 AX210/AX211/AX411 160MHz
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:a6:00.0
       version: 1a
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: driver=iwlwifi latency=0
       resources: irq:16 memory:7a200000-7a203fff

Any ideas what’s going on?

You should check out this thread: [SOLVED] Getting wifi working on Ubuntu 22.04

I had something similar where I had to delete and maybe install some Intel WiFi FW files because the first one that the driver was loading was crashing the card. When things are good they look something like this:

$ sudo dmesg | grep iwlwifi
[    5.399950] iwlwifi 0000:a6:00.0: enabling device (0000 -> 0002)
[    5.405479] iwlwifi 0000:a6:00.0: Direct firmware load for iwlwifi-ty-a0-gf-a0-72.ucode failed with error -2
[    5.406543] iwlwifi 0000:a6:00.0: api flags index 2 larger than supported by driver
[    5.406560] iwlwifi 0000:a6:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 0.0.2.36
[    5.406957] iwlwifi 0000:a6:00.0: loaded firmware version 71.058653f6.0 ty-a0-gf-a0-71.ucode op_mode iwlmvm
[    5.537555] iwlwifi 0000:a6:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420
[    5.693982] iwlwifi 0000:a6:00.0: loaded PNVM version 05a8dfca
[    5.706141] iwlwifi 0000:a6:00.0: Detected RF GF, rfid=0x10d000
[    5.782111] iwlwifi 0000:a6:00.0: base HW address: 04:XX:XX:XX:XX:XX
[    5.802301] iwlwifi 0000:a6:00.0 wlp166s0: renamed from wlan0

Note: failing to load a FW is fine, the driver will just try the next one. But if the WiFi core crashes because of bad FW then it just dies.

Overhaul of the 22.04 guide.

1 Like

After significant fussing about I found that running apt install backport-iwlwifi-dkms got me a WiFi device that I could use. I’m not sure how that relates to the NetworkManager power saving stuff in the guide.

Something is definitely odd if you need that. Under very select circumstances, like what you experienced, it can help. And I’ll add it to the Ubuntu knowledge base troubleshooting article, I’ll do that next week.

Speaking exclusively for myself, I have never, ever run into a position where it was needed. I know others who have. I’ve been fortunate I suspect. :slight_smile:

What kinds of things might cause my issues, in your experience? I would hazard a guess it’s not the KDE bits of Kubuntu 22.04.

Hi, some feedback on the installation guide above. All good besides this line:

(echo "[connection]\nwifi.powersave = 2" | sudo tee /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf)

It broke NetworkManager. Removing it fixed the problem, but does this mean I can’t enable wifi powersaving?

Yeah about fell over yesterday when I found this. Formatting…ooof, fixed :slight_smile:

sudo apt update && sudo apt upgrade -y && sudo apt-get install linux-oem-22.04 && echo "options snd-hda-intel model=dell-headset-multi" | sudo tee -a /etc/modprobe.d/alsa-base.conf && gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']" && sudo sed -i 's/^GRUB_CMDLINE_LINUX_DEFAULT.*/GRUB_CMDLINE_LINUX_DEFAULT="quiet splash module_blacklist=hid_sensor_hub nvme.noacpi=1"/g' /etc/default/grub && sudo update-grub && echo "[connection] 
wifi.powersave = 2" | sudo tee /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Ah ok so it was just ‘wifi.powersave’ misspelled as ‘nwifi.powersave’? Sorry my linux knowledge is still only basic, but I don’t understand why you want to change this settings to ‘2’ to disable powersave, which is already on by default?

If it’s marked as 2 on your system, then it must have been set this way previously. On a vanilla 22.04 install, it is set to 3.

Hopefully that makes sense. :slight_smile:

Here is the guide specific to wifi troubleshooting, for the future.

These two files being modified in the official guide are owned by two dpkg packages:

~$ sudo dpkg -S /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf 
network-manager: /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
~$ sudo dpkg -S /etc/modprobe.d/alsa-base.conf 
alsa-base: /etc/modprobe.d/alsa-base.conf
~$ 

That means upon package update or system upgrade the user will be given a potentially scary message (for novices) that some config files have been modified, where it provides a a choice to install the package version, keep theirs, diff the files, etc. That stops the installation/update process without user input. Unless they merge the changes during this step, they’re at risk of either losing the workarounds or missing changes introduced from the new package versions.

@Matt_Hartley if you are involved in writing/editing the official guide, you might want to use the alternative - creating new files in the respective dirs with different names, not overlapping with the package provided ones.

4 Likes

I’ll take a look Monday. I’ve never had any issues as described. However, I’ll look into it. These are approaches used for sometime now, never, ever have I seen warnings or users reported warnings (outside of formatting when pasted).

I will look closer Monday, but as of right now, they’ll remain because they work and have survived countless updates.

Appreciate the heads up to investigate.

I still don’t understand why you’ve included this command to disable wifi powersaving in the installation guide. In the Wi-Fi Troubleshooting Guide, of course, but surely if you get new users to disable wifi powersaving as part of their Ubuntu installation they’re just needlessly losing out on some power saving, unless you think the wifi powersaving mode is not beneficial?

@Rising_Exurb I can tell you there are some issues around it that it throttles wifi-speeds to insanely low numbers, causing wifi-cards to not wake up correctly from sleep and alike.

Because Framework needs to ship something that works rather than being power-efficient it makes sense to do this by default.

1 Like

@Anachron interesting, thanks. I’ve never had issues with whatever wifi card comes with my i7-1280P but your explanation makes sense.

Happy to clarify - be cause the sheer number of times a clean installation has issues with wifi power savings. It’s fairly a well know Intel issue. Therefore, I opt to avoid the countless threads of folks who (and have) had issues with this. I want this bypassed out of the box. In the future, once I feel confident that this issue is resolved with Intel wifi, I will adjust accordingly.

Other Linux OEM vendors suggest the same because it is needed when using Intel wifi. Hopefully that explains why a little better.

1 Like