[RESPONDED] Ubuntu 22.04 on the Framework Laptop 13

Stranger and stranger. All devices but one that didn’t work yesterday work fine today. One is clearly a cable issue, and increasingly suspecting hardware in the others.

I had some similar intermittent USB port failure. Eventually one stopped working permanently. Motherboard warranty replacement fixed it.

1 Like

Interesting! In my case, six devices that worked under 21.10 no longer did under 22.04. The following day I tried again to make a backup, and discovered that moving the cable suddenly caused the device be recognized and mounted. Four of the other devices then worked flawlessly. One still stubbornly refuses. I’ll watch and wait. Thanks!

Has anyone else found that upgrading to 22.04 removes support for high resolution external TB3 monitors? I have an LG34WK95 with 5120x2160 resolution, and in 20.04 the resolution was detected and scaled correctly. Now in 22.04 it detects the monitor as 3440x1440, which makes for significantly blurrier text, and I can’t change it to the real resolution. I’ve tried some custom xrandr commands from Ubuntu forums-- no dice. I thought initially it might be the fault of the dock I was using, but the same thing happens if I plug the monitor directly into the laptop. Anyone know what might be going on?

Per last issue with a 5K2K monitor in 22.04: disabling Wayland fixes this, for some reason. With Xorg it detects the 5K2K resolution just fine. I don’t recall having to do this in 21.04, but in case anyone else encounters the same problem, try switching to Xorg.

Anyone having luck with the fingerprint scanner? I was using Windows previously, but wiped it and installed 22.04. Ubuntu sees the scanner, and would let me start registering a finger, but when I first put my finger on the scanner it reports having an issues reading the hardware.

I tried using the py script above to clear the fingerprints in the scanner, but it errored out, and I didn’t feel like digging.

Anybody else having similar issues?

Has anyone been having their laptop freeze and then go to a black screen? I’m getting “failed to write” / “read-only file system” errors. From some Googling, it looks like this is an issue with the SSD. I’m getting a new USB thumb drive delivered to boot Windows from it and run the Western Digital SSD Update tool to make sure it’s on the latest firmware.

Has anyone seen this or had luck getting it fixed?

Works here. :sweat_smile:

Almost certainly a hardware issue. It could be a motherboard or RAM too, start swapping out components till the problem disappears. SSD is probably the prime suspect.

I switched to Fedora to try a different distro… during installation, I found out my storage was completely full, which doesn’t make sense from how I was using my laptop. I re-installed Ubuntu and have not had any more crashes since… I’m keeping an eye on my storage to see if it explodes for any reason.

Anyone else noticing spontaneous restarts? I haven’t had this problem before but am now, the machine will just die and restart itself on its own. For me this pretty much coincides with switching to 22.04, but it could be unrelated. Obviously it could be a hardware problem but I just wanted to see if anyone else has had problems.

This is happening on AC power, and I’m pretty sure it’s not related to heat (this last time there was only maybe a minute before it dying and me checking temp sensors on restart, they read in the 40-50 C range). Over the last week or so I can get a couple days uptime only before it will die on me. But there’s really nothing in the way of logging since it’s just… dying.

Hello everyone. I know this post is mostly Linux/Ubuntu related, but I have been experimenting with using an eGPU on my framework since last summer and still haven’t found a good setup for my use case and wonder if anyone else here can point me in the right direction.

I currently have a 1060 card in a Sonnet Breakaway Box connected directly to my framework. There is a monitor connected to the card and I can get an image to display on that and use it as a secondary monitor most of the time (sometimes I need to restart to get things working etc). This I consider progress on 22.04!

When I query which is my primary card it reports nvidia, but my gfxinfo output reports I am still using Intel/Mesa as my OPENGL driver. I can confirm that games perform like they would on the intel graphics setup.

I have read that the nvidia drivers might be getting loaded too late? This is all on wayland so most of the documentation about xorg configs doesn’t apply.

Any help would be greatly appreciated as getting a dedicated GPU for gaming working is the last step to replacing my old machine totally with the framework.

Hi, i don’t know what is wrong but you need to enable external gpu in the nvidia panel to be able to use your E-GPU. I had some problems like yours before that and needed to restart with the e-gpu in to be able to use it. Now it can just launch steam or other launcher after connecting my egpu. I transitioned my laptop and desktop to ubuntu 22.04 from win 10 o 11 since a month or so and even not everything is shiny for now (learning curve …) it is looking good and a fresh restart !

After upgrade from 21.04, my fingerprint reader stopped working.

The symptoms were a delay to prompt for the password on login screens or su.
Also could observe as output of systemctl status fprintd

fprintd.service - Fingerprint Authentication Daemon
     Loaded: loaded (/lib/systemd/system/fprintd.service; static)
     Active: failed (Result: exit-code) since Sun 2022-06-12 19:24:40 EDT; 1min 32s ago
       Docs: man:fprintd(1)
    Process: 75076 ExecStart=/usr/libexec/fprintd (code=exited, status=127)
   Main PID: 75076 (code=exited, status=127)
        CPU: 109ms

Jun 12 19:24:40 stroustrup systemd[1]: Starting Fingerprint Authentication Daemon...
Jun 12 19:24:40 stroustrup fprintd[75076]: /usr/libexec/fprintd: symbol lookup error: /usr/libexec/fprintd: undefined symbol: fp_device_suspend_finish, version LIBFPRINT_2.0.0
Jun 12 19:24:40 stroustrup systemd[1]: fprintd.service: Main process exited, code=exited, status=127/n/a
Jun 12 19:24:40 stroustrup systemd[1]: fprintd.service: Failed with result 'exit-code'.
Jun 12 19:24:40 stroustrup systemd[1]: Failed to start Fingerprint Authentication Daemon.

The issue was that the manual install of fprint for 21.04 had left the old version shared library at /usr/local/lib/x86_64-linux-gnu/libfprint-2.so.2

Removing it and restarting the service with systemctl start fprintd

@John_Flatness
Did you do a clean install of 22.04 or an upgrade? For me I’ve had 22.04 installed since the beta release (clean install), and it’s been virtually faultless…

virtually faultless…
The one issue I’ve had, which I’m interested if any others have also on 22.04, is related to my external monitor. It’s a standard, few years old 22" monitor, which I’ve connected from HDMI port to DVI. Ubuntu doesn’t recognise that their is a monitor connected after I boot - I have to unplug and re-plug to get it to output to HDMI. If I’m away and run a session without the monitor (shutting down after), when I start up again with the monitor connected it shows up straight away. Similarly if I reboot Ubuntu during the day the monitor shows up after rebooting. It’s just when I’m working at my desk on consecutive days (which is most of the time), every morning I have to unplug and re-plug to get it to show up, which is a little annoying. Any one else experienced this?

Having exactly that, but only after resuming from deep sleep or hibernation, never on a fresh restart. Doing a fresh install didn’t change anything, so also suspect hardware (I have the WD_BLACK SN850 NVMe )…

I have not had any restarts, freezes, etc.

I should note that I installed, and following the guide from Framework. Everything worked fine then, but then because something was missing I thought i would use @lightrush’s script on it. So I ran that. I have the delay when resuming from standby, but that is it. I still have a sleep mode that sucks around 1-2% battery an hour, and that hibernates beautifully.

The machine works VERY well and is very stable. I also have the SN850 NVMe.

However, I am still not able to use the fingerprint scanner. I can’t clear the old scans out.

This is the errors I am getting:

● fprintd.service - Fingerprint Authentication Daemon
     Loaded: loaded (/lib/systemd/system/fprintd.service; static)
     Active: active (running) since Sat 2022-06-25 23:03:52 CEST; 1s ago
       Docs: man:fprintd(1)
   Main PID: 34196 (fprintd)
      Tasks: 6 (limit: 76783)
     Memory: 1.6M
        CPU: 160ms
     CGroup: /system.slice/fprintd.service
             └─34196 /usr/libexec/fprintd

Jun 25 23:03:51 frame010 systemd[1]: Starting Fingerprint Authentication Daemon...
Jun 25 23:03:52 frame010 fprintd[34196]: libusb: error [udev_hotplug_event] ignoring udev action change
Jun 25 23:03:52 frame010 systemd[1]: Started Fingerprint Authentication Daemon.
Jun 25 23:03:52 frame010 fprintd[34196]: libusb: error [udev_hotplug_event] ignoring udev action change

The same udev hotplug issue happens when trying to use the python script to clear out the saved fingerprint on the scanner.

Anyone have any ideas?

I am unable to complete the 22.04 installation as the software update that happens on re-booting keeps freezing. The first time it froze was when it was “configuring bash”. I had to do a hard reboot to try again. This time it has frozen at “Unpacking liblouis-data”.

When this freeze happens, all the icons on the left menu bar become the same - a grayed out terminal icon. I haven’t faced this issue in my earlier laptops. Any idea why this is happening? Thanks.

Look for a hardware problem. Memtest86, Prime95, swap SSD, etc.

1 Like