[RESPONDED] Ubuntu on FW13 AMD 7840

I tried multiple ubuntus on my FW13 AMD 7840 (order R877702109) and I failed to install or run it.

  1. Ubuntu 22.04.3:

Installation works but slow with multiple errors during installation. I cancelled installation and switched to live session: it gives me this error (cros_ec_lpcs.0: EC ID not detected).

  1. Ubuntu 22.04.2:

Is doesn’t boot at all with error: Verification failed:(0x1A) Security Violation. It asked me if I enroll Mok hash/key from disk but it still didn’t work.

  1. Ubuntu 23.10.1:

I tried a live session in safe graphics mode. It works but slow. I managed to install the OS, it would give me multiple errors during installation. After installation I can’t load OS, it gives me black screen instead of login.

  1. BIOS info:

image

Solution:

I updated BIOS from Ubuntu 23.10.1 live session from 0.0.3.2 to 0.0.3.3 (JFP30.03.03) and it worked. I was able to launch previously installed 23.10.1.

  1. I installed Ubuntu 22.04.03. It was slow and painful. I got cros_ec_lpcs.0: EC ID not detected error during boot and a black display (it worked after 1-2 minutes of idle).

So far I managed to configure almost everything except for fingerprint. And on boot I got these logs which is a little bit annoying:

Hi @Roman_Proskuryakov ,

Saw that you linked this thread to the other other thread with EC ID issue.
just clarifying, Installation went through after bios update, and the only issue remaining
is with fingerprint?

Hi!
I was able to install ubuntu after bios update, updated fingerprint update, it worked. But the issue with EC ID remains.

@Loell_Framework Not only I have kernel panics on startup sometimes, but graphics fail sometimes too. I had a blinking screen on login (after suspend), and now blinking screen when I tried to play Vampire Survivors.

Hi @Roman_Proskuryakov ,

This Feels like hardware issue already, kindly contact support at the bottom of this page