Slackware on the Framework Laptop

Congratulations on your choice and please enjoy your Linux journey!

I’ll be multi-booting with multiple distros myself on the Framework as I’ll be back to using Linux after a decade (currently I’m doing that on VMs). Though I already seem to boot mostly into Slack.

1 Like

Got my Framework dual booting Slackware and Windows 10. Disabled secure boot, and set TPM to hidden before installing Windows 10. After shrinking the Windows partition, booted the Slackware 15 USB flash drive and installed Slackware. The only problems that I had were caused by my lack of experience with UEFI and grub2.

I had to change a lot of default fonts, since the screen resolution is so much greater than my old laptop. Other than that, everything seems to be working.


Well, I am finally here and will post more details soon. I am experimenting with a plain old Slack single install (with secure boot turned off for now) and using Windows in a VM. Might have to switch to dual boot in case this doesn’t work out well.

I’ll post in details about what has worked and hasn’t shortly.


Here is an update:

  • Sleep: Setup “nvme.noacpi=1” kernel parameter for greater performance
  • Fingerprint reader: Install frpintd from SBO
  • Video and Audio: Hard cut off buttons while in calls
  • Bluetooth: Works well without audio drop-off after tweaking pipewire a bit
  • WiFi: Works well and connects to all networks, speed however is an issue (kernel 5.15.38)
  • Audio jack: Works without any glitches and issues

A few things to remember:

  1. Updating kernel: When you first update your kernel, please do make sure to you update initrd. If in case you miss this, you might get a “No kernel modules found for Linux X.X.XX”. In case you get this error, please follow the guide at Slackware docs, and what worked for me was the details provided by users on LinuxQestions.
  2. Enabling multilib: In case you need multilib support for Steam, Skype or VirtualBox, please do follow the wonderful guide at Slackware Docs.
  3. Wayland vs X11: Please note that Wayland is supported by default in Slackware (for KDE). However, a number of applications break and do not work well on Slackware. A consistent challenge for me was the overheating and power drain when I used video calling applications (Zoom, Discord, etc.). Most of these issues were resolved when I switched to xorg.

A more detailed version is available on my blog.


Another update I forgot to post, I am on Slackware Current (with the kernel 5.19.12) without any issues right now.

Edit: Spoke too soon! 5.19.11 is the working version. I have the same problem as others have reported with respect to 5.19.12

1 Like

Hey 5uie1, the link to your blog returns “Not Found”.

Also, I’m pretty sure (works for me) that the Skype at SBo (network/skypeforlinux) works fine on x86_64 i.e. multilib not required anymore.

1 Like

@Christoph_Willing Thank you for pointing it out. I had moved my blog and forgot to change the link: Here is the new link : Setting up the Framework Laptop

The SBo package for Skype works fine for me too.

1 Like

Have you been able to make the internal mic work?

@Christoph_Willing Yep, both the webcam and microphone work perfectly fine.

The hardware cutoff switches function as in indicated too, I’m able to cut power to them mid calls and switch them back on to resume audio and video.

Interesting. My camera is fine but I can’t make the built in microphone work without first adding the Sound Open Firmware stuff. I wonder if it’s because I’m running -current?

I am on current too and haven’t installed anything out of the ordinary. Do you want to hop over to the friendly “unofficial” Matrix server for Slackware where more experienced users might be able to help you?

The internal mic is working fine with that extra SOF firmware installed so I’m happy - just a bit interested why you don’t need it.

Since we’re both on -current, my new theory is that your system (according to your neofetch output above) is 11th Gen Intel i5-1135G7 whereas mine is 12th Gen Intel i5-1240P which (being newer - it arrived yesterday) needs the extra stuff. I have another laptop (Dell) which is also 12th Gen and it needs the same SOF firmware added.

Next question - you mentioned fprintd from SBo. I built it and it recognizes the device when I run fprintd-enroll - it says enroll-stage-passed whenever I touch the sensor. However nothing ends up in /var/lib/fprint, where I believe the data is supposed to be entered. When I run fprintd-list or fprintd-verify, they say:

found 1 devices
Device at /net/reactivated/Fprint/Device/0
Using device /net/reactivated/Fprint/Device/0
User chris has no fingers enrolled for Goodix MOC Fingerprint Sensor.

How are you making yours work?

1 Like

I missed that! Yes, that maybe the reason, but my understanding was that the other devices were the same.

I will check later today with respect to frpintd and respond.

@Christoph_Willing Apologies, was busy with work. So I checked the fprintd and it works fine for me. When you run fprintd-enroll does it ask for permissions to capture and write them? It asks me for permissions to do so and I can find the file too.

Fingerprints for user XXX on Goodix MOC Fingerprint Sensor (press):
 - #0: right-index-finger

Yes it asks for authentication which seems to succeed but enrolling ends with enroll-unknown-error as below:

chris@d10:~$ fprintd-enroll
Using device /net/reactivated/Fprint/Device/0
Enrolling right-index-finger finger.
Enroll result: enroll-unknown-error
ReleaseDevice failed: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying

The thing is that it didn’t always do that enroll-unknown-error. For quite a while it used to go through the enrollment and finish normally but -verify would fail and -list would show nothing; also /var/lib/fprintd is empty (I believe, from somewhere, that that is where the prints are stored).

It’s no big deal - not sure if I’d use it much anyway - just intrigued why it doesn’t work. I saw some other people had similar problems and having to reset the device somehow. I’ll chase them up when I have some time.