"slow charger"

When I plug a charger into my laptop I’m seeing a “slow charger” warning from Windows. This happens with both the stock charger, and an Anker USB-C PD charger. I’ve tried both USB-C expansion cards, and both sides of the laptop. It just started happening today. Any suggestions?

1 Like

A reboot fixed this.


I also encountered this notification, immediately after a reboot, while using the stock framework charger via a Baseus CAHUB-CV0G “8-in-1” USB-C docking station (USB-C (PD), 3x USB 3.0, HDMI, 1x GbE, and SD/TF).

Unfortunately it was right before an important meeting, so I had to frantically disconnect my USB-C dock and reconnect necessary peripherals so that I could continue (i.e., not an ideal time to troubleshoot). Now I can’t seem to use the dock at all without constant “slow charging” notifications and screen flashing on the HDMI monitor connected through it as the hub powers on and off. Plugging the charger directly into a USB-C expansion card resolves the issue. Unplugging various or all devices from the hub makes no difference.

Strangely, the same charger > USB-C dock combination had worked without issue for several days but now seems to be non-functional. I suspect that a Windows Update may have caused this…? Unless the hub has failed, which is also possible.

Could you check if the 3.03 BIOS changes the behavior? Public Beta Test: BIOS v3.03 + Driver Bundle 2021_08_31

We’re also coming up on a 3.04 release that has additional fixes around USB-PD.

1 Like

BIOS v3.03 and the new driver bundle seems to have resolved this issue. If it recurs I will report it here. Thanks!

Unfortunately, my USB-C dock has started to disconnect and connect again in Windows 10 as of today (it worked for a while, and then I was using Ubuntu for a few days, so unfortunately I don’t have a very consistent set of observations to report except that it’s not stable anymore).

A difference that’s immediately evident is that Windows isn’t reporting “slow charging” this time. However, the hub (including HDMI, 1GBe, and Framework PSU) are up and down repeatedly as before until I unplug the PSU from the hub, at which point it is seems to stabilize.

FWIW I’ve had this happen rarely and sporadically in my Dell Latitude and my desktop. A reboot fixed both instances and it hasn’t come up since.

1 Like

I’ll have to spend more time in Windows (rebooting into Windows, as well, instead of between OSs) to see if this is the case for me.

I wasn’t able to resolve the issue with my USB-C docking station repeatedly disconnecting via rebooting. I had been using my framework power supply. Switching to an Aukey power supply seems to have shown some promise in making things more stable… perhaps the framework supply is part of the problem.

Confirmed with a third charger that wattage is the issue here. 60W just isn’t enough to power both the laptop and my docking station without disconnects and “slow charger” warning.

  • 60W Framework PSU : fail
  • 65W Anker PSU (1x USB-C PD + 1x USB-A) : pass
  • 100W Anker PSU (USB-C PD) : pass

No problem, I’ll reserve the Framework PSU for lightweight travel applications.

I believe some, if not all, docks will reserve power for peripherals. The CalDigit TB4 Element hub has a 150W supply, but provides a maximum of 60W back to the upstream (host) device, 3x15W for downstream TB4, and 4x7.5W for USB 3.2G2. Leaving a reserve of about 15W for powering the dock.