[Solved - Clear fingerprint reader storage] Fingerprint reader problems

I’m having trouble enrolling fingerprints under Fedora after an OS reinstall.

I’m dual booting Fedora 36 and Windows 11, but I have never enrolled fingerprints under Windows, only under Fedora. My understanding is that fingerprint data is stored in data files by Fedora, but in the hardware itself by Windows. Is this correct?

Under my initial Fedora installation, I enrolled fingerprints and everything worked just fine, but I decided to disable that functionality as I was using the laptop with an external keyboard, mouse and monitor and having to reach over to the laptop to authenticate things was a little annoying. So, I used fprintd-delete to remove all stored fingerprints from Fedora.

I later wiped the SSD and reinstalled both operating systems, this time enabling LUKS encryption for the Fedora installation. I’ve been trying to set up fingerprint authentication again, but keep getting errors. The graphical fingerprint enrollment dialogue in GNOME settings just returns a “Failed to enroll new fingerprint” error. Attempting it at the comment line gives an ‘enroll-duplicate’ response:

[root@framework ~]# fprintd-enroll -f right-thumb jason
Using device /net/reactivated/Fprint/Device/0
Enrolling right-thumb finger.
Enroll result: enroll-duplicate

[root@framework ~]# fprintd-list jason
found 1 devices
Device at /net/reactivated/Fprint/Device/0
Using device /net/reactivated/Fprint/Device/0
User jason has no fingers enrolled for Goodix MOC Fingerprint Sensor.

If fprintd can’t see any enrolled fingerprints in its data files, and I’ve never enrolled any in the hardware under Windows, why am I seeing this ‘duplicate’ response?

Can anyone give me any pointers?

Try the script at Fingerprints not getting deleted from device? (#415) · Issues · libfprint / libfprint · GitLab

The script throws errors for me:

[jason@framework ~]$ sudo dnf list installed \*fprint\*
Installed Packages
fprintd.x86_64                        1.94.2-2.fc36                    @anaconda
fprintd-pam.x86_64                    1.94.2-2.fc36                    @anaconda
libfprint.x86_64                      1.94.4-1.fc36                    @updates

[jason@framework ~]$ sudo python3 clearprints.py 
<__gi__.FpiDeviceGoodixMoc object at 0x7ff4e92dfd00 (FpiDeviceGoodixMoc at 0x55d2b1c81130)>
libusb: error [udev_hotplug_event] ignoring udev action change
libusb: error [udev_hotplug_event] ignoring udev action change
libusb: error [udev_hotplug_event] ignoring udev action change
libusb: error [udev_hotplug_event] ignoring udev action change

(process:8155): libfprint-ERROR **: 15:33:34.507: parse fingerlist error
Trace/breakpoint trap

Others have had success with this script, which looks a little different:


That one worked fine, thank you very much!

I’ve been able to re-enroll some fingerprints now.