[SOLVED] Disable iGPU in BIOS?

Is there a way to disable the Intel Xe onboard graphics so I can use my Framework with only my eGPU, as detailed on this Intel page here? I couldn’t find an option to disable this in the BIOS.

If you’re wondering why someone would even want to do this, it’s because my eGPU currently lags on external displays right now from the Intel Xe trying to drive programs that I only want the eGPU to handle. (see my thread for more info)


Nevermind! I didn’t read the page closely enough. It turns out I can just go to Device Manager in Windows and disable it from there. BE SURE TO RE-ENABLE IT BEFORE DISCONNECTING YOUR EXTERNAL GPU!


1 Like

I don’t have an eGPU so this isn’t really relevant to me. However I wonder, can you set up a task in Windows Task Scheduler to reenable the iGPU when you disconnect your eGPU as a safety?

1 Like

Possibly! But I still wouldn’t want to be the one to test it if it goes wrong

1 Like

I’ve disconnected the eGPU before renabling the iGPU before :sweat_smile:. After a restart or two it kinda re-enables it and the laptop has worked fine since, but it is a pain when you forget

1 Like

AFAIK that is not what it does. That’s why there are plenty reports of choppy animations when using external monitors with a different refresh rate than the one connected to the iGPU.

To enable/disable the iGPU in Windows, you can install devcon ( choco install devcon.portable) then run devcon64 disable <device-id> (and devcon64 enable <device- id>).

PS: the solution to the choppy animation problem mentioned above is to disable then re-enable the iGPU using those commands.

1 Like

Sorry, misspoke again.

Y’all right, it doesn’t auto disable, but it should prefer the eGPU.

I’m on Windows 11 right now and it does a better job preferring the eGPU instead of iGPU. I forget that Windows 10 is iffy and @RandomUser & @Jean-Marc_Le_Roux are right, using devcon is a solid solution. So far with Win 11, DWM & explorer will switch over, but Google Chrome won’t.

Sorry again for the misinformation/confusion.

Also, in NVIDIA Control Panel, under 3D Settings > Manage 3D Settings > Global Settings > Power management mode: Prefer maximum performance, if you haven’t seen that part.

I have been working on a PowerShell script that listens to some WMI events to call devcon and disable/enable the iGPU whenever the eGPU is plugged in. But I haven’t done much testing yet:

It’s fairly generic so it can run any PowerShell script when any PnP device gets plugged in.