[SOLVED] GPU driver apt upgrade failing

Starting yesterday my DIY Gen 11 Framework running Pop!OS 22.04 started failing sudo apt upgrade. When I try to upgrade packages I get failures on i965-va-driver & i965-va-driver:i386. I tried looking these up and they seem to be hardware specific dependencies for all of the other packages waiting to be upgraded. Here’s the full output:

$ sudo apt upgrade -y
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libalgorithm-diff-xs-perl libb-hooks-op-check-perl libclass-c3-xs-perl
  libclass-xsaccessor-perl libclone-perl libdevel-callchecker-perl
  libdevel-caller-perl libdevel-lexalias-perl libfile-fcntllock-perl
  libjpeg-turbo-progs libjson-xs-perl liblocale-gettext-perl libnet-dbus-perl
  libpackage-stash-xs-perl libpadwalker-perl libparams-classify-perl
  libparams-util-perl libref-util-xs-perl libsub-identify-perl
  libsub-name-perl libtext-charwidth-perl libtext-iconv-perl
  libunicode-linebreak-perl libvariable-magic-perl libxstring-perl
  python3-brotli python3-systemd
The following packages will be upgraded:
  i965-va-driver i965-va-driver:i386
2 upgraded, 0 newly installed, 0 to remove and 27 not upgraded.
Need to get 0 B/632 kB of archives.
After this operation, 20.5 kB disk space will be freed.
(Reading database ... 336785 files and directories currently installed.)
Preparing to unpack .../i965-va-driver_2.4.1+dfsg1-1_amd64.deb ...
Unpacking i965-va-driver:amd64 (2.4.1+dfsg1-1) over (2.4.1+dfsg1-1) ...
dpkg: error processing archive /var/cache/apt/archives/i965-va-driver_2.4.1+dfsg
1-1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/i965-va-driver/changelog.Debian.gz',
 which is different from other instances of package i965-va-driver:amd64
Preparing to unpack .../i965-va-driver_2.4.1+dfsg1-1_i386.deb ...
Unpacking i965-va-driver:i386 (2.4.1+dfsg1-1) over (2.4.1+dfsg1-1) ...
dpkg: error processing archive /var/cache/apt/archives/i965-va-driver_2.4.1+dfsg
1-1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/i965-va-driver/changelog.Debian.gz',
 which is different from other instances of package i965-va-driver:i386
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried running sudo apt install -f and sudo dpkg --configure -a but neither fixed it and I wasn’t able to find other things to try from internet searches.

Hmm… maybe try that before installing:

$ sudo mv /usr/share/doc/i965-va-driver/changelog.Debian.gz ~/backup_va-driver_changelog.Debian.gz

That worked for installing the i965 drivers! The same packages as before are still being kept back but based on my internet searches this isn’t inherently a problem?

1 Like

If you remove the -y option in your call to apt-get, you will be prompted for confirmation before accepting its conflict resolution plan.
And iirc (I’m not on Debian based distros since several years now) if you reply N then it will iterate to the next solution, possibly upgrading the packages that the first solution plan was keeping back.

Hi @junefish , looks like @Mapleleaf awesome response, resolved your issue? is it okay to mark this as solved already?


1 Like

Nope, it just resolves with 0 upgraded, 27 kept back, but I’m okay with that. I’ll see if this persists for more than a couple days.

Yes, thanks!