[SOLVED] No post, no bios, no life

Just received my new Framework Laptop 16 (AMD Ryzen™ 7040 Series) and was pretty stoked. I’m very good with electronics so I bought the computer disassembled. I carefully assembled my laptop which Framework made fairly easy in their instructions. I plugged in the power supply, pressed the power on switch and waited for boot. I waited for about five minutes and started to worry so I turned off power.

I disassembled the laptop and checked my components. Everything looked good. I looked for any hanging connectors or physical damage and everything still looked good. I reassembled the laptop and turned it on…nothing. Just a dark screen (even took it into a dark room to see if the screen came on with backlight).

I checked to make sure the brightness level was not down to zero but still nothing on the screen. The power switch light is lit and the fans were running. I did purchase an HDMI expansion card so I connected a TV to it to see if I could get any video (this was a desperate attempt to troubleshoot but I was running out of ideas). I let the computer charge for about an hour (watched a Netflix show) and still nothing. I check the USB-C expansion card and the light is steady and white.

I am out of ideas. I couldn’t find the CPU and I didn’t want to start taking things apart looking for it, but it seems that it is dead or missing. Any other ideas or theories out there would be appreciated.

For the administrator: I did a search on this topic but couldn’t find anything useful.

1 Like

Hey Steve, not sure why you moved it back to Framework Laptop 16 Category but I think it belong under Community Support. This is the category for other community members to help you, alternatively you can contact our support team.

I thought it could be a FW16 thing. Moved it back.

I haven’t received mine yet, but I’ve seen some suggestions to try only one stick of memory, if you have two. Also, the first boot may take quite a while, as it’s scanning the memory (reports are that it can be longer than an hour, if the memory is particularly problematic, though most suggest twenty minutes tops).

If all else fails, there’s always Framework’s Support Team.

Thanks. Will try the one memory stick. In the cue for tech support.

1 Like

Update: removed one memory stick from laptop. Let the computer run connected to the power supply for two hours. No change in indication.

I think I am having the same problem as you with no signs of bios. I am getting a diagnostic code 0xC5 (bgbg ggbb for the led flashes) about 1 minute after power on. Are you getting the same code?

No flashes on the LED. Just dark unless power supply is connected, then stead white light.

I am happy to report that this issue has been solved thanks to Framework tech support guru Lex. Here are the steps Lex shared with me to get the CPU going:

  1. Turn off the laptop and disconnect charger.
  2. Remove all of the expansion cards (I kept the USB-C installed for charger purposes), RAMs (remove only channel 0), and SSD.
  3. Connect RAM to channel 1. Leave channel 0 empty.
  4. Reconnect the charger and turn on the laptop.
  5. Try connecting an external display to a compatible port and see if issue persists (I did not do this step).

Lex gave an extra step that reset the mainboard. This step is what I think fixed my problem.

  1. Plug the laptop into AC power.
  2. Open the main cover. (This requires the removal of the mouse pad and keyboard along with the metal plate to expose the hardware components).
  3. Press the chassis open switch (see attached picture for location) in the center of the mainboard ten times. NOTE: You must press it slowly by pressing for two seconds, release and wait for the red LED to blink and then press again for a total of ten times. Use the flat tip of the Framework tool.
  4. Press the power button to boot the system.
  5. BIOS settings will be reset to defaults.

NOTE: You should see flashing red LEDs when the chassis open switch is not pressed, otherwise you do not have power to the mainboard. The BIOS password reset will NOT work if the mainboard does not have power.


Note to administrator: tried to tag this post as [SOLVED] but the tag was not there.