(SOLVED, sort of)Touchpad Not Working Fully

Yeah, I’m able to right click with the two finger gesture. However clicking with the bottom right doesn’t work for right click. In fact with physical clicking it doesn’t seem to register anything at all, I only get the tactile click feeling. I’m afraid it might be a hardware issue.

There is a known issue around this (Known issues on early Framework Laptops). Could you reach out to Support so that we can trade you a new Input Cover? We’re trying to get more samples of this issue so that we can root cause and resolve it.


Absolutely! Thank you for the rapid responses. Really shows the team going the extra mile to bring the right product to market.

1 Like

Chiming in here. I recently got a new input cover as my old input cover had a short/burnt on the board and connector.

I’ve installed the necessary drivers via the driver bundle. Device manager looks good no discrepancies noted. I am running Windows 10 fully updated. At first, the touchpad wouldn’t recognize my taps in order to click or “right click” into a menu not until I followed the advice to turn off the ps/2 emulator in BIOS. Now all my gestures work fine. As for the tactile, none of that works at all. I’m sure I get a good “click” everything seems to work fine mechanically but the OS doesn’t seem to detect it at all. Any suggestions would be really appreciated.

This is potentially the same hardware issue. If you could contact Support for a new Input Cover, that would be best. We’ll ask for the one you have back to analyze it.

tl;dr I think this workaround doesn’t work for me™; (distro=manjaro)

@junaruga thanks for figuring things out - I’m not having success, Can you (or anyone) LMK if maybe I’m incorrectly summarizing the solution below thus far?

exact steps: file manipulations, source links, etc.

summary of temporary-workaround steps junaruga found:

  1. copy the file contents from the libinput patch to clipboard/wherever eg
$ cat > upstream-file <<EOF
# manually set file contents, to fix two-finger detection of touchpad
# taken from:
# - https://gitlab.freedesktop.org/libinput/libinput/-/merge_requests/665/diffs
# - per https://wayland.freedesktop.org/libinput/doc/latest/device-quirks.html#device-quirks-local
# - per https://community.frame.work/t/solved-sort-of-touchpad-not-working-fully/3512/25
[Framework Laptop Touchpad]
MatchName=PIXA3854:00 093A:0274 Touchpad
  1. sudo mkdir -p /etc/libinput
  2. sudo mv upstream-file /etc/libinput/local-overrides.quirks
  3. sudo systemctl reboot

Then, upon reboot, two-finger scroll/right-click just works? Or am I misunderstanding?

Total aside: interestingly pricedspacefan reports above Manjaro Xfce two-finger scroll works for them. No idea what’s different… maybe I’m hitting a hardware issue…

I had this issue but changing the PS2 mouse emulation setting as @Kieran_Levin suggested fixed it! Only had it for a day and so far its definitely the best laptop I’ve ever had.

The firm press thing from this guide fixed my problem, although I do seem to have to repeat the process every so often: My touchpad isn't working

Can we @Sensel and get them to collab w/ Framework for a high end trackpad experience.


Hm, just got my DIY laptop today and I seem to be having the same issue with not recognizing double taps or gestures. Just wondering if anyone has heard anything new? Turning off PS2 simulation makes it so my touchpad just doesn’t work at all, and I’ve installed the driver bundle multiple times. Device manager shows many uninstalled/unknown devices (a Base System Device, an SM Bus Controller, four PCI Devices, and five Unknown Devices) that Windows can’t install, and my only input shown is a PS2 mouse, no touchpad at all.

Help please! I otherwise love this laptop but this is really frustrating.

1 Like

An update! In case anyone else comes here with this issue, I was just dumb, and framework support helped me out. In short, I was using the wrong driver bundle. If you are on 12th gen, you need the bundle here: Framework Laptop BIOS and Driver Releases (12th Gen Intel® Core™). Many of the ‘latest software’ links still head to the 11th gen, and I wasn’t careful enough to notice the mismatch. Once installed, everything is perfect!