[SOLVED] Three finger gesture stopped woring in xcfe4

I’ve installed the frame.work (DIY edition) successfully with Debian testing in March. I’m using xfce4 as my default desktop. The touchpad was working as expected (for instance two finger scrolling gesture works nicely.) In the beginning also three finger gesture to emulate middle mouse button to paste X buffer was working for several weeks. Unfortunately it stopped working at some point in time. I can confirm that I did not touched my xfce4 configuration intentionally. I did not minded much since I intended to re-install the box from scratch since I needed a swap partition which I missed in the first install. I simply was hoping that everything would work again as in the beginning.
Unfortunately this was false hope - the three finger gesture which I’m using very frequently is not working under xfce4 … but it works under Gnome as I tried.
I compared with some other laptop which has also a Debian testing installation and the same xfce4 configuration. There everything is normal.
In summary: Three finger gesture works on the frame.work in principle since it works under Gnome. Three finger gesture works under xfce4 on a different laptop. I’m now wondering why it does not work under xfce4 on the frame.work.
Any help would be appreciated.

I can reproduce the (new / faulty) behavior with Debian Live installer

Someone added a config file to get their touchpad working properly on Debian in this post here:

Unfortunately the suggested method is not working for me / xfce4 as I mentioned in the according thread I dived deeper and I found something related to the framework laptop inside the installed libinput-bin version 1.20.1-1:

$ cat /usr/share/libinput/50-framework.quirks
[Framework Laptop Touchpad]
MatchName=PIXA3854:00 093A:0274 Touchpad

I have no idea about libinput and those quirks but it seems someone tried to adapt something for the framework laptop.
Any further ideas?
Kind regards, Andreas.

I’ve verified that three-finger middle-click-paste works as expected for me in i3. I haven’t messed with my X input settings since that other post.


  1. open xev from the terminal, make sure you can read the terminal as you do stuff to the xev window
  2. hover the mouse over xev - you should see a ton of mouse-move events scroll by
  3. one, two, and three-finger tap

You should expect to see “button 1” for one-finger, “button 3” for two-finger, and “button 2” for three-finger. That establishes whether X is getting the click events as expected, to help isolate where the issue is coming from

Hi Matt,
I think using xev is a good idea. Unfortunately none of the button events are shown there. I’ve tested under xfce4 (where the gesture not works) and Gnome (where the gesture works). I have no idea what this might mean.
Thanks for the idea anyway, Andreas.

I investigated a bit more into this and installed other desktop environments. The three finger gesture works for Gnome only. It does not work under LXDE and Cinamon - so here it is the same as for XFCE4. So the question is: In how far is doing Gnome things differently regarding gestures and how can I get the wanted behaviour also in other environments?
I also like to remind that in March with the same Debian testing installation things were working - but now even with the current Debian stable life installer it stopped working.
Any more ideas? Kind regards, Andreas.

By chance I learned that the solution is extremely easy. It just turns out that the paste function is not available as three finger gesture but simply press there where you would expect the middle mouse button - just in the lower middle of the touchpad. Very simple - you just need to know this.


Thanks for getting back on this thread @Andreas_Tille , this will come in handy with other xfce4 users who may face the same issue.