[ SOLVED] Touchpad sometimes starts sending endless "END" KeyCodes

I recently went from Ubuntu 22.04 to Kubuntu 23.04 and I’m experiencing some uh…weird behavior. This only happens when using the touchpad, not a connected mouse. Sometimes, usually if I click and two finger scroll at the same time, whatever window I’m in will begin to scroll down forever.

Eventually, using xev, I discovered that there were constant “END” KeyCodes being received until any keyboard button is pressed. Has anyone else had this experience? PS/2 Emulation is off in the BIOS.

Welcome to the community, Ilya_Kogan!

This is not expected behavior, may I get some background on this?

  • New issue after an update or another event?
  • Can you test this on a live USB - is the behavior present there as well?

hi @Ilya_Kogan ,

Just checking, have you tried executing dmesg on terminal and see if there are weird errors showing?


1 Like

Hi, thanks for the suggestions. I have been traveling so I haven’t been able to test this on other live distros yet. I can confirm I see nothing new in dmesg or the system journal when this happens.

I had been using Ubuntu 22.04 for years and had not experienced this issue. It started after installing Kubuntu 23.04. I think the live USB test is a good idea and I’ll do that for a few flavors and versions of Ubuntu. For reference, here’s my kernel version:

Linux Chislobog 6.2.0-27-generic #28-Ubuntu SMP PREEMPT_DYNAMIC Wed Jul 12 22:39:51 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux
1 Like

So, weirdly, this seems to have magically gone away. I did recently have cause to open the laptop up and unplug the touchpad and plug it back in. Perhaps a loose connection could have done something like this? I’m not sure how that would have resulted in the “end” character being sent forever but it’s also possible a package update fixed some kind of bug.

1 Like

Hi @Ilya_Kogan , thanks for updating the thread, I’m leaning into loose connection or hardware, as not seeing other issues like this elsewhere. Glad it’s working now, labeling this as resolved, thanks. :slight_smile: