The Power Adapter

I do love the direct mount or cord flexibility. The ground prong is available for the 90-130w 7.4mm and USB chargers.

I have one of the Dell bricks for my XPS 13 (replaced by my Framework), and it’s been pretty nice. I like the modularity of the Framework adapter too. It would be nice if it had a fold-away plug, but there are advantages of having a cord, as previously stated. That said, I picked up a stubby plug to replace the 3-prong cord for when I don’t need the extra length:


Not elegant, but takes up a little less space in my bag. I may yet go for an Anker Nano II for a little more compactness when traveling. We’ll see.

Here’s the one I bought:

I also just noticed that they have a right-angle one:

Not sure how I missed it the first time. Looks like it’s just the right size to make the brick sit flush(ish) against the socket when plugged in. I think I may grab one of those too and see how it works.

What I’d really like is something about the size of the Framework brick or the Anker, but with one or two additional quick charge ports. That way I could just travel with one charger for my computer, phone, tablet, e-reader, etc.


This short adapter also looks pretty interesting!


@Adam_Melancon Yep, that looks like a nice compromise. And there are other short options with flat plugs and such that could come in handy, depending on one’s use case.

1 Like

I’ve really been liking my Baseus GaN chargers, the 65w dual USB-C and USB-A is great for tight places and the 120w dual USB-C and USB-A is great if I have two 60w devices I need to charge. They are compact but not having the ability to have a cord to work with all sizes/orientations of power strips and outlets.

1 Like

I wanted a charger that could charge the Framework Laptop (60 W) and my Pixel 5 (18 W), both USB-C PD. I also wanted one with a longish detachable power cord, not a “wall wart” because I plug it into a power strip and a wall wart will take up several outlets. I found two nice possibilities:

Neat in that it can be used as a wall wart for travel but comes with a long power cord too.

Just about perfect and even comes with a USB-C cable.

In the end I opted for the official Framework charger, but I may change my mind.


I’ve used Nekteck in the past and they are pretty good, though I’ve had one die on me after a couple years of abuse as my night stand charger getting all sorts of things plugged into it.

1 Like

@RandomUser I like that. Looks like it’s only a little bigger than the Framework one too. My only hesitation is that Ravpower was pulled from Amazon for paying for reviews. Doesn’t mean it’s not good equipment, but it is a little concerning. Haven’t had any issues with it?

@Fraoch and @Ethan_Spoelstra Thanks for the other recommendations. Will check them out.

1 Like

I recently got UGREEN 100W USB C Multiport Charger - 4 Port USB Charging Station GaN Fast Charger Power Adapter.

Been happy with the brand in the past.

(Sorry, I don’t know how to attach the links the way others have been doing it.)

1 Like

With help from @Fraoch, I can now attach the link. Note that there is currently a coupon discount available. What I like about it is that it has 3 USB-C.


That looks really interesting @njf. Thanks for sharing it. Poking around, I found this novel option too:

USB-C (3) plus USB-A, 100W total, PD, and a pass-through AC plug that can be used to plug something else into, or stack a second one (or more) on top. They also have a 65W version that’s a little smaller, with only 3 ports (2 -C and 1 -A).

I don’t know much about the brand, but it could be worth checking out.

1 Like

So I did a little experimenting today. I have one of these power adapters on my desk, providing power to a few USB devices (monitor lamp, charging headphones, etc.):

Nice little unit. It also happens to have a 30W PD USB-C port on it, so I figured, why not see if it’ll charge my FW. Plugged it in and got a curious notification:


So it’s not charging the laptop. I wouldn’t expect to charge it fast, given the 30W output, but my understanding was that the FW should charge with a 30W adapater, based on @nrp’s note above:

and indeed down to a 15W adapter, based on @Kieran_Levin’s post on the USB-C charging thread:

Has anyone else run into this issue with a non-dedicated PD adapter (or any adapter for that matter)? Or am I missing some hidden audio functionality in my Anker power adapter? :upside_down_face:

1 Like

Since Volta came up. I am happy with the USB C cables and magnetic connector I use from them. Volta has this Indiegogo campaign happening these days (11 days left): GIGA: The Ultimate Universal GaN Charger | Indiegogo


@mvw would this note on the product page for your charger help?

“If a port is not working properly, it may be because your device’s internal safely switch has been toggled. To reset, unplug all cables (including the power cable) for 5 minutes and try again.”

1 Like

Great find! Hopefully this fixes it for him.

This was an issue with the older Volta XL cables too, which lead to a lot of replacements because they didn’t have a resettable fuse. I think I have 4 or 5 that even my low draw phone thinks is an audio device due to a MacBook or Chromebook or something drawing too much power or an off spec charger doing something funky. The newer Volta Spark has been much better but I haven’t tried abusing it with as many different chargers since the pandemic started.

1 Like

Thanks @Frosty. I hadn’t seen that before. Unfortunately, that doesn’t seem to have helped. I had the system shut down and unplugged overnight, and just tried again. Same error. Also, no charging light when it’s not powered on. I’ve also tried with each different port, and different USB-C expansion cards, to no avail. Oh, and I’m using the USB-C cable provided with the Framework.

The Framework charger continues to work just fine, of course. I wonder if there’s something weird with the Anker one. Maybe the PD implementation isn’t to spec? I’ll also have to find another USB-C to USB-C cable to try.

1 Like

So… reading comprehension fail. I blame lack of sleep due to two young kiddos. :slight_smile:

Anyway, I mistook what @Frosty quoted as pertaining to the Framework, and not to the charger. Just realized that mistake, and unplugged the charger for 5 minutes. Plugged it back in, hooked up the laptop, and, lo and behold, it’s charging. LED light came on, and when powered on it’s showing a charging status in Windows (albeit with a slow charging indicator, as expected due to the 30W limit on the Anker).

Mystery solved. I mean, mostly. Still don’t know why it was showing up as an audio device. Nevertheless, good to have an alternative for power when the laptop is on my desk.

Thanks for the help everyone.


Awesome! Glad it helped!


As a side question, what did Lenovo do to earn the coughs?

Possibly the fact that they invent a new docking connector every couple years and have also changed their power connector using non-barrel styles with different pinouts every couple of years as well.

Sure they were reversible… but I challenge you to try plugging in a barrel connector wrong in any orientation.