Thunderbolt support on AMD Ryzen

Does Thunderbolt 3 eGPU products work with USB4?

1 Like

From what I’ve heard some do, I have a Anker 777 dock and it works with usb4. But no eGPU to test myself.

Yep, should do. I will be testing it when mine arrives. Batch 3, still no payment taken.

USB4 sort of includes the Thunderbolt 3 standard, so except for weird compatibility issues between specific models, it should generally work.

How does this work with the Framework Laptop 13? I have one and just received my dock today. I am not receiving any display output over Thunderbolt (I have a Thunderbolt Dock G2 230W from HP), and am wondering if it is an issue with software on the laptop/firmware of the dock or a hardware issue.

Which expansion card are you using? Only the two back slots (near the screen) are Thunderbolt compatible. From the product specifications that docking station should be compatible with the display output of the Framework.

A USB-C expansion card with the following serial: FRACCKBZ01

I have a AMD Ryzen 5 7640U, but according to internet that should be Thunderbolt 3 capable. I have tried both left ports of my laptop on the dock, will try again with the right back ports as well - when I’m home this weekend.

I meant which of the 4 ports of the laptop. Only the the 2 near the back/screen are thunderbolt compatible on the AMD Framework 13, you don’t need to try the front slots.

1 Like

Ah, sorry, I think I tried the bottom ones. I’ll try the top ones tomorrow!

The back slots work, but I didn’t report back yet, because I have not gotten it fully working. Sometimes if I plug in my dock after being away for a while, it just does not work, the laptop freezes, and after a while when I unplug the dock because I see it’s not going to work, it instantly comes back and works flawlessly. Then, when I reboot, the dock works fine again. I have no clue what happens when it freezes, it’s about 60/40 if it freezes or works fine, but when I disconnect and reconnect without having the laptop sleep, it has never not worked so far. Running dmesg (I run Linux) shows a bunch of USB errors, but those also come up when I boot with the Thunderbolt cable plugged in, and then the dock works fine. I should get the differences between those logs (working and freezing) sometime…

I have a similar problem.
I put my notebook to hibernate and when I wake it up, most of the times I have to unplug the TB dock and connect it again to get it working.
Not really a huge problem. No bluescreens, everything is working.