[TRACKING] Fingerprint scanner compatibility with linux (ubuntu, fedora, etc)

@dkc Here you go


@Henry_Luengas Thanks so much for the guide! I am using Linux Mint 20.2 with Cinnamon. A couple of notes for anyone else doing the same:

sudo apt build-dep doesn’t work, but the build process will tell you which dependencies are missing. Manually install them with sudo apt install. debhelper-compat does not exist because it is provided by debhelper. After you’ve installed all the other dependencies, as well as making the other necessary modifications in the guide, append -d to the build command to force it to ignore the lack of debhelper-compat.

apt-source --download-only fprintd fails to locate a source package. Use curl -O http://ftp.debian.org/debian/pool/main/f/fprintd/fprintd_1.90.9-1.debian.tar.xz instead.

The Cinnamon user configuration doesn’t have fingerprint configuration in the GUI, but you can configure it from the CLI.
fprintd-enroll -f right-thumb (or right/left index,middle,ring,little finger). Note that it will take many passes to complete, so don’t worry when you see a lot of remove-and-retry messages.
sudo pam-auth-update and ensure that the Fingerprint option is selected.


No, @Alfonso_Lopez I don’t recall having to do anything extra to get fingerprint login working for sudo or for 1Password. I believe I downloaded directly from 1password.com: Best Password Manager for Linux | 1Password

I’m also having the “can’t enroll in Linux anymore after doing the ‘windows fix’” issue.

These were the steps I took:

  1. Installed Manjaro and enrolled right-index
  2. Reinstalled Manjaro and wasn’t able to enroll right-index again, but other fingers worked
  3. Installed Win10 and removed the WinBioDatabase (via Fingerprint enrollment)
  4. Installed dual boot Manjaro and started getting the errors noted above when trying to enroll for any finger

I’ve reinstalled windows all on it’s own and fingerprint enrollment/use works just fine. I’ve reinstalled just Manjaro and the errors persist. I’ve run the python script and gotten the errors mentioned above. I’ve pulled the script apart and tried various other methods on the FPrint device. I’ve tried from a live USB.

I’m at the point where I’ve been trying to find a datasheet for the Goodix fingerprint scanner to see if I can take it apart and wipe it’s memory somehow. Unfortunately, something I read somewhere implied that the firmware is stored in the same place… so that might just brick the chip.

It seems pretty likely that this is a gap in libfprint/fprintd since Win10 continues to function fine. Unfortunately I don’t have the time to dig into that code and figure out how it differs from the Win driver.

1 Like

@DylanCM Ditto. I’ve given up on this and just waiting for a major update to libfprint that hopefully fixes this issue. I’m also considering buying a new fingerprint reader once the Framework marketplace opens.

1 Like

Sorry to hear you guys can’t get your fingerprint readers working. In case anybody else comes here wondering what python script you are refering to, it deletes fingerprints held in the device’s memory but that weren’t registered on the current OS.

Here is a version I modified to require root privaleges, and only list the fingerprints if not given a -d flag:

To list the prints run:
sudo python3 libfprint_delete_device_prints.py

To delete them all run:
sudo python3 libfprint_delete_device_prints.py -d


Thank you! This helped me! It seemed to also delete a fingerprint that I had registered in my current OS installation, but I was able to re-register my right index finger fingerprint after running sudo libfprint_delete_device_prints.py -d, which I hadn’t been able to do before running your script. Thank you again.

1 Like

I can’t get this to run. It is complaining about not being able to find stuff

/home/committed88/Downloads/libfprint_delete_device_prints.py: 3: from: not found
/home/committed88/Downloads/libfprint_delete_device_prints.py: 6: from: not found
/home/committed88/Downloads/libfprint_delete_device_prints.py: 7: from: not found
/home/committed88/Downloads/libfprint_delete_device_prints.py: 10: Syntax error: word unexpected (expecting ")")


Looks like it’s missing the


at the top of the file.

Try running it directly with python

$> python3 libfprint_delete_device_prints.py

Yes that’s correct, I accidentally left python out of the command. You’ll need sudo as well:
sudo python3 libfprint_delete_device_prints.py

Thanks, even though I’m a software guy, I admittedly have not messed with Python in the slightest.

Now the output I’m getting is:

<gi.FpiDeviceGoodixMoc object at 0x7f043672a280 (FpiDeviceGoodixMoc at 0x1ada0a0)>
libusb: error [udev_hotplug_event] ignoring udev action change
libusb: error [udev_hotplug_event] ignoring udev action change
libusb: error [udev_hotplug_event] ignoring udev action change
libusb: error [udev_hotplug_event] ignoring udev action change

(process:117261): libfprint-ERROR **: 17:44:35.342: parse fingerlist error
Trace/breakpoint trap

I’ve been having issues getting the fingerprint reader to work under Ubuntu 21.04 with Windows installed as well and using the fingerprint reader.

My guess is that this has something to do with it as well.

1 Like

@2disbetter did you verify that you had the latest libfprint installed for your distro? You can get some of the package versions with sudo dpkg --get-selections | grep fprint.


what I compiled was 1.92 so I guess one of the recent updates bumped it up.

Anyway, should I try to roll the versions back?

If so, would someone be able to give me a hand with that? I’m pretty familiar with Linux but have never had a need to do any of this.

I got the fingerprint sensor to work on Ubuntu 21.04, but the sensor itself is very hot to the touch. Anyone else experiencing this?

@Shdenison which libfprint version are you on? There was a fix for the hot sensor issue in v1.94.0

@Henry_Luengas The link to your script times out, could you post it again/somewhere else? I’d like to give it a try but can’t access it.

Here’s a github repo:
It still seems to be up for me on the original webserver, can you tell me more about what error you’re getting?


@Henry_Luengas It shows me a “Page not found” error after around three minutes. Thank you for the repo! This script worked for me! I was able to delete several fingerprints that have persisted across installs. Thanks again.

Welp, this has gone highly pearshaped.

After following much of the great advice here, I managed to get fprintd built and installed. When I ran fprintd-enroll my terminal hung with no output, and I thought, sure, maybe I should restart first.

Well, the system now cannot be logged into, both in text mode and graphical mode, nothing shows up on the login page, I don’t even get a prompt to login in text mode.

Hard to do any debugging at this point, so I’m planning on wiping the machine (it was a new install anyway), but anyone have tips on how to recover from this, and also important, avoid it in the future?

1 Like


Oh wow. That sounds very bad.

I was going to try to get it working, now I think I’ll wait a bit.