[TRACKING] Fingerprint scanner compatibility with linux (ubuntu, fedora, etc)

By checking the meson build log (duh), I figured out why the build of fprintd is failing. It’s using “/usr/bin/pkg-config --modversion libfprint-2” to determine the version of libfprint that’s installed. So, basically, you can do whatever you want to the libfprint library, but meson is just going to look at which version was installed with apt-get.

I’m not sure how the build of fprintd could possibly work without some intermediate step that updates the libfprint package version information.

1 Like

I’ve just spent a bunch of time trying to get the build of fprintd working. I’m basically having to edit the various meson configuration files and google, google, google. Feels like whack-a-mole (work around one issue to have another immediately pop up.)

I’m just going to live with fprintd 1.90. Replacing only libfprint with 1.92 seems to do the trick. I’m not sure what I’m missing by not having an updated fprintd. The settings app lets you add fingerprints, so isn’t that enrollment, right there?

I found the fprintd’s CI case to test it with a libfprint compiled from the source on Fedora.

    # Make sure we don't build or link against the system libfprint
    - dnf remove -y libfprint-devel
    - git clone https://gitlab.freedesktop.org/libfprint/libfprint.git

So, in case of Ubuntu, removing the libfprint-2 development (header) files might be enough.

$ sudo apt remove libfprint-2-dev

I’m working on an updated version of the guide for Ubuntu 21.04 to do only what is necessary. I appreciate everyone’s feedback in this as I am new to this kind of thing.

I’m testing on a fresh install. I should have an update soon.


After some troubleshooting on a fresh install I found a lot of unnecessary steps. All that is needed is an installation of the new library and some packages.

sudo apt update
sudo apt upgrade
sudo apt install python3-venv python3-pip
sudo pip3 install meson libglib2.0-dev libgusb-dev libgrepository1.0-dev gtk-doc-tools libpolkit-gobject-1-dev libsystemd-dev libpam0g-dev libpam-wrapper libfprint-2-dev python3-pypamtest libxml2-utils libdbus-1-dev

Download the source code and edit meson_options.txt

wget https://gitlab.freedesktop.org/libfprint/libfprint/-/archive/v1.92.1/libfprint-v1.92.1.tar.gz
tar -xvzf libfprint-v1.92.1.tar.gz
cd libfprint-v1.92.1
nano meson_options.txt

Change driver value to “goodixmoc”

       description: 'Drivers to integrate, "default" selects the default set, "all" selects all drivers',
       type: 'string',
       value: 'goodixmoc')

Build the new library and install it.

meson builddir
ninja -C builddir install

Again, I am new to this. Your help would be much appreciated. But I did this and got it to work on a fresh install.


I appreciate your efforts on this greatly, and I am still having problems.

Yes, I have internet connectivity.
Is there something I should install from the application stores?

Current issues are with this line in your more recent post.

All of these after meson fail for me with a similar error
sudo pip3 install libglib2.0-dev
ERROR: Could not find a version that satisfies the requirement libglib2.0-dev
ERROR: No matching distribution found for libglib2.0-dev

meson fails and says it’s already installed from before.

1 Like

Hey @Davis_Ladd,

Thank you for writing your instructions! They were clear and concise; nice work :slight_smile:

I’ve edited them to add a few apt dependecies and some of the comments from this thread:


  • Apt packages git gettext valgrind (git isn’t on minimal installations, for example)
  • The feedback from @junaruga about using tagged versions on the two git clones).

I successfully compiled libfprint v1.92 on Ubuntu 21.04.


  • gtk-doc-tools
  • libfprint-2-dev
  • libgirepository1.0-dev
  • libgusb-dev
  • libpam-wrapper
  • libpam0g-dev
  • libpamtest0-dev
  • libpolkit-gobject-1-dev
  • libxml2-utils
  • python3-pip
  • python3-pypamtest
  • git
  • gettext
  • valgrind

pip packages, install with “pip install ‘package’”

  • meson installed with “sudo pip install meson”
  • ninja
  • gobject
  • python-dbusmock

1. Start with installing dependices

sudo apt install gtk-doc-tools libfprint-2-dev libgirepository1.0-dev libgusb-dev libpam-wrapper libpam0g-dev libpamtest0-dev libpolkit-gobject-1-dev libxml2-utils python3-pip python3-pypamtest git gettext valgrind

sudo pip install meson

pip install ninja gobject python-dbusmock

2. Compile newest version of libfprint

git clone https://gitlab.freedesktop.org/libfprint/libfprint.git
cd libfprint && git fetch origin && git checkout v1.92.1

3. Edit meson_options.txt

To make things easier I specified the just the goodix device in “meson_options.txt”

nano meson_options.txt

For the drivers option use replace default with goodixmoc. This compiles libfprint just for this fingerprint sensor.

       description: 'Drivers to integrate, "default" selects the default set, "all" selects all drivers',
       type: 'string',
       value: 'goodixmoc')

4. Then build, compile and install

meson builddir
ninja -C builddir

5. Now for the newest version of fprintd

git clone https://gitlab.freedesktop.org/libfprint/fprintd.git
cd fprintd && git fetch origin && git checkout v1.92.0
meson builddir
ninja -C builddir

6. Enroll your fingerprint


Alternatively one can do this from the “Settings > Users” screen in GNOME Settings.

I believe that is all the steps you need to do. If you have any problems let me know and I would be happy to help. This is the first time I have ever written instructions.

I’m new to this forum editor, so I wasn’t sure the best way to quote reply.

Ian C (he/him/his)


When I try to install a couple of the pipe packages, it can’t find suitable copies, same message as I mentioned before. Only two packages weren’t found.
libsystemd and libdbus-dev

Where does Ubuntu go to look for these things?

The first round, it didn’t find any to install?

Finally got everything installed, using a combination of above and correcting some user errors.

Got an enrollment finger and logged in.

Thank you all for providing instructions.

I also added install to the ninja -C builddir commands.

There is a lot to install, isn’t there.

I finally figured out my issue with the fingerprint reader. Since I think the issue was at the hardware/firmware level, I’m moving over here from the Fedora 34 thread.


  1. fingerprint reader was working fine in Ubuntu 21.04,
  2. replaced Ubuntu with Fedora 34
  3. couldn’t enroll my finger - every attempt ended with “enroll-unknown-error”
  4. discovered it was failing, because the sensor said it was already enrolled - it had never occurred to me to try enrolling one of my nine other fingers
  5. other fingers enroll fine

Here’s my original comment regarding the issue.

After finally figuring out how to get fprintd into debug mode (here, at the very bottom of the page), the problem seemed obvious.

Aug 08 20:15:49 fedora fprintd[10147]: [goodixmoc] SSM FP_ENROLL_NUM_STATES failed in state 2 with error: Finger is too similar to another>
Aug 08 20:15:49 fedora fprintd[10147]: [goodixmoc] FP_ENROLL_NUM_STATES completed with error: Finger is too similar to another, try use a >
Aug 08 20:15:49 fedora fprintd[10147]: Device reported enroll completion

As you can see above, I found out enroll was failing because the finger I was trying to enroll was already enrolled… but on a brand new Linux install???

This leads me to believe that my fingerprint from enrolling in Ubuntu is stored within the fingerprint reader (or TPM?), which prevented me from enrolling the same finger again.

I was able to enroll any other finger without a problem, but I still don’t know how to delete/unenroll my right index finger from the reader, or get the OS to recognize that it is already enrolled from a previous OS.

Also, in all my troubleshooting, at some point, the ability to enroll fingerprints in Gnome settings disappeared and I can’t figure out how to get it back! So I can enroll and verify with fprintd, but can’t get the OS to use it as an authentication option :man_facepalming:


My OS: pop!_os, which is using Ubuntu 21.04 kernel 5.11

I finally was able to get the fingerprint reader working after using a combination of all the guides on this page. However, on pop!_os, running fprintd-enroll didn’t work, until I installed libpam-fprintd.

sudo apt install libpam-fprintd


@Adrian_Sanabria very interesting issue! We’ll dig into that and see what the right way to unenroll fingerprints in Linux for this module is.


I finally had a chance to try this out and I followed @Ian_Cleary’s instructions and got the lib and the daemon to build without issues. However, fprintd doesn’t seem to be working correctly. Checking my user account in the Gnome settings shows me a grayed out option for fingerprint logins which disappears entirely after about 30 seconds. Running fprintd-enroll directly gives me an error after 25 seconds saying that it couldn’t connect to the service and timed out. Systemctl says that the fprintd module loaded, then immediately errored out, but I can’t tell what the underlying error was (“failed with result: ‘exit-code’”). The only thing that might be a useful error was the line “undefined symbol: fp_device_has_feature, version LIBFPRINT_2.0.0” which doesn’t give very meaningful results in Google. Any ideas?

I was able to get a fingerprint enrolled on Ubuntu 21.04 using the most recent instructions from Ian, except I had to also install libsystemd-dev and I had to add the install command at the end of the ninja commands so that libfprint and fprintd would get installed to /usr/local/


sudo apt install libsystemd-dev

and then for libfprint and fprintd:

ninja -C builddir install

Then, fprintd-enroll worked.


Have you figured anything out on this? I got myself into the same situation, same finger even. There is a “Clear TPM” checkbox in the BIOS Security screen, but it does not reset the fingerprint.


No, but I think the Framework folks are looking into it.


Okay, I tried building everything again from scratch, adding in @Ryan_Helinski’s comment about libsystemd-dev and this time watching the meson build output. I noticed during the build of libfprint that it seemed to be missing a reference to the Cairo graphics library, so I also added
sudo apt install libcairo-dev
as well. Built libfprint, built fprintd, and everything seems to be working as expected now.

1 Like

@R_L_Royall_Jr I also found that I did not have to install libfprint-2-dev. I have since also learned that other instructions recommend that you first remove the older, system-provided libfprint and fprintd with the command:

sudo apt purge --auto-remove fprintd libfprint-2-2

The new fprintd-* commands will still work with the system-provided software installed, but you might as well save some space and possible contention / confusion.

1 Like

I am having what looks like the same problem as some others have reported. I had successfully enrolled my right index finger and middle finger fingerprints on my first Fedora 34 respin install a few days ago. I reinstalled the exact same respin and got the error “Failed to enroll new fingerprint”. I was able to enroll some other fingerprints, so appears as if something is not cleared out on install. I repeated the experience with the respin that just came out today, August 16. After the successful enroll of a different fingerprint, I saw that a button for something like “Delete Fingerprints” appeared, so I tried that, hoping it would clear out the data that seems to be preventing me from being able to register my index or middle fingers on this fresh install. (edit: It did not resolve the problem.)

dnf info libfprint says I’ve got the following installed:

Version : 1.90.7
Release : 3.fc34

1 Like

I’ve solved the issue of the fingerprint option disappearing in Fedora34/Gnome40!

Found the solution here: https://www.reddit.com/r/Fedora/comments/oik8sq/need_help_setting_up_fingerprint_auth_in_fedora_34/h4xvrqv

In short, these three commands brought it back in the UI (though I still have no idea why it disappeared in the first place - something I did while troubleshooting fprintd)

$ sudo authselect current
$ sudo authselect enable-feature with-fingerprint
$ sudo authselect apply-changes

Note - this doesn’t fix any issues with fprintd or the fingerprint reader itself. At this point, I had verified that fprintd-enroll was working perfectly, I just didn’t have the UI integration piece working.


On Ubuntu 21.04, I just installed libfprint and fprintd v1.94.0 following a slightly modified version of @Ian_Cleary 's instructions. Instead of sudo pip install I installed python packages in a virtual environment. It worked no problem for libfprint 1.94.0. When installing fprintd, however, I was stuck with this error message, even though I had installed the dependencies including python3-pypamtest:
meson.build:134:8: ERROR: Problem encountered: Python3 module 'pypamtest' required by test suite not found

My workaround was to comment out this line in meson.build:
'pypamtest': get_option('pam')

1 Like

Has anyone succeeded in using fingerprint for things other than the login screen? e.g. sudo on the terminal, or other dialog boxes that ask for authentication?