[TRACKING] Fingerprint scanner compatibility with linux (ubuntu, fedora, etc)

Same results as @velovix - Worked like a charm on my 21.10 - didn’t even have to reboot. Thanks @imome9a !

This worked wonderfully on EndeavourOS, just had to change a few commands to the appropriate arch equivalents. Marvelous though, good stuff.

Thanks for sharing this. It worked perfectly for me (Ubuntu 21.10 with 5.16-rc4 kernel).

How did you manage to find it? Any searches I try come up blank [on duckduckgo / google and directly at launchpad.net].

1 Like

The library in question was libfprint so a simple “ubuntu+libfprint” brings up the launchpad links

What are the chances this binary or greater will be included in 22.04? Or should I hold onto this .deb?

Your script just saved my ass again @devyn_cairns. Sorry I will leave you alone and stop @ing you (and start @ing ing possibly, sorry ing). I uninstalled Ubuntu and forgot to wipe the print first (because I never really set up fingerprint authorization on there) and was able to wipe it from Pop OS. At first I thought it had stopped working but then I realized I just needed to be root.

I did a fresh install of Ubuntu Desktop 21.10 on the 20th of December (my Framework laptop is Batch 6 which uses the Goodix device – usbid is 27c6:609c). The packages for libfprint would part of the default installation:

fprintd/impish,now 1.90.9-1build1 amd64 [installed,automatic]
libfprint-2-2/impish-updates,now 1:1.90.7+git20210222+tod1-0ubuntu4~21.10.1 amd64 [installed,automatic]
libpam-fprintd/impish,now 1.90.9-1build1 amd64 [installed,automatic]

As I am testing both Ubuntu 21.10 and Pop!_OS 21.10 (on the NMVe and 1 TB Expansion Card), I manually typed “apt install libpam-fprintd” to have the package and all dependencies installed:

apt install libpam-fprintd
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
The following additional packages will be installed:
fprintd libfprint-2-2
The following NEW packages will be installed:
fprintd libfprint-2-2 libpam-fprintd
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 343 kB of archives.
After this operation, 1,422 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 Index of /ubuntu impish-updates/main amd64 libfprint-2-2 amd64 1:1.90.7+git20210222+tod1-0ubuntu4~21.10.1 [240 kB]
Get:2 Index of /ubuntu impish/main amd64 fprintd amd64 1.90.9-1build1 [89.3 kB]
Get:3 Index of /ubuntu impish/main amd64 libpam-fprintd amd64 1.90.9-1build1 [13.7 kB]
Fetched 343 kB in 0s (988 kB/s)
Selecting previously unselected package libfprint-2-2:amd64.
(Reading database … 232223 files and directories currently installed.)
Preparing to unpack …/libfprint-2-2_1%3a1.90.7+git20210222+tod1-0ubuntu4~21.10
.1_amd64.deb …
Unpacking libfprint-2-2:amd64 (1:1.90.7+git20210222+tod1-0ubuntu4~21.10.1) …
Selecting previously unselected package fprintd.
Preparing to unpack …/fprintd_1.90.9-1build1_amd64.deb …
Unpacking fprintd (1.90.9-1build1) …
Selecting previously unselected package libpam-fprintd:amd64.
Preparing to unpack …/libpam-fprintd_1.90.9-1build1_amd64.deb …
Unpacking libpam-fprintd:amd64 (1.90.9-1build1) …
Setting up libfprint-2-2:amd64 (1:1.90.7+git20210222+tod1-0ubuntu4~21.10.1) …
Setting up fprintd (1.90.9-1build1) …
fprintd.service is a disabled or a static unit, not starting it.
Setting up libpam-fprintd:amd64 (1.90.9-1build1) …
Processing triggers for man-db (2.9.4-2) …
Processing triggers for dbus (1.12.20-2ubuntu2) …
Processing triggers for udev (248.3-1ubuntu8pop0~1634223273~21.10~0f0b7aa) …
Processing triggers for libc-bin (2.34-0ubuntu3) …

After the install, I click into Settings > Users to enable the “Fingerprint Login”. Everything was working without any issue.

1 Like

I’m not even dual booting (Arch), but I had the exact same symptoms as other people here. Running this script fixed it immediately. Thank you so much!

1 Like

the ninja is giving me errors

1 Like

Super educational thread, especially @Christopher_McGee ’s notes about storing fingerprints.

Has anyone found an easy way to turn down the brightness on it? I run on .5 brightness, and that thing is a wee spotlight.

@nez - If you use ectool to set the power led color to blue (which it does not support displaying) it turns the led off.

1 Like

Problems editing post. Link here:

1 Like

Following your instructions on Xubuntu 21.10, I get the following error when running $meson builddir:
ERROR: Could not detect Ninja v1.8.2 or newer
Running the next command ($ninja -C builddir), I get this message:
Command 'ninja' not found, but can be installed with: sudo apt install ninja-build
Following this advice, and re-running $meson builddir I no longer get the former error and the ninja command also runs ok.

I just reformatted and reinstalled 21.10, including adding the updated fprint library. When I go to enroll my fingerprint, when I do the last touch it says it can’t reserve the device, it is already claimed by another service.
So I tried to run the python script to remove fingerprints (I had enrolled mine with the previous 21.10), and I get:

  sudo pytnon3 ./libfprint_delete_device_prints.py
  ValueError: Namespace FPrint not available

I have the following currently installed:

  fprintd/impish, now 1.90.9-1build1
  libfprint-2-2/now 1:1.94.1+tod1-0ubuntu2
  libpam-fprintd/impish,now 1.90.9-1build1

Anyone know what’s going on and how to fix it?

This appears to be a problem with the hardware stored fingerprints being carried over from one install of ubuntu to another, in some manner where one set of fingerprints obscures a previous set. If I try to enroll a previously un-registered finger, it registered it – sort of. But it didn’t recognize it for login.

Checking out the gitlab bug #415 @Bob_U pointed to, I discovered the “Namespace FPrint not available” error was a result of not having gir1.2-fprint-2.0 installed. Installing that allowed the delete script from #415 to run. However, when run, it listed only two fingerprints (I thought I had 3 registered at this point, right-index, right-middle, and right-ring), both right-middle. It deleted the two it seemed to know about, but it did not delete the right-index, as it didn’t seem to know about that one. When run again, it showed no fingerprints.

However, when I went to settings to enroll a new fingerprint, it showed a right-index-fingerprint, and the option to delete. So I clicked delete, and that seemed to work.

Subsequently, I was able to re-enroll my right-index.

1 Like

Dell XPS 9510 with ubuntu 21.10. Using updated fprint library, python script and installing gir1.2-fprint-2.0 worked for me, thank you all.

Hey all, Im running Kubuntu 21.10 and im following the walkthoughs in this thread but when i get to the build steps it seems ninja isnt quite working. i get the following error ninja: error: loading 'build.ninja': No such file or directory Im not sure where that file would come from what info needs to be included. or if there is an argument on the command im missing? any help would be much appreciated.

@Sam_Lane it looks like you saw a similar error, how did you resolve it?


I was able to get the ninja build to work by rebooting.

Howdy all,

Having an issue with the fingerprint reader in Manjaro XFCE minimal. Big thing is that fingerprint reader is seen by fprintd but not seen by fingerprint-gui. I have tried to use the fprintd setup here: fprint - ArchWiki however it is still not working. Could this be an issue with my greeter (lightdm-slick-greeter as recommended from another thread)?

$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 27c6:609c Shenzhen Goodix Technology Co.,Ltd. Goodix USB2.0 MISC
Bus 003 Device 002: ID 0bda:5634 Realtek Semiconductor Corp. Laptop Camera
Bus 003 Device 004: ID 8087:0032 Intel Corp. AX210 Bluetooth
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Hi! I am also getting the libfprint-ERROR: parse fingerlist error
are there any updates on a fix for the python script?

1 Like

@Declan_Li-Carney - the script in the post linked below works for me: