[TRACKING] Hard freezing on Fedora 36 with the new 12th gen system

I did experience some issues with gnome, but I think they are related to fractional scaling

@prepaidpyramid did you encounter problems with panel self-refresh disabled?

@ayhcheung I don’t know what is that. Can you explain me?

@prepaidpyramid have you tried adding the kernel boot argument I referred to earlier in this thread? (i915.enable_psr=0)

It would also help if you identified what distribution and version you’re running, as well as the kernel version.

I’m using arch linux with kernel 5.19.10

A post was split to a new topic: Hard freezing on Windows 11 on 12th gen system

Having the same kernel: [ 68.603405] i915 0000:00:02.0: [drm] *ERROR* Fault errors on pipe A: 0x00000080 Issue on void linux but only after resuming from hibernation. Interestingly the screen (window interactions) is still functional and the mouse is visible but everything else is black. Already tried enable_psr=0 as well as something else I found on the Arch wiki (enable_guc which is new in alderlake) but both didn’t change anything. I also tried unaccelerated rendering, this makes the screen flicker rather than black and it eventually recovers after reloading i3 a few times (same error messages though). Not sure why it’s happening though.

Restarting XOrg (in my case Blind Ctrl+Shift+e, click exit in i3) fixes the issue instantly so I’m assuming it’s a sync issue in the igpu.

1 Like

Fixed the issue by chance by setting i915.enable_fbc=0 in kernel parameters, so it seems framebuffer compression was the cause (at least in my case)


How did you validate that this addressed the issue?

Does it have any side-effect?

1 Like

Not sure if it fixes the original issue described, but it does fix *ERROR* Fault errors on pipe A: 0x00000080 being triggered, with the problems that seem to come with it (in my case black screen). Validated by hibernating (loginctl hibernate) and resuming from power-off, previously always triggering glitches or black screens; now hasn’t occurred after trying it a few times.

From the documentation it seems the only side-effect is that it can increase power consumption (by ~0.06 W) compared to compressed framebuffers (see arch wiki: Intel graphics - ArchWiki)


“options i915 enable_psr=0” is still looking good here. I just got done cranking away on a game with no issues. Not even a burp. My lap is super sweaty because the laptop is cooking! LOL!

I went back through journalctl to see if I could find any oddball graphics messages, but I haven’t seen any since changing this option.

1 Like

@James_Adams Pretty sure the DisplayPort adapter is the culprit. Removing it from my wife’s computer and putting one in mine switched around who’s computer was freezing. Then adding it back to her computer caused hers to also freeze again. I just took them out of both and we’ll see what happens.

@Paul_Sorensen – I tested that. It happens with DisplayPort, HDMI, or USB-C with dock

Still no more crashes. F36, KDE Plasma, Wayland.

1 Like

@Aggraxis could you explain how and where exactly you need to put that kernel command or addition? I have a i5 12th gen and I didn’t have that file in /etc/ that others have referenced and I’m not sure how to make that change to the kernel parameters.

I’m having hard freezing, screen stuttering, and mouse movements stuttering too.

1 Like

@Brendan Sure!
Type the following command in a terminal window:

sudo nano /etc/modprobe.d/i915.conf

The file may not exist, and so nano might be presenting you with a blank file. This is ok. Put in the following line:

options i915 enable_psr=0

I also have two other lines in mine because I was following several different guides. It is my understanding that these two values are already at their defaults for 12th gen based on the Arch wiki and other random Google results:

options i915 enable_guc=3
options i915 enable_fbc=1

Save the file (ctrl+x, follow the prompts).
Now that you’re back to the shell prompt we need to call dracut to incorporate your changes:

sudo dracut --force

It may take a few seconds. When it finishes (usually without output), reboot your system. At that point the changes should have taken effect. You can check for any i915-related messages since the current boot with journalctl:

sudo journalctl -b | grep i915

I hope that helps. Good luck!

–Edit: added sudo to dracut line.


Got more freez (mister). It happen to me very rarely mostely when I am on google meet video call, pushing the machine a little with many heavy apps and sharing windows.
I had it with Ubuntu mate 22.04 LTS kernel 5.18.x yesterday and this time it freezed two times, the mouse moves but the window manager is unresponsive. The video conferencing was somhow still there, at least the sound, the mouse was moving… It came back once…and then I had to hold the power button down to reboot and come back in the conference (I was organising!).
Other than video call;
I had another freeze just before opening a simple PDF wih no video call (but I was on the phone, it s asif it detect I really need it to not freeze !). I mention it because with my thinkpad E590 I never had such blocking of the wall desktop.

@Aggraxis Thank you! Awesome. I got it working quickly. I also have an open ticket with Framework Support. Hopefully, this helps.

1 Like

This seems to be a good workaround on NixOS for me.

I’ve followed the steps described by @Aggraxis - hopefully this’ll resolve the freezing issues. After setting the option, and then afterwards reading what it does (lol), I understand that it’s a power saving feature. Additional context from my situation is that I’ve followed the linux power-saving guide stickied somewhere else here… could this be the culprit?

1 Like