[TRACKING] Kworker stuck at near 100% CPU usage with Ubuntu 22.04

Happening on my device too: 13" 11th gen i5-1135G7 on BIOS version 3.17.

Unloading the xhci_pci module works, but the process appears again as soon as I load the module again.
Disconnecting the battery via BIOS for a few seconds fixes it temporarily, but it usually appears again after 1–2 days.

Hello! Any news about this issue? I have the same problem on a freshly installed kubuntu 22.04.3 LTS on a ASUS laptop with AMD Ryzen 9 7845HX and RTX 4060 GPU. Disabling the module xhci_pci works, but unfortunately in my case when I do this the keyboard becomes completely inactive. Is there a way to blacklist this module without disabling the keyboard?

What fixed the issue for me was to open up the case and unplug/replug the small motherboard pill battery. Hasn’t happened since upon connecting USB devices, which was a major trigger.

Other issues persist, like the floppy hinge of the screen (Framework dismissed this as pretty much me imagining it), and the mouse appears frozen at more or less every other time the laptop wakes up from deep sleep.

I have the early gen 11 laptop from 2021, I hope these issues aren’t affecting later ones, because frankly its both underwhelming (regarding support and their attitude to customers with actual problems) and embarrassing as a manufacturer.

have the same issue with kworker high CPU usage on Framework 13 AMD.

/sys/firmware/acpi/interrupts/gpe10:   98548     STS enabled     unmasked

Disabling gpe10 helps

echo "disable" > /sys/firmware/acpi/interrupts/gpe10

I just had this happen, out of nowhere one core was just pegged by a kworker thread and there was like 12W of battery draw (Laptop was just sitting there with 2 terminals open).

Disabling that interrupt got battery draw back to the 4ish W it was before.

Wonder what’s going on there, is that a bios bug?