[TRACKING] PPD v TLP for AMD Ryzen 7040

Nice! That release should hopefully come to rolling distros like OpenSUSE, Arch and OpenMandriva very soon.

I’ve put the update request in for Solus as well

Awesome! Out now for Arch as well

I can confirm a perceivable improvement in battery life with light usage on debian unstable (with power-profiles-daemon 0.2 and custom built 6.7.4 kernel with enabled CONFIG_AMD_PMF and CONFIG_AMDTEE) versus power-profiles-daemon 0.13-2 and kernel 6.6.15, with no apparent drawbacks in stability.

3 Likes

Great news, it includes M_L’s patches!

Woohoo! :raised_hands:

3 Likes

Hello, is there any official guide for this for the AMD 7040 13"?

1 Like

Check this out: https://github.com/FrameworkComputer/linux-docs/blob/main/Fedora39-amd-fw13.md

I’ve got another change for PPD I’ve prepared that I anticipate should squeeze a little more battery life out.

This tunes EPP values in the PPD balanced state based upon whether the system is on battery or not.

I’d appreciate some testing and affirmation it actually helps compared to PPD 0.20 behavior and doesn’t cause any noticable performance impacts:

8 Likes

Hello matias,
I am not using fedora, right now I am using tuxedOS

:heart:

This is exactly how I configured TLP and would make PPD “just work” in pretty much all cases.

IMO, it’s better than adding separate balanced-power/balanced-performance settings because, if I needed performance, I’d just switch to the balanced performance setting.

It would be nice to be able to specify some kind of battery threshold (e.g., >50% battery → balanced_power), but that’s not critical.

This can be achieved with some simple scripts that get called via udev.
The arch wiki has an example that uses a udev rule to hibernate the system, this rule can be adjusted to set ppd to balanced.
https://wiki.archlinux.org/title/Laptop#Hibernate_on_low_battery_level

Switching from balanced to power-saver, yes. Switching from balanced_performance to balanced_power, not without Introduce a 4th power state on the modern interface (!168) · Merge requests · upower / power-profiles-daemon · GitLab.

On the other hand, if I need performance while I’m on battery, I can just temporarily switch to performance.

Another big THANK YOU @Mario_Limonciello for constantly spending your time on this!

I had a long working day on battery and observed no noticeable impacts on performance or stability within my normal workloads.

I will do some tests the coming days and check if there is a measurable benefit on battery lifetime.

4 Likes

Sure! And thanks for testing it. I think this is the last improvement I expect until some kernel scheduler work that will happen later this year.

10 Likes

Is this kernel scheduler work public? If so, could you maybe give us a link to the overview?

1 Like

It hasn’t happened yet.

2 Likes

The link to Fedora bug tracker only mentions packages for Fedora 40 and 41. I am not familiar with Fedora backporting process so I was not sure which version I was on with Fedora 39. I ran

$ powerprofilesctl version
0.20

So it looks like backport indeed happened! :tada:

Hi Everyone! I just got my Framework 16 and I installed Ubuntu 24.04 daily build. Everything works great so far but PowerTop shows ~9 watt battery draw at idle. I’ve already installed the latest PPD from Mario, disabled Bluetooth and enabled Power Saver mode in the Gnome menu. What else do I need to do to get it down to 4 watts?

root $ powerprofilesctl list
  performance:
    CpuDriver:	amd_pstate
    PlatformDriver:	platform_profile
    Degraded:   no

  balanced:
    CpuDriver:	amd_pstate
    PlatformDriver:	platform_profile

* power-saver:
    CpuDriver:	amd_pstate
    PlatformDriver:	platform_profile

What terminal app are you looking at this from? Some terminal apps cause more power consumption. If you want to be entirely sure it’s not that you can check over ssh.

I don’t suggest you run on power saver mode day for day, balanced should be adequate.

Also you can turn the refresh rate down from 165 and brightness down, or instead pick up the patch I posted about VRR and enable VRR in gnome 46 or kde plasma.