[TRACKING] PPD v TLP for AMD Ryzen 7040

thanks for your work on this. My power draw is significantly better. I can watch youtube and temps are normal now :slight_smile:

1 Like

Tried to merge in this order with NixOS but still facing rejected hunks :frowning:

The nix config in the earlier reply works great.

Already tried it. The patches have changed since and now have conflicts.

The commit in 130 is also in 127/128/129. So you need to use merge not cherry pick. By using merge git figures it out and doesn’t apply the identical sha1 twice.

It’s been approved! Hopefully will get PPD v0.14 very soon with all these MRs included and now the new baseline for PPD.

Great job Mario!


I’m super excited about this, thanks for the notification!

Sorry if this is a noob question (I’m still relatively new to Linux). If we already installed the patch from Mario_Limonciello, will we have to remove the patch once the updates are integrated into PPD, or will it not matter?

Sorry for taking so long – when I looked at your post the day it was published, it said you had deleted it so I did not investigate further.
I just pushed an update to the PKGBUILD which should resolve this issue, allowing the package to be built again.

Once 0.14 is released you will have to install PPD from your distro’s repositories again, if you want to get all of the other changes this update will include (as well as future updates to PPD). In theory, if the current power consumption levels are satisfying to you, you could keep the package you have, but I would recommend against doing that.

Anyone else here running kernel 6.7 have their 6GHz wifi disabled (check iw list | grep -A15 Frequencies) on the AMD rz616 card? It was working on 6.6, but when I updated to 6.7 for better battery life (according to this thread), I can’t connect to wifi 6E anymore.

[Edit: figured it out, need to add disable_clc=1 to the mt7921_common kernel module, there was a lot of work on the wifi driver for 6.7]

There’s no problem! I deleted the post because I was reading the forum and I was convinced that I had done something wrong using AUR, but trying again I still had the same error, here I restored it.
Thanks again for the support.
I read that the patches have been accepted into the mainline now.

Hi Alex,

Just to confirm, the patches have been approved but are waiting for someone to merge into PPD. I think we are three steps away:

  1. Someone in the PPD team merges the MR’s that Mario created for this
  2. The PPD team make an updated release tag for v0.14 with these changes included
  3. Your distro of choice updates their repos with v0.14

Yes, I saw the details of merge on PPD git page.
Waiting for the Arch package (usually very fast to release) I’m going to update the 13.2 AUR package posted by @efindus.
Thanks to all.

I just installed the same .deb on Debian testing/sid. Joey Suri, how did you produce that summary?

That is “Energy” app part of KDE.

Installed the 0.13-2 from AUR; I noticed that the patches were ignored during the building process. Is this the normal behaviour?
Thanks again.

Yeah I had to revert to the old one (luckily I still had it built), there’s something wrong with it with the (presumably) updated PRs. I guess we can’t download the old PR patches?

That’s definitely not normal. Thanks for reporting!
I just changed the patch source to sidestep this issue and after triple-testing the build, everything should be fine now. Sorry for that.


Hi all,

Just to give a running commentary, the merge requests have been merged and now the final step is for an updated release tag of 0.14 for different distro’s to update their own repos with.

Kate did mention that she would create an updated release tag so not far away.