[TRACKING] USB port stopped working: over current condition

I’m not exactly sure what you mean here. If you purchased the laptop in Europe you should have a 2 year warranty (1 year better than the US). Unless you purchased it before it was available in your country (accepting all the risk of doing so) you should hopefully be able to reach out to support to ask for a replacement.

1 Like

Thank you, I have reached for support many times and so far I got nothing.

Have you ever gotten around to start a Live-ISO and see if that condition also occurs there as requested by Matt here?

If live-ISOs work, then something is clearly wrong with your installation. If they don’t that’s a sign of bad hardware and you should be able to request a new one, especially if it dragged out for months like you said and nothing rules out an hardware issue.

Hi Anachron, yes, I have live-booted the machine, to the same effect. First all fine, after a while the issue pops up.

Okay, do you use the Framework charger? Does this also happen when you are on battery?

Yes, I use the framework charger exclusively, even though I have other USB-C chargers sitting around, from Apple, that in principle I should be able to use. It is not even compulsory to buy the Framework charger, is it.

And yes this happens while on battery and while plugged to the charger.

This works on any combination of expansion port + usb c expansion card, right?

(Shuffling the power and mouse ports to see if it makes any change)

Yes, so far no difference which port gets power – plus the issue occurs in battery too. It might as well be a kernel issue, as posted here: [TRACKING] Kworker stuck at near 100% CPU usage with Ubuntu 22.04 - #28 by Albert_Cardona

I am also running Linux (Ubuntu 22.04) and have both the Kworker XHCI issue and just today noticed my left front USB port is no longer working on some devices. I normally keep the Type A adapter card in there. It’s delivering power ok, but some devices don’t respond at all. Both the framework SD card reader and a small USB one I have work ok still, but a USB device that enumerates as an ACM plays dead (it still gets power). Rebooting I see the following in my kernel buffer:

[  +0.132415] input: FRMW0001:00 32AC:0006 Wireless Radio Control as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-2/i2c-FRMW0001:00/0018:32AC:0006.0001/input/input5
[  +0.000166] input: FRMW0001:00 32AC:0006 Consumer Control as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-2/i2c-FRMW0001:00/0018:32AC:0006.0001/input/input6
[  +0.000101] hid-generic 0018:32AC:0006.0001: input,hidraw0: I2C HID v1.00 Device [FRMW0001:00 32AC:0006] on i2c-FRMW0001:00
[  +0.035330] input: PIXA3854:00 093A:0274 Mouse as /devices/pci0000:00/0000:00:15.3/i2c_designware.2/i2c-3/i2c-PIXA3854:00/0018:093A:0274.0002/input/input7
[  +0.000234] input: PIXA3854:00 093A:0274 Touchpad as /devices/pci0000:00/0000:00:15.3/i2c_designware.2/i2c-3/i2c-PIXA3854:00/0018:093A:0274.0002/input/input8
[  +0.000357] hid-generic 0018:093A:0274.0002: input,hidraw1: I2C HID v1.00 Mouse [PIXA3854:00 093A:0274] on i2c-PIXA3854:00
[  +0.035055] usb usb3-port4: over-current condition
[  +0.136107] usb usb3-port6: over-current condition
[  +0.127959] usb 3-9: new full-speed USB device number 2 using xhci_hcd
[  +0.114765] ish-hid {33AECD58-B679-4E54-9BD9-A04D34F0C226}: [hid-ish]: enum_devices_done OK, num_hid_devices=1
[  +0.002439] hid-generic 001F:8087:0AC2.0003: hidraw2: SENSOR HUB HID v2.00 Device [hid-ishtp 8087:0AC2] on 
[  +0.036426] usb 3-9: New USB device found, idVendor=27c6, idProduct=609c, bcdDevice= 1.00
[  +0.000006] usb 3-9: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  +0.000003] usb 3-9: Product: Goodix USB2.0 MISC
[  +0.000002] usb 3-9: Manufacturer: Goodix Technology Co., Ltd.
[  +0.000002] usb 3-9: SerialNumber: UID9E46B8F4_XXXX_MOC_B0

I am currently removing the xhci_pci driver on bootup to have any semblance of battery life. It does not affect any USB devices I normally use.

Any suggestions? Did I somehow lose a port on my mainboard? How can it be complaining of a over-current condition while still delivering power? (The OC error also exists even if the bay is empty)

As previously indicated and I realize it takes time because we have to gather information, issues like these need to be in a ticket.

  • Those with existing tickets, please continue through the process.
  • Those without tickets posting here, please create one.

I have just run into this issue myself. No software changes were made recently, and I was using the same cards I normally use, and suddenly both ports on the right side stopped working for anything besides storage devices.

Please see above so we can track it.

Ran into the same issue now (on my dad’s 11th gen) and opened a support ticket. Weird thing is that it seemingly happened overnight. Even disconnecting all cards the condition is still present and older kernels also don’t fix it. So either it is a hardware issue or some firmware update broke it? Anybody found a solution yet?

These are all long shots but worth a try.

  1. Power the machine off, disconnect it from power, let it sit for two minutes, then plug the charger back in and turn the machine on.

  2. Reset the bios to defaults

  3. Reset the mainboard. If you do this BE CAREFUL removing the RTC battery. Follow the directions, as the holder is extremely fragile.

Hopefully one of these helps. Good luck!

1 Like

I guess I can try those, when I visit my dad again. We already tried a long power off, but afaik it was only 30s with me holding the power button for that duration. Thanks!

I don’t fully understand the cause of the issue but I have a little routine that I do to get things working again which up till this point has been me just trying to repeat what I did the first time it happened where I opened up the computer to do a visual inspection but forgot to unplug it and saw the red lights flashing and when I put everything back together it did the thing where the screen stays black a little longer before it boots up and the ports started working again.

I’m definitely curious if just powering it off and unplugging for 2 minutes instead would fix the issue, though I’m almost certain that I’ve successfully performed my routine in less than two minutes and ended up with everything working though perhaps I’m wrong.

In my case removing the RTC battery or changing bios options has never been necessary. I also haven’t tried the 30 second power button hold.

1 Like

So apparently unplugging the battery did resolve the issue for now, thanks a lot everyone!

1 Like

Delighted to hear this. Everyone else affected, is unplugging the battery helping at all?

I just tried leaving my computer powered off and off the charger for 2 minutes and got my usb ports back (and the kernel worker to stop using so much cpu).

Though this overvoltage wasn’t random like most, I accidentally stuck a usbc plug in a standard usb port. Don’t think that would change anything but its not my place to assume.

Like I said, I have little specific knowledge about the hardware, was just sharing my approach up till this point. Also I never unplugged the battery, I was talking about unplugging the charger.


In case it helps anyone else, heres what happened to me:

Kubuntu 22.04
had the power cable for some headphones connected to a USB hub that was connected to my framework (this cable is a USB-A to magnetic POGO pin style connector). this was inconveniently close to my keys.

apparrently the magnet had gotten close to my keys and attached itself to something metal, shorting the two POGO pins and giving me over current messages in dmesg.

removing and replacing the USB A expansion cards seemed to be enough to fix the issue for me, no shutdown or battery removal needed apparrently not, still getting over current messages on boot and most external usb devices arent working.

Edit2: can confirm that unplugging the internal battery resolved the issue. sudo dmesg | grep current now shows nothing.