Ubuntu 20.04.4 LTS on the Framework Laptop

I just tried out 20.04.3 as well, and can confirm that WiFi did not work, and Bluetooth only partially worked. We recommend sticking with 21.04 for now, or using an older WiFi card instead of the AX210.

5 Likes

@ericgundrum Confirmed bluetooth working great! Has good distance and sounds great on Bose BT earbuds. Been listening to music for a few hours to ensure long term connectivity and it’s looking good. (21.04)

Thanks again!

1 Like

Hardware should be shipped to me in a few days.
I am no Linux Guru, but I think I am gonna give 20.04.3 a try with an older wireless card, assuming I have time I will fiddle with it.

Plan is to use an Intel 9560AC, (20ish dollar part form 2018 timeframe)
I don’t have any other wifi-6 capable hardware so I am not really missing out. I’ll let you all know how my little experiment goes.

1 Like

For the Linux Minters out there, if there are any others, from a baseline Mint xfce 20.2 with kernel 5.11.0-25, the apt update/upgrade today raises the linux-firmware version to 1.187.16. It seems to have a regression for the AX210 (noted in the Ubuntu bugtracker already https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1941044).

For now used timeshift to recover and am just holding this package back, and things seem to work OK.

2 Likes

It should be noted that Ubuntu 21.04 is using 5.11.0-31 and this works out of the box with wifi and bluetooth.

3 Likes

Yes, this allows the iwlwifi driver to load. It then seems to work OK on my 2.4GHz network but flickers on my 5GHz network.

The kernel bug thread for the 5GHz problem has someone suggesting that it’s a flawed AP to blame - updating the firmware on my router (a Netgear Nighthawk) has indeed seemed to fix this for me in that I can remain connected. Speeds are not great though.

I am using 20.04.3 on my framework laptop. I did not run the installer though - I had the drive ready installed from my desktop in preparation for the laptop arriving so I do not know if the installer would work.

It is necessary to move the /usr/lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm file aside for the ax210 wifi to work. As noted above I also had to update my router firmware to get the wifi to be stable - if you see the message “No beacon heard and the session protection is over already…” in dmesg, that’s how I fixed it.

I couldn’t initially log-in, possibly because it was trying an X desktop and I’d previously used the install with an nvidia GPU. Switching to wayland fixed that.

Bluetooth works fine for headphones. Also works with an xbox elite series 2 controller in steam (with the usual changes that requires).

Touchpad works in what I’d call semi-multitouch mode. I have multitouch scrolling but any number of finger clicks is interpreted as a left-button click except for the front-middle and front-right areas of the touchpad. I can get used to this I think. I have turned off PS/2 emulation in the bios but I don’t know if that helped anything as I didn’t try with it on.

Speakers work fine, volume hotkeys work fine, backlight hotkeys work fine, airplane mode and screenshot keys work fine, framework-logo key opens rhythmbox, media-transport keys all work fine.

I haven’t bothered to try and set up the fingerprint sensor.

I ran geekbench 5 and here are the results.

I’m using the i5-1135G7 DIY kit with the framework-supplied AX210 no vPro wifi card and the framework-supplied 2x8GB RAM kit. I used this SSD because of its low power-draw.

Overall, no complaints and certainly a nice upgrade from my previous machine (a 2015-era MacBook 12").

1 Like

Could you elaborate slightly? What do you mean by aside?

(My linux experience is very… One dimensional.)

I mean do what Random_User said here: Ubuntu 20.04.3 LTS on the Framework Laptop - #17 by RandomUser

2 Likes

This absolutely works, and from my perspective was quite easy. I don’t have any wifi6 hardware to do any real tests, but packages and other downloads seemed fine.

(my Bluetooth mouse (logi mxanywhere2) worked just fine as well.)

yup. I concur. Installing Ubuntu 20.04.3 was fairly easy. I ran the mentioned command and wifi started working right away with no other tweaks.

I’ve made some aesthetic changes to Ubuntu, but that’s it really. I’m glad that I just now got this laptop, as I’d much rather be running an LTS distribution.

2 Likes

Interesting. I’m using the i7-1165G7 DIY w/32GB RAM & non-vPro wifi. Here are my lappy’s Geekbench scores.

Maybe it is time to get LTS on mine. Just need to review this thread again to make sure I do all the post install stuff.

I would think Ubuntu LTS would be capable of similar results, especially with some assisted cooling going on.

After installing gnome-tweaks I have got multitouch right-click and middle-click working, which makes things even better.

Enabling deep sleep mode significantly improves battery life when the lid is shut. It can be done without a reboot:

echo deep | sudo tee /sys/power/mem_sleep

You do need to add mem_sleep_default=deep to the boot parameters to make the deep sleep behavior persist after a reboot. The machine does take noticeably longer to resume from deep as you might expect.

2 Likes

Thanks Phil! I originally wanted to use 20.04 on the Framwork, but at the time the solution was to compile and use a more current kernel. It is nice that we can use it with only minimal adjustment and have it full on working.

I noticed on Ubuntu 21.04 that resuming from deep also took some time. The time, I believe, is directly related to the amount of RAM you have installed. All in all I did not mind, as I had hibernation also enabled on a swap partition from the 250gb Module.

1 Like

Running Ubuntu 20.04.3
For 32gb I had a wake time of approx. 15 seconds (on battery)

I recall windows, at least back in the win 7 days, had a MASSIVE page file for the hibernation, which was a deal-breaker for me. How does the size of this file fair on Ubuntu?

1 Like

This is determined by the image_size kernel parameter:

https://www.kernel.org/doc/html/latest/admin-guide/pm/sleep-states.html?highlight=image_size#basic-sysfs-interfaces-for-system-suspend-and-hibernation

The Arch wiki covers this a bit:

Power management/Suspend and hibernate - ArchWiki

The default target size is 2/5 of physical RAM. For safety sake I would use at least half (or 16 GB in your case), and 2/3rds is safer yet (20 GB).

Personally, I allocated a swap partition matching the size of my physical RAM in order to allow for faster hibernation and resume.

1 Like

I’m trying to get hibernation to work (first on a test machine - if I can get it working there I may try to resize the encrypted partitions on my framework machine, or bite the bullet and start over, hoping not to have to do that now that I have things set up an running smoothly).

I’m still digging around but have had no luck so far. I have expansion cards that I can install an OS on to test this. I tried it with Manjaro and Fedora on a UFS card, but have yet properly to get the machine to hibernate. If I do figure out what I’m doing wrong I will write up a guide, because so far nothing I’ve found online and tried has resulted in any success.

Any and all pointers are welcome. Thanks!

Honestly, on Debian, I just set up a 16G swap partition (I have 16G of RAM), used blkid to get the UUID of the device, and then added:

resume=UUID=[UUID]

To my kernel params in /etc/default/grub. Then an update-grub and a reboot and it just worked (which frankly surprised me).

Of course, the Arch wiki, which I previously linked to, is as always pretty thorough on this topic.

2 Likes

that is the basics. Note, doing this with LUKs active is possible but is a bit more intricate. Making sure that your swap partition is also encrypted takes some work. So make sure to find the guides on it. I believe all of the ones for Ubuntu 18.04 are all still viable.