Using the AX210 with Linux on the Framework Laptop

everything is working well here on debian bookworm kernel version 5.15.0-3 including bluetooth and 150Mbps+ (fast.com test, so possible LAN is faster).

I’m dual booting Windows 11 and Fedora, I was having some problems with wifi not working in Fedora after rebooting from windows, what worked out was I had to turn off fast boot in Windows. link to a related article

Dang seems like I missed this thread

Has anyone seen the ax210 fail to come up with kernel 5.16 or 5.17?

I keep having to rmmod the iwlwifi kernel module, then modprobe it to get my WIFI to show up.

1 Like

The vPro version of this card is still crashing on Fedora and Arch for me. Arch, I have to restart iwd when coming back from sleep or booting up, where with Fedora, I had to manually remove some firmware to get the kernel to load a subpar (buggy, slow, etc.) version.

It works, just not well. I don’t see any activity upstream for this either.

1 Like

I don’t believe there is complete kernel support for the vPro version. I think the vPro requires some proprietary software for some of the features to work properly as well, for which I am not sure there is a Linux equivalent.

If you don’t need vPro for work, the non-Pro would be the way to go.

Did you manage to identify the issue? Wifi also refused to show up on my machine running Fedora 35 with kernel 5.16.20, and it turned out that I had to block firmware versions 67 and 66, which could be the same problem encountered here: https://bugs.archlinux.org/task/73387

My backup kernel 5.14.10 uses firmware 63 instead, and it works just fine.

If the issue persists, perhaps the information from running command “dmesg | grep iwlwifi” could help.

After tinkering with different firmware versions for my ax210 vpro I got stuck with version 62.
I tried different approaches to activate newer firmwares but to no avail, reloading iwlwifi module or restarts didn’t help.

Then after a complete shutdown I powered the framework on again and to my suprise the firmware 67 got loaded.
It could have been by accident but this was my observation. Maybe it helps others.

PS: DIY 1185G7, Fedora 35, latest Kernel 5.16.20.200

The community whatsit is telling me to review this thread and perhaps post here rather than create a new thread, so here it goes.

Received Framework i5 DIY kit late last year, purchased non-vPro ax210 wifi card with it. Installed ElementaryOS because reasons. I struggled with drivers initially but got the card to show up and connect reliably. After a while realized my download speeds were horrible, started troubleshooting. My access point told me the laptop had negotiated 6Mbps RX and upwards of 80Mbps TX(from laptop perspective). I thought maybe it was the AP since it’s old and off-brand, so I swapped it for my spare of the same make/model. Same issue. I bought new access points from Xyzel, full blown AX model APs. Still negotiating 6Mbps RX on the laptop. I installed Fedora to have a more supported operating system on the hardware, same issue, 6Mbps RX negotiated. I decided to hold off and wait a few months, let some new kernels release and new drivers drop. I’m now running kernel 5.18.9-200.fc36.x86_64 and had the same issue with 6Mbps RX. I decided to order a new wifi card, an AX200 to match that which is in my work laptop which negotiates in the upper 800Mbps on these access points. After installation, yum update, reboot, still negotiating to 6Mbps.

Sorry for the wall of text but I’ve been researching and reading for months and have not had any luck. Any help or ideas is much appreciated.

[REDACTED@framework ~]$ iw wlp170s0 link
Connected to b8:ec:a3:db:fc:5d (on wlp170s0)
	SSID: REDACTED
	freq: 5765
	RX: 8540 bytes (68 packets)
	TX: 9772 bytes (76 packets)
	signal: -57 dBm
	rx bitrate: 6.0 MBit/s
	tx bitrate: 245.0 MBit/s 80MHz HE-MCS 3 HE-NSS 2 HE-GI 2 HE-DCM 0

	bss flags:	short-slot-time
	dtim period:	1
	beacon int:	100

[REDACTED@framework ~]$ uname -r
5.18.9-200.fc36.x86_64

[REDACTED@framework ~]$ dmesg | grep iwlwifi
[   13.450806] iwlwifi 0000:aa:00.0: enabling device (0000 -> 0002)
[   13.461330] iwlwifi 0000:aa:00.0: Direct firmware load for iwlwifi-cc-a0-72.ucode failed with error -2
[   13.495251] iwlwifi 0000:aa:00.0: api flags index 2 larger than supported by driver
[   13.495262] iwlwifi 0000:aa:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 89.3.35.37
[   13.495473] iwlwifi 0000:aa:00.0: loaded firmware version 71.058653f6.0 cc-a0-71.ucode op_mode iwlmvm
[   13.623898] iwlwifi 0000:aa:00.0: Detected Intel(R) Wi-Fi 6 AX200 160MHz, REV=0x340
[   13.770140] iwlwifi 0000:aa:00.0: Detected RF HR B3, rfid=0x10a100
[   13.840346] iwlwifi 0000:aa:00.0: base HW address: 48:68:4a:ca:fd:9b
[   13.858869] iwlwifi 0000:aa:00.0 wlp170s0: renamed from wlan0
[  257.454881] iwlwifi 0000:aa:00.0: reached 20 old SN frames from b8:ec:a3:db:fc:5d on queue 8, stopping BA session on TID 0
[  257.952734] iwlwifi 0000:aa:00.0: reached 20 old SN frames from b8:ec:a3:db:fc:5d on queue 8, stopping BA session on TID 0

@Adam_Wilber

Worth a try on a different channel although I don’t expect that to change anything. Next/first thought: Antenna (connector, wiring) issue in the laptop?

Semi-useless example of one from me: AX210 non-vPro on Fedora 36 so

iwlwifi 0000:aa:00.0: loaded firmware version 71.058653f6.0 ty-a0-gf-a0-71.ucode op_mode iwlmvm
...
iwlwifi 0000:aa:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420

AP (Netgear Nighthawk X4S R7800 meaning ath10k WLAN, OpenWRT 19.07.10) configured only for 20MHz because Comcast sucks anyway, so why pollute the spectrum:

# iw dev wlan0 info
Interface wlan0
	ifindex 11
	wdev 0x2
	addr xx:xx:xx:xx:xx:xx
	ssid xxxx
	type AP
	wiphy 0
	channel 153 (5765 MHz), width: 20 MHz, center1: 5765 MHz
	txpower 30.00 dBm
	multicast TXQ:
		qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcol	tx-bytes	tx-packets
		0	0	76121	0	0	0	0	12231515		76122

From the framework side (several walls partially in between this and router):

$ iw wlp170s0 link
Connected to xx:xx:xx:xx:xx:xx (on wlp170s0)
	SSID: xxxx
	freq: 5765
	RX: 36582259 bytes (32875 packets)
	TX: 3940877 bytes (18771 packets)
	signal: -60 dBm
	rx bitrate: 130.0 MBit/s VHT-MCS 6 short GI VHT-NSS 2
	tx bitrate: 173.3 MBit/s VHT-MCS 8 short GI VHT-NSS 2

	bss flags:	short-slot-time
	dtim period:	2
	beacon int:	100

I don’t know if this helps:

$ iw wlp0s20f3 link
Connected to xx:xx:xx:xx:xx:xx (on wlp0s20f3)
	SSID: xxxxxxxx
	freq: 5745
	RX: 80841535 bytes (62278 packets)
	TX: 5146765 bytes (28965 packets)
	signal: -50 dBm
	rx bitrate: 866.7 MBit/s VHT-MCS 9 80MHz short GI VHT-NSS 2
	tx bitrate: 866.7 MBit/s VHT-MCS 9 80MHz short GI VHT-NSS 2

	bss flags:	short-slot-time
	dtim period:	3
	beacon int:	50
$ dmesg | grep iwlwifi
[   13.063042] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-QuZ-a0-hr-b0-72.ucode failed with error -2
[   13.101413] iwlwifi 0000:00:14.3: api flags index 2 larger than supported by driver
[   13.101428] iwlwifi 0000:00:14.3: TLV_FW_FSEQ_VERSION: FSEQ Version: 89.3.35.37
[   13.102944] iwlwifi 0000:00:14.3: loaded firmware version 71.058653f6.0 QuZ-a0-hr-b0-71.ucode op_mode iwlmvm
[   13.276206] iwlwifi 0000:00:14.3: Detected Intel(R) Wi-Fi 6 AX201 160MHz, REV=0x351
[   13.401349] iwlwifi 0000:00:14.3: Detected RF HR B5, rfid=0x10a100
[   13.468272] iwlwifi 0000:00:14.3: base HW address: xx:xx:xx:xx:xx:xx
[   13.486976] iwlwifi 0000:00:14.3 wlp0s20f3: renamed from wlan0

so it looks like my machine loaded the same firmware file as you did, but was happy to negotiate an excellent Rx speed. Perhaps it’s a hardware issue? Something wrong in the antenna or its connection? Perhaps (mild) antenna defects affect Rx more than Tx?

Are there some updates about how well (or not) the vPro wifi is supported with recent kernels (6.0) on the FrameWork?

Still issues? In particular with internet speed (compared to the non-vPro)?

Arch linux kernel 6.0.2 with AX210 non-vPro working as expected. I cannot comment on speeds as my primary router is acting up at the moment. Stable 450Mbps PHY connection to an older Wifi 5 R7000 router though. Hope this helps.

1 Like

Thanks, though I would like to know about the vPro version.
I already knew it works for the non-vPro, as I have one.