Windows 10 Installation Load Driver prompt preventing installation

I am using Ventoy to install the LTSC edition of Windows 10 (this is the version of Windows often installed on kiosks, etc. to avoid the bloat). This is an official Windows iso and I have successfully installed it on a Virtualbox guest on my Linux installation, so I have confirmed that the iso itself works.

During installation I am getting a prompt to browse for missing drivers on the installation of Windows 10. I know about the Framework driver bundle, but this is for post-install and the Windows installer does not understand the format of those drivers as one big .exe file.

I tried eliminating Ventoy from the picture, by using Unetbootin to “burn” the Windows iso to the USB drive, and I get one step further: to the partition editor, but upon attempting to use the default settings for a Windows installation it throws a generic error about not having a suitable Primary Partition.

The DIY installation guide references using the Windows 10 media creation tool, but this only prompts to give me an iso, not to actually have the exe that formats a USB drive. Furthermore, I don’t see an option to use the LTSC version which I would greatly prefer to the typical bloated Windows 10 install.

I tried live booting from Ventoy to Ubuntu and it worked fine. Since I was getting errors on the Primary Partition, I went ahead and used GParted from Ubuntu to reformat the primary partition as NTFS just to have a clean slate for my next attempt, but it was of no help.

I have the WD Black SN750 NVME SSD 1TB storage, and I am guessing that this is probably what is leading to the errors, but I don’t know for sure and I am running out of ideas. Any help would be appreciated.

More updates: I found a WD driver on MajorGeeks that was detected when I scanned from within the Windows 10 Installer, but they failed to install with no reason behind it.

I temporarily gave up on the LTSC edition of Windows 10 and downloaded the main iso from the official link here: Download Windows 10 Disc Image (ISO File). I get the same problem: “A Media Driver your computer needs is missing.”

Windows seems to be pretty shitty about basically forcing you to use the Media Creation Tool to burn a Windows installation disc/USB. Also, please don’t install random drivers — that’s a recipe for introducing malware.

As for installing Windows LTSC, you could try this guide (I guess Rufus might(?) work, but YMMV). It could also just be the case that Windows 10 LTSC just won’t work on this hardware (i.e. this hardware is too new for it), which could be possible (e.g. if the motherboard or CPU itself isn’t properly supported).

Thanks for the reply. This laptop is for my wife who needs Adobe software, but I don’t have any Windows computers. I’ve been scrapping by with a Virtual Machine that I made (with the LTSC edition) but I’m not sure why Framework specifically would not work for this. In this case, the non-LTSC edition fails the same way.

I am now using my Virtual Machine to use the media creation tool directly just to see if there is some magic sauce in that tool (which, like everything Microsoft does, I find infuriating).

Well, it states in the FAQ that the LTSC may not work on hardware that came out after the latest LTSC release. Then again, I have no idea when that was or whether that’s more of a general statement that usually doesn’t hold true. Regardless, something to think about.

Personally, I’d install vanilla Windows 10 and then debloat it using one of the many reputable tools out there.

[Edit] This might also shed some additional light on the matter, if indeed the problem is with storage (and if you were using your old LTSC ISO instead of an up-to-date one).

Looks like it is accepting a vanilla Windows install but only if that vanilla windows was from the Media Creation Tool. Personally, I am willing to fiddle around with manually installing drivers, etc. if it results in a better final result but it looks like whatever it is was producing problems.

I wonder if this issue could be resolved by merely bundling the Framework Driver pack as a zip file that I could unzip and put on a USB drive to browse for during install rather than an exe that depends on a completed install first.

Honestly? I don’t think it’s worth it. You can probably follow the guide I linked to disable telemetry and stuff after-the-fact (before connecting it to the Internet), which is presumably your main concern?

You can have Ventoy boot right off of the Virtualbox installation.

If other computers can do it, I think Framework laptops should too. You can never fully remove things the way that you can when you don’t put them on in the first place. That being said, I did go ahead and do vanilla Windows 10 Pro simply because I exhausted all the other options. It sounds like the real problem is that my iso of LTSC was not as current as the vanilla isos on the website AND that there is some magic sauce about the Media Creation Tool. I do hate Microsoft with a passion for this, but since its not my laptop and its to run Adobe I am gritting my teeth and trying to make it suck less.

I fully agree, but I also haven’t run Windows in over a decade at this point, so it’s hard for me to try to troubleshoot this haha :slight_smile: Mostly just going by other stuff I’ve seen on this forum, tbh.

Yeah, but it doesn’t particularly seem like LTSC actually helps with that? Then again, I’m not too well-versed in that, so it’s more of what I’ve gleaned from a cursory look at the description (and the fact that even the LTSC install guide I linked to has a “debloating” step afterwards, suggesting that there’s a lot of stuff that’s still installed by default).

That is my interpretation as well. It also seems really sketchy that you have to download the ISO from a random third-party site rather than being able to download it directly from Microsoft. If I had to run Windows, I’d probably take my chances with a regular install + debloater afterwards.

1 Like

Microsoft really does not want people installing the LTSC version because their business depends on spying on you, building advertising profiles, and eventually transitioning to digital identities. They only allow it because there are certain devices that really could not work that way and they really want that sweet licensing money, so they hide it in some enterprise level contracts. But you should really try a LTSC version on a VM because it is a night and day difference. Even after running a de-bloater there is tons of garbage. Long term I really want to transition my wife to Linux but in the short term she needs fewer transitions and she’s a professional with Adobe.

No thanks! I’ve been Windows-free for over a decade and I intend to keep it that way :wink:


I had that same error when installing Windows 11 during my last two installations. I found that if I got to that error, backed all the way out into the main menu, then tried to install again it would just work. Not sure why but it has happened twice now (with my Dell tower and my Framework Laptop).

This message can appear for a number of reasons unrelated to a missing driver. A common one is a version mismatch in the setup files. For example, if you applied a Setup DU such as KB5007402 to sources/ on the installation media, you also have to apply the same update to the Setup image inside sources/boot.wim:2. If you were not applying any updates, the files can just be missing or otherwise damaged.

I’d start by verifying the integrity of the image you’re installing from: make sure it is an unmodified one and that the checksum is what it should be.

If it still doesn’t work, I’d look at setuperr.log and setupact.log to see what’s actually going on. It’s not necessarily hardware-related, it can be many other things instead: that error message has been notoriously misleading.

Adding my voice to the chorus: when I used the Windows Media Creation Tool on another Windows machine here, it worked fine; other methods had similar errors to those described here.

Moral of the story: use the WMCT! It’s unfortunate, and hopefully there will be a better answer at some point (because it certainly used to work to do without it), but for now, it’s the one thing guaranteed to work.