XFCE certain program windows won't update until rescaled

Reposting from an earlier thread:

I am using endeavor with XFCE here, and it has driven me up a wall.
To keep it short:

No tip has extended the four hour battery life for me.

Certain programs, such as Obsidian, Discord, endeavor easy package install, will not redraw and will display a frozen image until the window border is changed in any way.

Certain icons for window borders and menus will be tiny for zero reason.

Scaling in general is broken and doesn’t cooperate with me.

Can someone please, please tell me what I’m doing wrong? I’ve tried two days worth of troubleshooting and absolutely nothing has fixed all of those issues.

Settings I have changed:

  1. Enabled the xhidpi theme
  2. Set custom DPI to the suggested 192
  3. Kept scaling as it is.

Things I have tried:

  • Searching journalctl [No discernible issues found.]
  • Enabling GUC via grub [No effect.]
  • Searching the arch wiki and google [Can’t find any mention of the issue at all.

So I fixed issue #2 by following 6.19 at Intel graphics - ArchWiki

Have no clue if this is going to negatively impact anything, but it worked.

The symptoms here look similar to this thread, although that one is specifically about Electron apps:

1 Like

Am on my try… thanks