XPG/ADATA S70 1T Not Detected

I bought this SSD to use in my DIY model of the framework. I’ve tried to install Fedora 35 and Linux mint with no success because neither distro can see the drive when I try to install. It’s like it doesn’t exist. I got it to show up temporarily on Fedora 34 but the install failed. I can also see the drive in the BIOS.

I tried another M.2 with a windows 10 image already on it and it seemed to work fine.

Does anyone have any ideas or suggestions? I really don’t want to have to send this drive back…

This is the drive I bought…


Do you have Secure Boot turned on in the BIOS?

1 Like

I’ve tried it turned on and off

Is it fresh out of the box and completely blank?

Can you see it in GParted Live? If so, wipe the MBR if it exists and make a GPT partition table. You may want to format the drive ext4, not sure if this step is necessary.

Then try to install Fedora or Linux Mint to it.


The drive was brand new at first. I tried formatting it to ntfs and installing windows but that also failed.

I booted up gparted and scanned for a long time before throwing this error.

Eventually it worked but the only drive found was my gparted boot drive. Nothing when I refresh.

I may give Windows a shot again tomorrow.

That drive is defective.

Reasoning: you can’t install any OS to it, Linux or Windows. GParted sees it since Linux assigns a drive designation to it (/dev/nvme0n1p1 which is normal) but can’t read or write to it, I/O error. The drive is not responding to read or write commands. That’s a hardware issue.

1 Like

Thanks for all your help

Worth a shot for sure!

So I tried a bunch of things including the rubber and everything suggested. I got it to show up in GParted somehow and did what was suggested. It still didn’t work (I didn’t know how great gparted was btw. I’ve just used diskpart on windows so thanks)

I tried using my m.2 reader with my windows desktop to try to update firmware because I saw that somewhere with no luck. I’m not sure if it has to be on the board for that.

I’m just gonna get a WD Black SN850 since I’ve never had issues with the brand and they’re about $160 right now for 1 Tb on Amazon.