Xubuntu 20.04 Trackpad and Suspend Works on Live Image but not Install

Recently installed Xubuntu 20.04. On the live image, the touchpad worked out of the box with PS2 emulation disabled (even right click and two-finger scroll). Suspending also worked fine.

The install has issues however:

  • The touchpad does not respond to any input whatsoever
  • Suspend now leaves a small horizontal bar (cursor?) in the upper-left corner, and does not turn off the backlight
  • Following resume, the graphical session does not respond to any mouse/keyboard input - except cursor movement. It is still somewhat responsive (unplugging the charger creates a notification) but the system only works from a tty

I have never had such different behavior between a live image and install. Has anyone encountered this or have recommendations to fix it?

1 Like

I noticed that while the live image ran kernel 5.8, the installed version was 5.4. In trying to upgrade, I broke networking and chose to re-install with Pop. Worked out of the box, as it auto-upgraded to 5.13 so I didn’t have to mess with WiFi.
I’m planning on fixing a few other issues with this guide: