11th Gen BIOS 3.09 Beta release

Anybody else having trouble with the EFI shell update? The USB device is not a boot option, tired 2 drives 2GB and 4GB. I had not trouble with previous upgrade 3.06-3.07.

Fedora 36. Ran the fwupdmgr command. No errors displayed, but still on BiOS 3.07. Tried from bootable USB drive - got an error and it dropped to a shell. SecureBoot is disabled in BIOS. DisableCapsuleUpdateOnDisk=true is configured in uefi_capsule.conf.

What else can I try?

Once in the boot selection menu (F12 right after restart), I had to re-insert my flash drive and it showed up.

1 Like

I have an interesting thing happening where the factory-shipped BIOS (on a replacement mainboard) is detected as version “774” by fwupdmgr, so it doesn’t want to do the update. The actual version (reported by dmidecode) seems to be 3.06, which would be in the usual versioning that’s used for these updates.

I can force it to update and ignore the version number, but just wanted to point out the oddity.

Thanks, I ended up using the Windows installer but confirm this “trick” worked.

I just got 3.09 installed via LVFS in Fedora 36, a couple notes:

It seems like I ran out of space on my 100MB EFI partition (as I have Fedora, Ubuntu, and Windows on the same drive) when fwupdmgr copied files over to it, which caused the installation to silently fail. My system rebooted without actually updating, and I only noticed when Fedora said something along the lines of “Warning: /EFI/boot/ is running out of space (64KB)”. That wasn’t the exact error message as I’m going off my memory.

I ended up resizing the partition to 500MB (please only do so if you know exactly what you’re doing as you can prevent your OS from booting if configured incorrectly). After that, it updated successfully.

I’m confirming that BIOS 3.09 seems to have fixed the issue on my end. I’ve linked to/added uninstallation steps for the udev rules and custom driver here.

Many thanks!


Forcing the update to allow “older” versions worked fine and the update seemed to go fine. Interestingly, the reported version is still “odd” in the same way, just updated: post-update, now fwupdmgr reports the firmware version as “777”.

Can you dm me the output of.
sudo dmidecode

1 Like

Success on a Fedora 36 only machine, 3.07 → 3.09 using fwupdmgr update and DisableCapsuleUpdateOnDisk=true.

Note/reminder that the update resets the battery charge threshold, F2 into settings to set back.

One fix I’m noticing is that my external monitor, connected via the HDMI expansion card, no longer seems to require an unplug/replug on cold boots to detect/wake up the monitor. I assume that’s part of changelog #9 and/or #10.

Also a Fedora 36 user, also used fwupdmgr witht that same config option set.

At first the update seems to have worked just fine. But it looks like all of my USB ports died. The only USB devices that still work are the internal ones (fingerprint reader, webcam). My microSD card reader, two external USB-A devices, and a 65W power supply seem to do exactly nothing. My USB-C power meter shows 5V and 0.00A with the 65W supply connected.

I haven’t tried any Thunderbolt or Displayport devices yet.

Should I try a mainboard reset? Or should I downgrade to 3.07?

Ubuntu 22.04 installation. Upgraded through fwupdmgr/LVFS work, no F3 needed.


  • There is a typo in the upgrade warning/mitigation:

[…] Press F3 during boot to manually select a desired boot entry after the update has completed it you run into this issue.

  • Had to re-apply my ec fan curve settings, is the ec upgraded / restarted during this procedure?
  • The first boot take a long time (memory learning? 64GB might not help here). Would have been nice to warn about that. A blank screen after BIOS upgrade is scary :sweat_smile:
  • The machine was really really hot after the upgrade, I think close to emergency off points. Partially my fault as I was doing this with the machine on the bed, thus lowering the airflow significantly. Is the CPU running at full clock speed during the whole upgrade?

Anyway, it worked! And frame.work shipping a new BIOS through LVFS is just great. Thank you for the hard work!

1 Like

Funny, LVFS didn’t work for me on Linux Mint 20.3. It didn’t indicate there were any new upgrades…?

The EFI shell update worked perfectly though.

Yes, I noticed that the fan was at full speed and it was getting hot.

I also noticed the long memory training and panicked a little.

But - all’s good!

Have to check the battery limit now.

fwupdmgr does some caching, so it may only tell you about the update in a few hours, possibly tomorrow. But you can tell it to check right now.

peter@raamwerk ~> sudo fwupdmgr refresh
Firmware metadata last refresh: 16 hours ago. Use --force to refresh again.
peter@raamwerk ~ [2]> sudo fwupdmgr refresh --force
Updating lvfs-testing
Downloading…             [    \                                  ]Updating lvfs
Downloading…             [***************************************]
Downloading…             [***************************************]
Downloading…             [***************************************]
Successfully downloaded new metadata: 2 local devices supported
peter@raamwerk ~> 

Also I fixed my USB port issues by doing a battery disconnect on uefi firmware, then connecting the power supply to one port on the left. This fixed both ports on the left. Then I repeated that with a port on the right side. Now all 4 ports are working again :slight_smile:

Still weird what happened though.


Yeao same with my Win dual Ubuntu, I’ve never heard the fan work so hard, but it wasn’t rattly just a bit disconcerting. Is a BIOS upgrade really that demanding, and long period of balck screen No No would be nice to have some clock at least

Another Fedora user here… I was on 3.0.7 and also lost all usb-c ports after the smooth upgrade to 3.0.9. Pulling the cmos battery seems to have fixed it up though…

@Peetz0r you might try pulling the cmos battery for a few and see if it clears things there too…

Seems common with BIOS updates, my other laptops and even my desktop does the same. I’m guessing the CPU frequency controls are rudimentary while in the BIOS.

I already fixed it, see my earlier reply. I guess both are valid methods to reset the USB PD or Thunderbolt controllers.

It’s not that it’s CPU demanding…it’s because the EC is being flashed. At that point. you’re left with no power management…safest bet is “Fan on”. This behaviour is common in many laptops.


fwupdmgr worked for me. Humming along and all things are good. Thanks Framework for the continued excellent work!


Noticed a typo in the 8254 clock gate option: