11th Gen BIOS 3.09 Beta release

It seems that I successfully upgraded the BIOS from 3.02 to 3.09 by LVFS. Though I see the left-ctrl - Fn key swap setting was reset.

$ sudo dmidecode -s bios-version
03.09

My environment is

  • Fedora 36
  • Kernel: 5.18.10-200.fc36.x86_64 (uname -r)
  • Window manager: Sway
  • fwupd version: 1.8.1 (rpm -qf /bin/fwupdmgr)
  • LUKS encryption - Yes. Maybe. The sudo cryptsetup -v status luks-XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX printed the /dev/mapper/luks-XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX is active.

Here are the detailed command log and photos: Upgrade BIOS from 3.02 to 3.09 on Fedora · junaruga/framework-laptop-config Wiki · GitHub. Hope it helps.

1 Like

image

It this BIOS update supposed to put Windows 11 into Test Mode? If so, how do I disable test mode?

It didn’t for me.
Test mode disables driver signature enforcement. To disable test more (and therefore require signed drivers), you can do this from the command prompt:

bcdedit /set testsigning off

The test mode message is kinda new to Windows and informs the user that driver signing enforcement is disabled. You’ve disabled driver signing in the past so that you could boot up using an unsigned device driver, disabling test mode may make it difficult to start your computer up. If you’ve never done this, then you should be clear to disable test mode.

2 Likes

I regret to report that I’m having the same issue. What pains me is that I can’t seem to narrow down exactly what the issue is. Am I missing a step for DisableCapsuleUpdateOnDisk? I tried (with no success) both with and without the hashtag in uefi_capsule.conf (which already said DisableCapsuleUpdateOnDisk=true).

Just to clarify:

  1. The Framework Laptop battery was not fully changed, AND it was plugged in with a USB-PD adapter, and the Framework Laptop was charging. Correct?
  2. fwupdmgr update was executed without any error. Correct?

Without the hashtag is the correct entry.
(Hashtag acts as a comment / ignore line indicator)

Updated from 3.07 to 3.09 using LVFS on Manjaro. Ran fine, but I did have to boot from my install media and rebuild grub. Then booted into the BIOS and reset my power light to low and max charge to 90%.

FYI, you could give the F3 boot option a try. It allows you to navigate your EFI partition for an EFI payload to execute (in this case, you likely will find the grub efi in one of the directories on the EFI partition). i.e. No need to bring out an install media.

Once booted into your linux environment, you just need to grub update IIRC.

1 Like

The “Test Mode” watermark has existed since at least Windows Vista, possibly earlier. :slight_smile:

The InsydeH2O Windows updater should not be enabling test mode.

1 Like

Thank you for the correction. You’re right; the test mode message has been around for some time.

They were exploring the System Requirements Not Met message a few months ago.

Just barely updated to firmware 3.09. I use the grub bootloader in efi mode on arch linux. No issues with the update and I didn’t have to do anything to grub settings. I updated via lvfs.

edit: now it worked, it seems that i forgot to remove the # in the conf file or didnt safe it correctly. now all the ports arent working but im trying the workarounds mentioned in this thread.
everything worked, fedora 36 with luks encrypted / home, unencrypted efi and boot, secure boot was enabled all the time

this also worked for me, thanks!

Anyone tried to update the BIOS from Windows booted from expansion card drive? Or is that a no-no?

Success on pop!_os 22.04 via LVFS. Giant thanks for bringing its support!

2 Likes

Updated from EFI, just in case. :slight_smile:

1 Like

@Kieran_Levin @nrp Whoa, I just realized that I’m experiencing a major issue since updating… My laptop is no longer charging when powered off!

A couple nights ago I powered off around 57%, put it on the charger, and went to bed. I noticed in the morning that the LED was still solid orange. That surprised me because the release notes say that it should be solid white now, whereas it used to be flashing orange sometimes when finished charging. Then I opened the laptop and found it at 57%. Last night and this morning I reproduced the issue.

Am I being dumb somehow, or is this a major bug in 3.09?

If the laptop is powered on with the lid open or closed in s2idle, it charges fine.

3 Likes

I’m seeing similar behaviour (not charging when powered off):

1 Like

Yes and yes. Still not having any luck and I’m at a loss as to why.

I can confim the report (BIOS 3.09 Beta release - #97 by tim300) regarding the lack of charging when my computer is not powered on. 66% and still 66% after an hour. Normally I would have seen a full charge in that length of time.

1 Like

Regarding the failure to charge.

I’m using Win 11 and this happened the first time but since I’ve been using since I haven’t noticed.

When I stop I either sleep or hibernate it. I will try switching off to see if the issue is still there.

1 Like

@tim300 and others, thanks for reporting on this find. I would love to help test or confirm the bug, but not charging while the laptop is off is a showstopper for me, so I’m gong to have to stay on 3.07 for the time being. Looking forward to hearing a definitive answer as to whether this affects all Framework units, only those using Windows, etc…