12th Gen DIY Hard Freeze issue

I got a 12th Gen DIY a week ago, installed Win11, and started getting a couple hard freezes while working on it on my lap. The whole OS freezes, mouse cursor locks up, etc. The underneath felt hot when I put my hand to it, but I didn’t feel it on my lap. I suspect the importing vent was at least partially blocked by my clothing.

Is this a common issue? What software can I install to log the temp and help debug after a freeze?


Some tips that ultimately fixed my issue (while using eGPU if that’s relevant):

Laptop (Notebook) drivers for any Nvidia eGPU instead of desktop drivers

PCI Link State power options and other configuration quirks

Install all drivers offered in the framework driver package and confirm that you have the 12th gen package

: Whenever my framework would lock up, the fans would go 100% and the air would be warm suggesting a whole lot of calculations. I think this ended up being due to the PCI Link State when plugged in for me, but this has almost exclusively been a Windows quirk when graphics drivers are angry about something.

Probably unrelated, I have 2 windows desktops that have started freezing maybe once a month in exactly the same way this year.

In all cases, Event Logger and Event Viewer in Windows 10/11 did not report any abnormalities and logs would stop at the freeze and the next log would be on startup from whenever the pc was hard reset by me.

Thanks for the tips! I’ll check the steps in detail I am on the latest drivers however.

Now that you mention this. I also had this issue happen to me a couple times today while working on battery on my lap. I noticed occasional lock ups where I wouldn’t be able to move anything. I thought it was just Excel Locking up on me but the file wasn’t that big for it to be doing that.

EDIT: This post was merged here but this post is NOT about the DIY version of the laptop.

The laptop froze soon after getting in to Windows for the first time. Was not concerned thinking there may be a driver or firmware issue addressed in a newer driver/firmware release. Ran all framework driver/firmware updates, then Western Digital driver/firmware updates - there were no WD updates.

Freezing continued to occur at random times while setting up the laptop. There was no response to input via internal keyboard and trackpad, nor external keyboard or mouse, nor to any network requests. Tried with and without external input peripherals attached before and after the freeze. Holding power button for 10 seconds was the only action that elicited anything, which was to power off the laptop.

Setting up the laptop included:

  1. Ran all Windows Updates.
  2. Renamed computer and joined to domain.
  3. Installed and setup 365 suite.
  4. Configured Outlook, Teams, and et cetera.
  5. Installed Adobe Acrobat.

Handed laptop over to user and they experienced the same freezing behaviour at random intervals, regardless of whether they were actively interacting with the laptop.

From the topics I’ve seen in this forum, it looks like unexplained freezing is not an isolated incident. I opened a ticket with framework last week, but they did not respond. How long is it reasonable to wait for a response? Has anyone else experienced random freezing, and/or know of a root cause?

Thank you!



Linking this here as well. I just started noticing this when I updated to Windows 11. I don’t recall this ever happening on windows 10 the first week I had it.

I’ve been having this issue as well with a 12th gen DIY. Have updated driver for SSD and Intel drivers for graphics and wifi. Another suggestion they’ve made to me has been to switch my RAM cards (have 2 16 GB DDR4 cards) and try booting them individually while also switching the slots to see if there is a problematic RAM card or slot. The boot up after a freeze is exactly as described above. Fan runs at 100% and the bottom of the computer is warm.

Any feedback is welcome. Thank you. :disappointed:

1 Like

Same. Hard freezes fairly random. Not sure if eGPU is doing that or not - will observe next week, as I use it at work without eGPU.

I use eGPU with latest drivers, although there is no notebook version of mine (gtx1660). I also don’t believe notebook driver even exists… When you search for that version it will show generic driver anyway. But there are two to choose - gamer ready and studio. Studio supposed to be more stable so I am running that.
Of course all drivers from framework installed, WD850 drive had already latest firmware when I got it.

DIY 12th gen 1280p, 64GB RAM, WD850 2TB, 2x USB C+USB A+HDMI cards, Razer Core X+GTX1660. Running Windows 11.

Hi there,

Just circling back on my problem. I reported my hard freezing issue to Framework and had a number of rapid, helpful responses. I followed their advice and switched the slot that my RAM card was in and then performed a RTC reset. After two days I’ve had no hard freezes. Hopefully it stays that way.


Hi Andrew, I tried switching the RAM slot, and I still freeze. Do you remember what the steps were to reset the RTC? I haven’t found anything in the BIOS. I assume it’s a weird power button sequence.