12th gen Intel will not power on

If you swap the motherboard and the 12th gen board still shows no signs of life, but the 11th just starts fine, I wouldn’t have much hope for the 12th gen board.

I’m not ready to teardown my working machine to diagnose this one. When I hear back from support, I’ll update this thread in case anyone else has a similar problem in the future. :slight_smile:

1 Like

Are you getting any codes in the lights on the side, or is the machine not getting to that point? You likely know this, but remember that the initial boot after a reset can take some number of minutes while checking(?) the ram. Good luck, I hope that you are able to get things resolved soon.

1 Like

I never get to that point. The power button never illuminates. The right led never illuminates.

The left led is solid white when the input cover is in place. The left led blinks red (on/off no sequence) when input cover is off which is expected when the intrusion switch is open.

I will be interested to hear what Support has to say. In the meantime, you might try this shot in the dark.

Remove all expansion modules, disconnect the main battery, carefully remove the RTC battery, hold down the power button for 30 seconds. Carefully re-install the RTC battery, connect the main battery, use only one usb-c card to supply power, and try to power on the machine. Try the card + power in each of the four slots. I don’t have high confidence that this will fix things, but it may be worth a try. I’m sorry that you are dealing with this. If I had to guess I’d say that for some reason the board died. Hopefully it is still under warranty and you are able to get it replaced.

1 Like

I quite literally had something similar happen to me today/yesterday! Sad part is this is my work laptop, and I’m oncall!

One of my cables is a USB-C Dongle that in turn has an HDMI, USB-C power, and a USB switch that connects to my Keyboard/Mouse and my desktop computer. That switch is flaky and in the past has made weird static noises, so I suspect that could be the culprit? At the same time, since you mentioned

This is my main work machine so I’m kinda dead in the water until this works.

I’m wondering if the timing and the fact that our machines might be ‘managed’ might have something to do with it.


Anyway, story goes:

My laptop froze when I disconnected all my monitors for the day (aliased xrandr command and then pull out the cables). Screen went blank, nothing happened anymore, power button still white. Hold down the power for a bit and nothing happens, so I just close it and call it a day. Plugged it in and left it over night

Fast forward to this morning… Side LED is white when connected to power. Pressing power button does nothing. Tried plugging in a variety of orientations of my cables, plugging in the crappy dongle with switch and switching between devices in hopes that would do literally anything… nope.

I just finished following the guide to remove the RTC battery (Fully Resetting the Mainboard State - Framework Guides). Still no dice. Side lights are still white when plugged in, still nothing happens…

I am/was running Ubuntu 22.04 on a 12th gen framework 13, it’s just over a year old now.

It magically started working again…

Had my laptop open on my desk, hit the power button a bunch of times, then unplugged it. Was looking away when I noticed the power button turned on about 20 seconds later and the thing boots as normal (with the caveat that the system clock is now 2 months off).

Any suggestions for what I can do to diagnose what just happened? Logs to search for?

@David_Goldstein - These are almost exactly the same symptoms I have. However, mine still isn’t magically coming back.

I was able to get the diagnostic lights to show consistently this morning where they wouldn’t before. Here is the output and the errors from the lights documentation

Green
Red - 3V5V supply not good
Green
Green

Green
Green
Green
Green

Red - Fan error
Red - CPU S0 error
Green

Green

Orange
Green x8

1 Like

Exact same problem here.

What I sent to the support:

Hello,
I left my my 12th gen mainboard (1280P) unplugged for ~2 weeks. When I came back from holiday, I worked with it until the battery died. They I plugged it in. And it does not boot anymore. The led is blinking red for :

  • Power Good VCCIN_AUX
  • Fan detected and spins up
  • CPU reached S0 state

I have read My Framework Laptop (Intel 12th Gen Intel® Core™) is not powering on , but it did not help.
I have tried charging with/without the expansion cards: same result.
I have tried multiple power adapters: same result.
I have tried to reset the mainboard: same result.
I have tried to remove the RAM / SSD: same result.
I have tried with only 1 stick of RAM: same result.
I have tried different RAM sticks: same result.
Please advise,

@Tommy_Messbauer here is their suggestion:

The Led code on the video is also indicating an issue with the Fan. Can you please try to reseat the FAN and see how it goes? Click here​ for guides. May we also request a clear picture of the entire mainboard showing all components?

Hadn’t time to test it out. Pretty sure it’s not the fan since I did not touch that at all. Still going to try it of course.

The community here is really great. I was concerned that I would post this and get no replies. I’ll try re-seating the fan.

Its kind of a bummer that it is only possible to get one message from support every 24h. I sent a few videos thus far so hopefully they figure out what to do. I also sent them this thread, but it is unclear if they are checking it.

I love this machine so I hope people keep buying them so framework can invest in more support.

Hey folks, I’ve also had 12gen die on me a week ago. During a couple of weeks before that I’ve got a few freezes, after first one touchpad stopped working, after few more it started working again, then stopped again. I’ve unplugged/plugged all ribbon cables, it didn’t help.

When powering on, there is audible click in the speakers, fan tries to spin up but stops in 0.5s.

I’ve removed the motherboard and tried booting it up when powered by usb charger. Blink pattern is R GGGG RRRRR GG, which indicates that fan doesn’t spin up and CPU is not reaching S0.

I’ve removed all the stickers from the MB and found a small hole in the package of the audio chip. My theory is that it’s burned out and short circuited power rails to the ground. It also explains click on power on.

Haven’t asked support yet – I’m travelling so won’t be able to do much, FW folks are also overloaded with batch1. If nothing helps I’ll try desoldering the chip to see if it helps.

@Tommy_Messbauer you can lightly press on intrusion detection switch to stop orange/red blinking – it’s at the very top of the board in the middle (on-board power switch is at top right). In your case seems like 3V/5V power is failing. You can try removing SSD, wifi and (maybe) RAM, and disonnecting all the cables (MB is supposed to work well standalone, in that coolermaster case, so only RAM is needed for it to POST). Who knows, maybe your ssd burned out and is short-circuting power.

I had stripped the machine down to barebones and the results were the same. The key to getting the diagnostic lights to show was taping down the intrusion switch, then using the motherboard switch to attempt to turn it on.

Support just got back to me and will be sending me a replacement motherboard.

Side note: most of the USBc hubs that are available these days support pass-through charging. Most of the time (like 75% of the time), I opt to connect the charger directly to the port on the computer (we have 2 frameworks, a dell, and 2 macbooks). On the day this happened, the power was connected through the USBc hub.

I don’t think this matters because I’ve been using this same hub across multiple computers for over a year without issue. I’ll post this here in case others have seen any weirdness when using the pass-through charging of these hubs.

Hardware fails sometimes and it has been a really long time since it’s happened to me… which reminds me - I need to backup my home directory when this machine is working again. :slight_smile:

@Tommy_Messbauer that’s cool! Are you still covered by warranty?

I was using a non-brand PD usb-c docking station for a couple of weeks before the issues started, along with usb-c portable display, could also be related.

I just got the exact same issue while using HDMI to VGA on the framework HDMI dongle to watch a movie.

I got " Power Good VCCIN_AUX" on red blinkling wich is a bad sign

My framework 13th gen is also dead i think, only white led (or orange when charging)

There is definitively an issue with devices, electrostatic ?

it’s kinda annoying if framework can fried in split second with some devices connected :confused:

Yeah. I’m still under warranty. New motherboard is being delivered today.

I still love my framework laptops. This experience actually made me love them more for work situations. Here’s why - other manufacturers offer premium support options which still require extra work on my part to ship the machine or schedule service. They aren’t cheap either (like Apple care)

If I want the same experience, I can just purchase an extra motherboard and keep it around OR order one quickly.

This forum has been helpful too. The support team was great, only a little slow in replies which will get better as framework continues to grow.

1 Like

It turned out I’m out of warranty. Managed to repair my board by desoldering audio codec IC, it has burned out and was short-circuiting power. I also had to replace the touchpad, it also stopped working (keyboard and power button were fine though).

Now I’m thinking that my docking station somehow intermittently fed +20V a few times in the voltage negotiation process when FW wasn’t ready and had it connected to 5V rails, eventually causing burnout of less resilent chips on 5V power plane.

1 Like

Could this be related to the burnt out power switching mosfet issue some people are reporting?

@Tommy_Messbauer how many rounds of back-and-forth support emails did it take before they agreed to send a new motherboard? I’m having similar problems and it took ~2 days to get a generic response. I’m getting nervous about how long I might be out-of-action for.

@Adrian_Joachim very unlikely, I’ve rechecked all the mosfets, they don’t have any visual signs of thermal damage (for folks here [IN TICKET] Piece of mainboard partially melted it looks evaporated :scream_cat:).

@Nate2 It took me about 4 roundtrips for us to determine that they can’t fix the MB and it’s out of warranty.

1 Like