AMD Batch 8 Guild

  • I use a custom built mesa with some additional build options. Building it (Mesa v23.2.x) with LLVM/Clang v17 is failing. I tried building it with v16 but that is breaking rusticl.

  • I’m running into the following error when trying to add a fingerprint. There might already be a fix for it around the forum, just haven’t looked yet.

  • The latest Nextcloud client has a Nautilus integration: Nextcloud shares shown twice bug.

  • The Dash to Dock gnome extension has a Show Applications bug.

  • Ran into a bit of issue while replacing ffmpeg-free with ffmpeg. I’ve been able to resolve it.

  • One time when the laptop woke up from suspend, the whole screen was white. I haven’t looked into it any further but restarting the laptop fixed it. Not sure if it is related to the graphical artifacts issue.

Some of the issues might not be directly related to Fedora, just from third party packages. I’ve an Intel NUC with Fedora 38 where I’m not running into these issues, given it has older versions for some of these packages.

Overall the system is stable for me. Me saying seems a bit unpolished might have been a bit harsh.

Yeah, that’s a known issue with the fingerprint reader firmware (and not Fedora). Of course, there’s the part where match-on-chip Goodix fingerprint readers (used in many laptops) are questionably secure as well (and I think this does apply to the Framework?), so whether you’d want to use one at all is also worth considering.

(Now that I’m thinking about it, let me make a separate thread on fingerprint reader security.)

1 Like

So delivery time was this morning between 8:30-12:00 (mind you most of packages are delivered late afternoon, this caught me by surprise). I had to take my son to school and the short time I was gone, they had already came :pensive:…now it’s scheduled for tomorrow. :man_facepalming:t3::person_shrugging:t2:

Exact same time for me. It’s typically right at 12 but I’m not budging until it arrives.

I guess it’s okay. A part of me is excited to try the new hardware but I honestly don’t want to perform the switch out until my classes are done this semester, especially with the varying experiences others have had. My 11th gen is baked in at this point and reliable.

Shipped on 29th November
Delivered 4th December

1 Like



I’ve spent the last couple of hours getting set up, I can honestly say this thing is brilliant.

I installed Fedora and set up the development project I’m working on, which is web stuff with Docker, and I haven’t heard the fan yet. Fantastic.

The expansion cards are surprisingly tough to get out though.

1 Like

For real. Not worried about losing one for sure.
Didn’t realize how big the esc and del keys are as well.


Not bad temp wise. 7840

1 Like

Damn the UPS is not happy with that base lol, you using any mods?

Got mine set up! A few quick thoughts:

  • Installation was mostly a breeze, with one excepption:
  • A wire was out of place near the lower left corner of the screen, causing the “bump” at the bottom of the bezel to not fit right. It caught each time I opened and closed the lid and was starting to rip itself off of the rest of the bezel. I have the wire straightened out now, but I think the bezel got a little damaged in the process of figuring it out.
  • Only the bottom ~half of the touchpad is clickable when tap-to-click is disabled. Kind of a disappointment. (I’ve gotten spoiled by my work macbook’s touchpad.)
  • I hit a security problem when trying to install NixOS, going to circle back to that
  • For my Windows partition, after installing the framework driver bundle, I rebooted and ran AMD’s driver tool, and it found a few more things to install.
  • Overall, I’m very happy with it :slight_smile:

Received my laptop this morning. The included screwdriver bit is indeed too soft, glad I have a ifixit set with me. Otherwise the setup process is really smooth. Installed NixOS, got around 5w on idle and 10w on light use with default configuration, not bad, but can use some optimizations.


You need to disable secure boot first. You may reenable that by using GitHub - nix-community/lanzaboote: Secure Boot for NixOS [maintainers=@blitz @raitobezarius @nikstur]

1 Like

Got mine today too and I had the exact same problem. I don’t think there ended up being any damage but I was pretty worried about that catching on opening.

I’ll echo the issue with the included screwdriver not being sufficient. Way too soft. I have the same screwdriver that worked great. That NVME screw was on tight.


Thanks, I figured it was something like that. But then I decided that NixOS was more likely to play nice with an existing Windows install than Windows was with an existing Linux install, so I decided to do Windows first.

Like 100, that’s the FPS though, the zoom mod causes that, even on my desktop, Factorio was not made to render full detail at that zoom level.
Speakers on this thing are far better than the grills implied. GJ FW
A NOTE ON THOSE TEMPS: That was done in the middle of installing everything and setting this laptop up, running that same base again I didn’t even hit 70* for the 5 mins I let it run

Got my new motherboard last week to upgrade an older laptop. Immediately had issues with what appears to be display signal corruption. Emailed support about the issue including details like the issue goes away when I swap back to the original 11th Gen Intel board. Support replied today saying they can replace the monitor if it’s under warranty. I don’t think they even read the email because the issue is clearly something to do with the new board.

At this rate of reply from support it could take weeks or months to get to an RMA. Hopefully the support staff will scale with the number of new customers. Right now it’s pretty bad. I would include a ticket number or something in case someone reads this that can address the issue, but there’s nothing to uniquely identify support requests visible to users. :person_shrugging:

Got mine yesterday, exactly as estimated! If I’d had it shipped to home, it might even have come a day or two early.

Super easy to put together, and so nice! I’m coming from an XPS 15 so it’s light and small compared to what I’m used to. I do have a crunchy spacebar, but haven’t tracked down what’s going on with that yet - feels like maybe some dust in the switch?


Fiddled around with power-profiles-daemon and epp profiles, now I’m getting 4.3w on idle. Seems that p-p-d would only use ACPI platform profile when it’s available, not touching epp. Don’t know what’s the interaction between these two.

Edit: according to [TRACKING] PPD changes have no effect after suspend on AMD until reboot - #8 by Justin_Weiss, they should be able to work together.