AMD Framework USB-C charger compatibility issues

That is indeed weird.

Can you share some more details? Like charger make andmodel, which port is used and all that. Does windows show what the charger negotiated somewhere?

I have a USB-PD analyzer at home (and I am not there). When I get back, I will take a look with the analyzer and post back with my findings here.


Thanks for the recommendation. I picked up the Anker 737 and it charges the laptop, thankfully!
Thanks to the others for the recommendations as well :slight_smile:

With the 3.03b update my steamdeck charger is now working again for the framework, thanks :slight_smile:


I retested my chargers with 3.03b, changes are in bold:

  • No name 45W powerbank → 20V 2A
  • Baseus 65W powerbank → 20V 3A
  • Baseus 100W multiport charger → 20V 4.5A
  • Baseus 30W wallwart → 20V 1.4A
  • Baseus 20W wallwart → 12V 1.5A doesn’t need kickstart anymore
  • No name 65W charger → 20V 3A
  • Wotobeus 100W power brick → 20V 4.5A
  • Wekome 40W wallwart → Died since the last test, guess there’s a reason it was 6$
  • Random 100W powerbank board → 20V 4.5A Works now but the board is still flaky af
  • IP2368 powerbank board → 20V 4.5A
  • Random 22W powerbank board type 1 → 12V 1.4A
  • Random 22W powerbank board type 2 → 12V 1.5A doesn’t need kickstart anymore
  • Random 22W powerbank board type 3 → 12V 1.4A doesn’t need kickstart anymore but needed multiple replugs to get the right charge direction
  • random qc3 powerbank → 12V 1.4A works now(guess it does also support PD) but needed multiple replugs to get the right charge direction
  • Ultra compact 18W power bank board → 12V 1.4A
  • 5v only powerbank c to c → 5V 1.1A (needed kickstart)
  • 5v only powerbank a to c → 5V 0.8A (needed kickstart)
  • 5v phone power supply → 5V 0.8A (needed kickstart)

Cute little 18W power bank module:
cute little 18W power bank module


Any idea when this update might be availble for the Framework Laptop 16? I have a no-name 4s lithium battery 140W PD board that I’d like to be able to use but it cuts out constantly trying to start charging because of the sudden load step which it sees as over current. Once the laptop does manage to start charging it’s mostly stable although still prone to seeing load steps as overcurrent events and dropping into over current protect again.

Thanks for these tests! These three were the ones I was most curious about. Sadly it seems the AMD framework laptop is still worse at charging than my deceased 11th gen Intel framework laptop.

Just wanted to chime in and say the Minix Neo P1 does not work on version 3.03b

1 Like

It’s just got a bit of a mental block with those, since it’s possible to kickstart it is perfectly capable hardware wise so this may get fixed just as the sub 45w pd stuff got fixed.

1 Like

I have the same issue, I brought with me only the steam deck charger, and it doesn’t charge my framework 13 amd 7640.

Cruelly, I can’t update the firmware to fix the charge without a charger plugged in.

1 Like

Can second that this is the case

Adding data here: My FW13 AMD doesn’t charge through Apple’s USB-C dongle (A2119). Tried it with both the MacBook Pro charger, and my own Anker charger, which both work fine when hooked straight up to my laptop. I’m using Firmware, and running Arch Linux with Kernel 6.8.9-arch1-2.

Definitely upgrade to firmware 0.3.5 to confirm whether the issue still persists after the known bug is fixed. (Framework laptops do have a history of spotty compatibility with usb-c docks, which is what that is … there are some other threads about that.)


Updated via fwupd. Went very smoothly, but it did not seem to fix the issue with the Apple USB-C adapter. I noticed that the power consumption in the Energy app is <10W, but on charger directly it’s 30-45W. I will note that on all ThinkPads I’ve tried this adapter with, it works fine. I’ve also tried several different adapters, and the issue is consistent across all of them.