AMD Framework USB-C charger compatibility issues

Since receiving my AMD Framework 13, I’ve tried using various chargers and I’ve had issues with some of them, namely:

  • USB-C2 port of “Sharge Storm2” power bank (up to 15V 2A)
  • Steam Deck charger “Chicony W20-045N1B” (up to 20V 2.25A)

With both of them, the laptop reports to be charging and stops charging immediately.

Compared to other laptops/devices (which ramp up their current slowly after requesting the charging voltage), the Framework seems to pull a lot of current during the voltage ramp-up of the PD source (it seems to pull 3A during the entire 5V->15V/20V ramp).
This seems to upset at least some PD sources, possibly because their current limit is already set to the lower one (2A / 2.25A) during voltage ramp-up, while the Framework is still pulling 3A throughout.

Today, I’ve had access to a proper USB-C PD analyzer and I could take a closer look:

This was the Framework connected to the Steam Deck charger. The PSU first turns on with 5V, after a few milliseconds the Framework starts drawing 3A (which is fine on 5V), then requests the maximum of 20V 2.25A the charger supports, and then (with some weird pauses) keeps drawing 3A during the voltage ramp up until the PSU shuts off somewhere around 11V, possibly due to its overcurrent protection.

The same test with the Storm2 power bank looks similar, except with some voltage oscillation during ramp-up until the power bank shuts off.

EC / PD Controller firmware is the one provided with the current BIOS 3.03 (EC 66fc8, PD Controller 0.0.1C).


@patagona thanks for the detailed report.
This looks like we need to decrease the input current limit to our charger IC before we start the transition from 5V to 20V. We will investigate a fix for the next bios release.

I remember in the PD spec, we need to drop the current to a very low value during voltage ramp for EPR transitions, I need to see if this is also the case for SPR voltage ranges as well.


That looks like it could be the culprit, yes.

Also, independent of whether it’s in-spec or not, maybe consider still reducing the current during ramp-up of the PSU, at least the Storm2 (which is, well, possibly not designed very well in places) seems to (audibly) oscillate while ramping up under the full 3A, it possibly does that when pulling the correct 2A as well (though I couldn’t check if that is the case).

All I know is that a lot of PD devices seem to stop drawing current during the transition, so the case where current is still being drawn is likely not well tested (even if it is allowed by spec).

PS: Thanks for the quick and qualified reply, it’s a welcome change to get a direct answer from an engineer instead of the (for other manufacturers) typical “have you tried turning it off and on again”, “you’re using it wrong”, “we don’t support that”, etc.


Also just tried another PD source which shows the same behaviour:
An “Anker PowerDrive Speed+ Duo” car charger. That one does 20V at 1.5A.
Same thing, starts at 5V, Framework starts pulling current, requests 20V 1.5A, current exceeds the limit during the transition and the charger turns off:

(19.5V / 2.8A max; 1.95V/div, 0.28A/div, 0.1s/div)


Anyone know if the Intel boards also have this issue (or not, and only affects the AMD boards)? And whether it could be related to the melted MOSFET issue?

I’m not trying to be a pain in the butt here. It’s just that I’ve now started to use my 11th gen laptop more, due to improved power-on reliability / consistency with the RTC substitute. And so, with increased usages, and still unknown cause(s) to the burnt MOSFET, in combination with me trying to be careful with a TB3/4 cable selection, there’s still a portion of “will it happen to me” anxiety (especially now that I’m out of warranty, and no option for extended warranty). Granted, the 11th gen isn’t TB certified, but Framework did say they’ll support TB use cases the best they technically can.


I just wanted to mention that the steamdeck charger worked with the 3.02 BIOS (which had PD 0.0.1E I think). But after the upgrade, it stopped working. But also I was wondering that 0.0.1E → 0.0.1C looks like it was a downgrade (as C is before E)?


I was also kinda wondering about that as well. I thought that was just a display issue with the upgrader, but yea, it seems like it might’ve actually done a downgrade. Didn’t test the (now) non-working chargers before the upgrade though.

@Kieran_Levin do you have an explanation for that PD controller firmware version weirdness?

Version 1E was working around a timing issue we were seeing on boot, where the HPD to the APU would go high before PSP init finished when it would take longer to boot. This cascaded into a GPU crash/hang on boot. We got a firmware update on the APU to fix this later on, so we went back to the old PD firmware which did not have this issue.


Tested with 3.02 BIOS, never updated. Belkin ‘30 Watt PD Power Adapter’ Model: WCH001dq. Output: 5V3A, 9V3A, 15V2A, 20V1.5A.

Similar charging behavior which the laptop quickly alternates between charging and not charging. Therefore, at least from this data point, it seems like the PD version 0.0.1C and 0.0.1E isn’t relevant to this PD charging issue.

(Charger and cable is known-good, it is in fact the daily charger for a different 12th Gen)

@patagona Thank you for you insight and scientific analysis into this issue! Your USB-C PD analyzer report seems to blow the case wide open.
@Kieran_Levin Thank you for your prompt reply and raising this issue with the relevant team. I hope this bit of additional information can further assist! Please do update us once there’s further information regarding the investigation and fix.


I’m also seeing similar behavior when charging from a “trickle” PD source like both the Pixel 18w charger and Apple iPad 20w charger. Usually it will settle down and charge but it would be great if they would charge on first try. Both chargers work to slowly charge my MacBook.

1 Like

My 3.03 7840U Framework has issues with this 47 W dual USB-C Anker charger and this 67 W dual USB-C + single USB-A Anker charger. The behavior for both of them in W11 is they toggle charging on and off at about 1 Hz and eventually (after ~10 seconds) settle to charging properly.

I see similar behavior with the 30w USB-C port built in to my couch (no idea who makes the electronics part).

1 Like

The steam deck PSU used to charge my Framework reliably. In fact, it was the only charger I used before updating to 3.03, since it was already plugged into my desk.

1 Like

It really looks like there is an odd behavior with firmware 03.03 and charging.
My issue is perfectly reproducible.
I’m on Windows 11 (but don’t think it matter that much for a charging issue) I’m using a Lenovo Docking Station (this model) and the behavior is different between back-left port and back-right port.
On the back-right port everything work as expected :

  • laptop is charging
  • connected display is working (32 inch 1440p@60Hz)
  • usb devices working (mouse, keyboard, headphones…)

On the back-left port :

  • laptop is not charging
  • connected display is working (32 inch 1440p@60Hz)
  • usb devices working (mouse, keyboard, headphones…)

However I can make it charge on the back-left port with the dock attached.
Here’s a step by step to achieve that :

  1. Connect the laptop to a charger on the back-right usb-c (it’s charging)
  2. Connect the dock on the back-left usb-c (it’s still charging and the display is recognized as long as the other devices)
  3. Disconnect the charger from the back-right usb-c (the laptop is still charging with the power from the dock)

To me that clearly indicated a fault / bug in the firmware as it is not idempotent

I’m a batch 4 guy and mine came up with 03.03 built-in so I cannot compare, but I see the same weird things with power delivery as others ( for example : like here )

Really hope that at some point framework will create a fix for this because my desk is set up with the usb-c coming from the left and i cannot change it. For the time being I can manage but it is a shame not be able to use the ports the way it is intended.

I’m also batch 4, and I can add that I also seemed to have more success with the dock on the back right port and more flakiness on the back left. No time to test now. I received my laptop w/ 3.02 but immediately upon getting Windows installed, I updated to 3.03.

Batch 2 Ryzen 7 7840u on Windows 11 with BIOS 3.03. I’ve noticed some issues with charging in general. First one just happened where the charge indicator kept flashing red and refused to charge on the back left port. After switching to the back right, it began charging. The next issue is with powerbanks. It often will try to charge the powerbank instead of accepting charge, even when the device is completely powered off. I’ve had some success with waking the powerbank before plugging in the laptop but this has never been an issue with my 12th gen board.

I can confirm an issue with the following charger:
MiniX Neo P1. Which supports 66W, PD3.0/QC4+/QC3.0

On AMD 7640 bios 3.03 It does not charge, and the framework red light flashes very slowly.
At least in the back slots left and right.
I have tested 3 different chargers of this type, all don’t work.
They do work on all my other laptops.

Available on a.o. amazon if the developers want to add it to their compatibility test.
I have bought 3 of those a while back, and they work well on all of my laptops/phones.
Please add them to the list for testing so I don’t have to buy 3 new ones to put around the house :blush:

AMD Framework USB-C charger compatibility issues Looks like there might be an issue, where the laptop continues drawing the full 3A during voltage ramp up phase, which causes some PSUs to shut off. Hopefully it can be fixed in the next firmware update.

1 Like

I’m unsure if that is related, but I also did some testing with the CC-resistor-based 5V PD signaling (for 5V 1.5A and 5V 3A), and while the Framework seems to detect and pull the correct current, it stops charging after a few 100 milliseconds (both turned on and off, at 70% battery level), so 5V PD charging doesn’t seem to be working correctly either (from my tests).

With 1.5A resistor (22kOhm):

With 3A resistor (10kOhm):

Probably the safest bet would be to subscribe to this thread, though that might also lead to some unneccessary notifications.


Same problem. No charging from left back port. I happen to have the same dock too, but the charging problem exists when the dock is not plugged in too