Arch Linux on the Framework Laptop 13

I am preparing a drive to put arch linux on and if kernel 5.15.8 works completly with WIFI and BT out of the box, where is the ISO file with that kernel? This is my first time installing a specific kernel version and I can’t find where to get it. On the archlinux website the iso file is packaged with kernel 5.15.5 .

@Arik, the ISO won’t have the latest kernel, but WiFi should work well enough to do the install. You will get the latest kernel either in the pacstrap step of the install, or later whenever you do a full system upgrade.

Be sure to specify a DHCP client (such as dhcpcd) in the pacstrap command, and then enable the service in the chroot phase.

The tricky part is getting WiFi configured during the chroot phase of the install.

I found it much easier to use a USB-C ethernet adapter for the install and all of the initial setup. Then after getting a full desktop environment setup, that is when I configured WiFi.

@Arik - Wifi will work for the installation process, you just have to manually enter everything through iwctl to get it set up initially. When you get to the pacstrap part you want to make sure you are installing dhcpcd and networkmanager along with the other stuff. When you get to the arch-chroot part of the installation, make sure that both the networkmanager and dhcpcd daemons are enabled when you reboot. If you’re using something like GNOME or KDE Plasma the built-in network tools will work out of the box. When you install you will get the latest kernel, so you shouldn’t have any networking or bluetooth issues.

Standard arch distro comes with wifi-menu command still, right?

Or you could use an arch derivation like Endeavour or Manjaro with graphical installers if command line wifi is a no go…

I assume nobody has successfully used the LVFS testing channel and updated their firmware yet?

Seems like fwupdmgr isn’t properly creating the boot entries and manually setting this up isn’t working great on my end.

1 Like

Arch community, thanks for the great Framework Laptop wikipage on ArchWiki. Seeing the Function keys page, I found maybe one mistake at Framework Laptop - ArchWiki .

F9 Super+L

According to my check by xev -event keyboard, the F9’s key symbol is not Super+L but Super_L + p (Left Super + p). As I didn’t want to edit the ArchWiki page, I just report it here. Hope someone in the Arch Linux community will update the page.

Press “F9”, then the result was like this.

$ xev -event keyboard
...
KeyPress event, serial 28, synthetic NO, window 0xe00001,
    root 0x29a, subw 0x0, time 41784725, (154,66), root:(720,607),
    state 0x0, keycode 133 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 28, synthetic NO, window 0xe00001,
    root 0x29a, subw 0x0, time 41784725, (154,66), root:(720,607),
    state 0x40, keycode 33 (keysym 0x70, p), same_screen YES,
    XLookupString gives 1 bytes: (70) "p"
    XmbLookupString gives 1 bytes: (70) "p"
    XFilterEvent returns: False

KeyRelease event, serial 28, synthetic NO, window 0xe00001,
    root 0x29a, subw 0x0, time 41784866, (154,66), root:(720,607),
    state 0x40, keycode 33 (keysym 0x70, p), same_screen YES,
    XLookupString gives 1 bytes: (70) "p"
    XFilterEvent returns: False

KeyRelease event, serial 28, synthetic NO, window 0xe00001,
    root 0x29a, subw 0x0, time 41784869, (154,66), root:(720,607),
    state 0x40, keycode 133 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
1 Like

The more and more I dig, I think its a hardware issue. I went as far as installing Windows 10 with Secure Boot and all the bells and whistles; and still no mic.

I’m frustrated.
Thanks for your suggestions, I had also thought of switching to pipe or jack options… its not my cam/mic module, its not the hardware switch in the bezel - so I guess I have to go from there. :confused:

Could I get some assistance on switching the mouse setting from the default sides profile to the triple/double/single finger click as well as tap to click? The wiki for the framework laptop is kind of confusing as it doesn’t explain the process very well, and I haven’t seen a whole lot of discussion about it here other than one person.

Depending on your desktop environment, there might be some easy ways of setting this - I use GNOME and settings allows me to select tap to click right in the touchpad section… to do the right-click thing I followed the Arch Linux Frame.work pade:

Arch Linux Frame.work Laptop Wiki

Hope that helps…

pAULIE42o
. . . . . . . . .
/s

@Paulie420 I used that same wiki that you sent, but I don’t really understand what it wants me to do. I tried using their temporary command to see if that would work, but I’m not really sure what I’m supposed to put for the device portion (i tried imputing id=x). I should also mention that I’m using BSPWM, otherwise I would’ve had an easy time just switching the setting in GNOME settings too.

Although I used the temporary command, I would prefer to do the permanent one, as I liked the way that I was using my touchpad on gnome.

EDIT: I’ve taken some time to understand libinput a bit more, and when I input the command (from the wiki)
xinput set-prop “device” “libinput Click Method Enabled” 0 1
I get “property ‘Click Method Enabled’ doesn’t exist, you need to specify its type and format”
I’m looking at the xinput(1) wiki right now, but I’m still unsure of what I would need to input to get that to work. Either way, this is not a persistent setting change, and I’m still looking for the permanent solution to this

EDIT 2: So I have now realized that I need to edit /etc/X11/xorg.conf.d/ to add the triple/double finger click mode as well as tap to click, but what do I need to actually input into the .conf file and what is proper syntax?

1 Like

@jerry

You can create a file called 40-touchpad.conf in /etc/X11/xorg.conf.d/ that looks like this:

Section "InputClass"
    Identifier "touchpad overrides"
    Driver "libinput"
    Option "ClickMethod" "clickfinger"
    Option "DisableWhileTyping" "true"
    Option "Tapping" "on"
    Option "NaturalScrolling" "true"
EndSection

That will give you the right settings for BSPWM. If you want to add trackpad gestures you will want the libinput-gestures package as well, which uses a separate config file that lives in ~/.config/ and has to be started separately. (I start it from my bspwmrc file.) That lets you use swipe gestures to change workspaces, which is really handy.

EDIT: Fixed config file path for anyone else who uses this as a reference later!

2 Likes

@Jay_Reding Thanks for the response! I’m so glad that somebody is practically in the same situation as me, and that I can in fact have gestures for switching workspaces (that would’ve been my next task). I hope to also ask you for help with that if I need it.

One question though: I am using vim, and when I try to wq/wq!, my terminal tells me that /etc/X11/xorg.d/40-touchpad.conf cannot be opened for writing. What do I need to do to open this file for writing?

EDIT: Figured out the issue, you had a typo in the directory name. I should’ve noticed but I didn’t lol. Anyways, I didn’t add the “NaturalScrolling” as I am fine with the scrolling out of the box and the same goes for “DisableWhileTyping”, but thank you so much for this help, and I hope to ask you about the gestures as soon as I get to that :smile:

I fixed it by myself on ArchWiki. Only English version. Because to edit the Japanese translated page, it seems I needed one more account on the Wiki.

1 Like

@Jerry - Glad you got that figured out! The libinput-gestures part is pretty easy - the only think you will want to do is copy the example config to ~/.config/libinput-gestures.conf and then update the device part of the config. I think the device identifier should be the same for all Frameworks:

device PIXA3854:00 093A:0274 Touchpad

If that doesn’t work, you can get the device name this way:

libinput list-devices

Just look for the Touchpad option there and copy the Device name to your config file and you should be ready to go. I personally reversed the swipe left and right lines in my libinput-gestures.conf file (that by default will change workspaces in BSPWM) as it seems more natural to me, but you can play around with what works best for you.

Then you can add

libinput-gestures-setup start

as a line in your bspwmrc file to start the gesture system.

I was just trying this myself and couldn’t get it to work, either. Fwupd stuck an efi application and *.cap file into my boot, I manually added it to the efi boot manager, but it just outputs “Reset System” when it runs on boot and doesn’t update the BIOS.

I’ve been trying to enable verbose debug logs on the efi application, but neither efivars nor the sysfs interface will let me create the FWUPDATE_VERBOSE variable:

[sean@glitch ~]$ sudo efivar -n 0abba7dc-e516-4167-bbf5-4d9d1c739416-FWUPDATE_VERBOSE -w -f /tmp/one
efivar: Input/output error

@Sean_Greenslade Apparently Framework is still testing when it comes to LVFS, according to the Arch Wiki article section on LVFS.

I don’t know is this the right place to report this, but I see an issue. On kernel
5.16.2-1 when I suspend the framework, the keyboard backlight keeps lighting up, though when I close the lid, it disappears, and when I open it reappears.

2 Likes

Perhaps, the issue is same with the following issue. Not sure it is reported on the kernel.org.

1 Like

A rolling distro like Arch Linux, Fedora rawhide, Debian unstable (sid) is for users who are comfortable to report and fix by themselves, downgrading the pacakge in a mean time.

A distro with the stable version release style is more stable. But in this case, Fedora 35 kernel version will be upgraded from 5.15 to 5.16, upgrading a minor version. Fortunately it is not actually released to the stable version package repository yet. On Fedora there is a process to report the testing version using an app called Bodhi. And I reported here. So, I hope this version will be not released.
https://bodhi.fedoraproject.org/updates/FEDORA-2022-57fd391bf8#comment-2394706

If more people are involved in the testing, more issues will be fixed before releasing, and you don’t see the issues on the stable version.

In case of Framework Laptop requiring new kernels and libraries, in term of Fedora, maybe the stable Linux distribution is future Red Hat Enterprise Linux (RHEL) 9.x or downstream distros of the RHEL. On RHEL, as far as I know important packages are only upgraded on the maintenance version level (z in x.y.z) or only a source code patch to fix specific bug is applied. I don’t know other downstream distro’s situation.

One more tip to use stable version is as Framework Laptop works better on Fedora 35 than Fedora 34, people are usually using the Fedora 35, the latest stable version. But if you consider stability, you can use Fedora old stable version (latest stable version - 1 or - 2). I recommend continuing to use Fedora 35 even after Fedora 36 and Fedora 37 are released. I am sorry to write Fedora topic on the Arch thread.

2 Likes

I have similar thoughts that the suspension doesn’t work properly as it seems to drain the battery a lot.

When I installed the system, the kernel version was 5.15.12, and seemed not to have this issue with the backlight. But it didn’t wake when the keyboard was pressed, it waked only with power button press.

1 Like