Arch Linux on the Framework Laptop 13

No luck for me with the kernel 5.15.3 upgrade. Bluetooth not detected, KDE freezes for a few seconds before re-responding, etc. Downgraded to 5.14.16 :confused:, most issues fixed. Baloo got excited and using significant system resources at the moment, probably nothing to do with the process and just a random coincidence.

1 Like

I had the same experience after upgrading this weekend. I just downgraded to 5.14.9-arch2-1 (just because it was the only other version I had in /var/cache/pacman/pkg) and everything is normal again for now. :slight_smile:

1 Like

I also tried 5.15.3, but no dice, I was having the exact same issues as on 5.15.2. I had to backdate down to 5.14.16 again, where everything is running fine.

Still no total joy with 5.15.4. It seems like the bluetooth module is fixed but the display issues are still there and were actually worse than previous versions. Back to 5.14.16…

1 Like

Just updated Manjaro and am now on kernel 5.14.18-1-MANJARO. Woke my laptop from deep sleep, on a whim switched on bluetooth (it turned on!), connected to the tp-link input on my stereo system, and am playing blues harmonica through my speakers.

Too much information. The important part is that bluetooth appears to be working and it didn’t until today.

1 Like

linux-zen 5.15.4 resolves Bluetooth for me, as they’ve packaged the fix

(referring to Arch Linux on the Framework Laptop - #95 by Kanshou)

1 Like

I’d like to upgrade to 5.15.x for no good reason.

I’m sticking to 5.14.x for now.

@hakayova a patch is up for 5.15.4 to fix the gpu hang issues. I have been running with it for a couple days with no problem. See section i915 on Framework Laptop - ArchWiki


Thank you so much @Guillaume_Binet. Compiling kernel is a little daunting task for me. I am trying to gather some courage at the moment for doing this. I have done it before but not on arch linux. Unless I nuke the boot loader (grub) somehow in the process, I should still be able to boot to a previous kernel image I guess if the compiled kernel fails to boot or work properly. I will let you all know if I feel confident enough to do this in the near future!

I compiled the kernel with the suggested patch and it seems to be working now. I got bluetooth and no significant graphical mishaps. However, I have to say that there are a few pixels that need updating every few seconds when working on virtual terminal (in my case konsole). What I mean by that is a few garbled pixels appear and disappear quickly every now and then, which has never occurred until about a week ago when the whole issues started to appear. This was also happening after my previous downgrade to kernel 5.14.16. I hope this gets resolved in time as well. Thanks again @Guillaume_Binet !


Unfortunately back with more trouble, which is not resolving by a kernel downgrade either. Hangups, network-applet not showing its dialog when clicked to scan available wireless networks are the ones I am noticing now. I also noticed that top shows a constant 30-60% CPU usage by Xorg. I checked my pacman cache and saw that there has been several xorg updates lately (since September). One interesting leap was that xorg-server package went from xorg-server-1.20.13-3-x86_64.pkg.tar.zst (October 31) to xorg-server-21.1.1-3-x86_64.pkg.tar.zst (November 10). I thought that leap in version numbers were unusual but not sure if it is the source of the problem. I also am not sure if it is expected Xorg to use 30% CPU constantly, I feel like it shouldn’t but I may be wrong. Can others with more stable systems report what they are observing in this regard please?

Based on the issues I have been having lately, which may not be just limited to kernel upgrade, and the above-mentioned observations, I am wondering what I should do to get a stably working laptop? I love arch-linux and will not give up on it easily but I also need the laptop to be reasonably stable. I would appreciate any input.

I’ve never noticed what’s normal before, but I currently see xorg idling at 0%, which will spike up to ~2-7% when I click around, move windows, type this message, etc.

FWIW I’m using the xinit system with DWM instead of a desktop manager, but I’m not sure if that would make a difference.

Edit also I appear to be using a version before the jump to 21.x?

[root@lake log]# X -version

This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See for git access instructions.

X.Org X Server
X Protocol Version 11, Revision 0
Current Operating System: Linux lake 5.14.9-arch2-1 #1 SMP PREEMPT Fri, 01 Oct 2021 19:03:20 +0000 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=e41b9e06-1b82-4db2-8479-16d72d6b1a25 rw loglevel=3 quiet mem_sleep_default=deep net.ifnames=0
Current version of pixman: 0.40.0
        Before reporting problems, check
        to make sure that you have the latest version.


[root@lake log]# uname -a
Linux lake 5.14.9-arch2-1 #1 SMP PREEMPT Fri, 01 Oct 2021 19:03:20 +0000 x86_64 GNU/Linux

Thank you @Erik_Schoster. Just to clarify I am on KDE, and despite its fame for resource heaviness my experience was flawless with it until about 2 weeks ago.

After posting my previous message I was able to improve some things that calmed down the Xorg usage. I won’t go into very much detail here but I believe it was actually my fault of not noticing several instances of gkrellm working for example. It is now at single digit numbers if not 0%. I am sorry for the confusion.

After seeing your post, I also checked my X version which is same as yours not 21.x. I guess there must be a typo in the package name.

When I now use the custom kernel I made by applying the patch discussed above, KDE launch always stalls now for several seconds. Moreover, KDE taskbar may or may not load at system login. Notification dialogs from the taskbar take several seconds to show their content if at all. Going back to kernel 5.14.16 effectively fixes these problems.


For an idle desktop, light web browsing, etc, I would consider that crazy excessive CPU use by xorg. There might be certain workloads / use cases with very high software redraw (i.e. animated 3D cad with a lot of movement creating a lot of partial screen “damaged” areas that need updated in frame buffer) where that might be a reasonable use, but those should be pretty rare in my opinion. Even playing movies unmaximized in a window with a frosted glass effect terminal partially overlaying the movie, I see maybe 6-8% CPU use on a 5Y71 processor on xorg-server 21.1.1-3 on Arch + Gnome 41. Maybe 1% CPU use by Xwayland on a Wayland session instead.

Did the high use start at the version jump?

Is there an obvious memory leak in the xorg process?

Anything wonky in your xorg setup, plugins, libs, etc?

Is the high use any better under Wayland instead?

1 Like

I am sorry to introduce noise to this discussion and mislead people. The high CPU use by xorg I believe had nothing to do with other issues I was having. I had put gkrellm in autostart list for KDE and not only it started itself with every boot, KDE also started a second copy on top of its original window at the same location based on the config. This made me not notice that there were several gkrellm instances running, and I believe this led to the Xorg going crazy. By the time I identified this problem, I believe there were more than 20 gkrellm instances simultaneously running. When killed them all, Xorg calmed down immediately.

Thank you so much for extending a hand though. It is very much appreciated.

1 Like

Never heard of that project before. Learn something new all the time in the Linux space.

Glad you got it figured out.

1 Like

I didn’t find anything about the patch you mentioned. Could you post the link?

I’ve found the patch you mentioned here:GPU HANG. Kernel 5.15 on TigerLake (#4530) · Issues · drm / intel · GitLab
and it worked fine on my 5.15.6 kernel built with the latest stable kernel source.

Yep 5.15.6 now includes the fix. Finally a kernel with everything working for the framework!


Agreed. I confirm that it is working on my end too, which means working Bluetooth and no freezes during startup and later. Thanks to all who made this available.

I am on EndeavourOS, and 5.15.6 seems very nicely stable. This is a first for me. Every version before this one has been flaky in one way or another.

Agreed. EndeavourOS is a keeper for sure. Couple hiccups in the graphical installer but it’s been good for all the basics since.

Working on eGPU + Nvidia next