Arch Linux on the Framework Laptop 13

The most important is to get the amd-ucode package and linux-firmware (if you didn’t already have it, it would be unexpected if you don’t). When it comes to software tools, just uninstall tools you no longer need and adapt configurations.

It can be a lot simpler to just reinstall the OS but you can carry over your existing installation simply by installing the microcode. It’s just a little bit of a chore to adapt configurations if you need to do so.

It’s less of a pain to fresh install than undo various configurations done over time.
On my 12th Gen board, I have kernel parameters that help save battery in sleep, disable hid sensor for brightness keys to work, config for wifi card, disabling watchdog, fixed pci quirkiness powertop complaints about, etc

Some of these issues will likely won’t exist in the new amd board or even 13th gen board.

1 Like

A few other quirks I’ve noticed going from Intel → AMD – it seems like the AMD sound card can’t handle PIPEWIRE_LATENCY=64/48000 (I use this because I use my laptop as a guitar amp) compared to the intel one.

I had to remove that from my ~/.config/environment.d to get audio to stop crackling (unless I use an external DAC)

Whoah yeah, the amdgpu errors are gone after the bios update and wayland doesn’t crash upon the first start anymore. Thanks framework team <3

Edit: Oh, no i the flickering again:
amdgpu 0000:c1:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0005 address=0xfff5b000000 flags=0x0000]

Got this while i took a screenshot via slrup and grim, but i didn’t set the kernel parameter mentioned here for now → [RESPONDED] AMD Ryzen 7040 (7840U) - Arch Linux amdgpu errors, blank screen on opening Steam
Just as an Info :slight_smile:

1 Like

Is anyone else having a kernel panic upon boot if no external monitor is connected, but was connected at shutdown?

Basically:

  • boot normally
  • connect and enable an external display (HDMI extension card)
  • shutdown
  • disconnect the external display
  • boot

This results in a kernel panic for me. Subsequent boots work fine.

1 Like

I’m not looking for help at this point anymore, just providing some information in case someone is stuck–or has more knowledge.

I was running into the issue of boot hanging on A start job is running for /dev/disk/by-uuid/...(no limit) if I cold booted off battery. If I did a restart or booted plugged-in, Arch would start fine.

https://bbs.archlinux.org/viewtopic.php?id=291044 led my to believe it was possibly a systemd bug or an issue with systemd on encrypted btrfs (didn’t use encryption though).

I tried all combinations of the following but still hung on battery boots:

  • Downgrading to 254, 253, or 252 of systemd
  • Changing kernel versions to lts and zen
  • Downgrading kernel versions
  • Grub/systemd-boot
  • btrfs/ext4
  • various kernel parameters

Thus led me to believe it was maybe a hardware issue, so I tried Debian Bookworm. Bookworm worked 100% fine. Upgraded everything on Bookworm and it worked fine. Changed to Debian Trixie and it worked fine.

Maybe it’s a timing issue or maybe it is a firmware issue with the nvme module I have, not sure.

Nextorage Japan 2TB NVME

Other thing to check is a bad /etc/fstab entry. I’ve run into that a couple of times if I make a typo in that file.

1 Like

So linux 6.7 is now available on Arch. Does anyone have good links for what this fixes? I feel like there were some energy savings associated with it for AMD, but I cannot find that discussion.

All I know is it broke 6GHz for me on the RZ616, I posted a workaround here: [RESPONDED] AMD RZ616 wifi card doesn't work with 6GHz on kernel 6.7

fstab entries were correct, I don’t think that would be a problem if it was willing to boot while plugged into AC?

I’m running 6.7.1-arch1-1 on my Framework 13 AMD and so far so good. I had issues with Steam not running via flatpak, but I switched to the command line installation and it has been fine. That may have been related to my changing the bios to enable gaming.

I’m running KDE with Wayland and it’s been stable.

3 Likes

Hello,

Does anyone have any suggestions for fixing severe flickering on Framework 13 13th Gen Intel, running Artix (Arch linux derivative)?

I have tried:

  • Reading Intel_graphics on the Arch Wiki top to bottom
  • Reading Framework_Laptop_13 on the Arch Wiki top to bottom
  • Switching from xf86-video-intel to modesetting [no screen output: either ‘failed to find device’ or ‘no driver available’]
  • options i915 enable_psr=0 enable_fbc=0 enable_dc=0 in /etc/modprobe.d/i915.conf
  • Option "DRI" "2" in /etc/X11/xorg.conf.d/20-intel.conf - no change
  • Option "DRI" "iris" - no change
  • Deleting /etc/X11/xorg.conf.d/20-intel.conf and uninstalling xf86-video-intel [claims it can’t find the intel module and doesn’t even try to load modesetting
  • Using XFCE instead of KDE [less flickering, but window content still doesn’t update until you resize the window]
  • Switching from 60Hz to 45Hz in system settings
  • Installing kwayland, and plasma-wayland-protocols, and trying Plasma with Wayland [black screen with underscore cursor only, nothing else happens]
  • export MESA_GL_VERSION_OVERRIDE=2 in /etc/profile [no change]
  • Trying Ubuntu 22.04 live ISO [WORKS. But I want to use Arch if possible]

inxi:

CPU: 12-core (4-mt/8-st) 13th Gen Intel Core i5-1340P (-MST AMCP-)
speed/min/max: 400/400/4600:3400 MHz Kernel: 6.6.32-1-lts x86_64 Up: 5m
Mem: 1.9/15.34 GiB (12.4%) Storage: 465.76 GiB (44.0% used) Procs: 344
Shell: Bash inxi: 3.3.34

Model: Framework 13, 13th Generation Intel

/etc/X11/xorg.conf.d/20-intel.conf:

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option "TearFree" "true"
  Option "DRI" "2"
  Option "SwapbuffersWait" "true"
EndSection

[tried all combinations of SwapbuffersWait, DRI=iris|2 - both present and not present with no change]

Xorg.0.log: https://pastebin.com/avARkCuY

Screen flickering description:

  • Items on main plasma panel flicker like Z-fighting in a video game
  • Desktop background does not show [tho I once saw it briefly on login], instead being replaced with black
  • If a window’s content [e.g. systemsettings] changes, then it does not update on the screen until you resize the window
  • The only program that appears to work properly is yakuake, which I have done most of the above debugging in.

…and nothing has worked. Does anyone have any suggestions at all? I have been at this for hours with no success.

1 Like

What’s the Linux kernel version it is running ?

From my understanding of the FW13 12th, the graphics driver for Intel Graphics chip are from the kernel, so an old version might lead to artifact.

It’s a Framework 13 13th Intel i5-1340P, running 6.6.32-1-lts as mentioned in the inxi output :slight_smile:

1 Like

I’ve started a project to tidy up the Framework entries on the wiki and organise information based on the generation of mainboard (along with setup and troubleshooting new parts that shipped with each iteration). I own a 7040 series Laptop 13 and have started to move information over to here but I need help from owners of other models to populate each page. You can find an overview here and the discussion section here.

Any help would be greatly appreciated :slight_smile:

1 Like

No issues with bog standard Arch, Hyprland WM on iGPU since 6.5-ish up through current (6.9.3 IIRC), also i5-1340P.

That’s an awful lot of things you’ve messed with. Any luck if you go back to booting from a live installer medium? Maybe try one of the officially supported distros also?

Heya - thanks for the suggestion! I’ve just tried a KDE arch/artix installer and while it was fine at first, issues quickly became apparent. The wallpaper did not display (instead just black) - and even manually setting did not help.

I tried Ubuntu 22.04 again, and while it appears to work, some digging suggests that it is using software-based rendering in the live environment rather than hardware rendering, which causes the issue. All tests:

Distro Desktop Environment Status
Ubuntu 22.04 - live GNOME works, but software rendering
Parrot OS - live MATE works, but software rendering
Arch/Artix 202308 - live KDE does not work - hardware rendering
Arch/Artix KDE does not work - hardware rendering

Hardware/software rendering was confirmed by glxinfo | grep -i direct, or Firefox → about:support if glxinfo wasn’t available.

…so to this end, I am reasonably confident in diagnosing the issue as a faulty iGPU. Going to reach out to support. Thanks for the advice once again!