Arch Linux on the Framework Laptop 13

I’ve had mine a few days now, I just wanted to document my experiences here in case they help anyone.

Batch 8 (UK) i7-1165G7 64GB RAM and AX210 WiFi
I’m using Garuda Linux (Dragonized) - an Arch derivative which has some nice tweaks. I’ve not long started with arch, so some of this might seem obvious.

Initially, I thought I had a broken machine. The X server kept crashing, everything seemed slow.

It wasn’t until I saw *ERROR* Atomic update failure on pipe in my journalctl output, and found this post on the arch forum that I realised it wasn’t loading the microcode - turns out I needed to install the intel-ucode package and run a grub update

I also struggle with the interface scaling - I like my text small, but that’s too small - and the hidpi settings are too big. So I leave it as tiny, have a script containing xrandr --output eDP1 --scale 0.75 to fix that whenever I reboot or connect a monitor.

Since then, the only problem has been the WIFI. The connection speed is horrible. I have three laptops that I use on my desk a floor away from the router, and the Framework is the only one that has this problem - losing connection after about 30 seconds into big downloads. I don’t suppose anyone has a good fix for that yet?

Otherwise, it’s working well!


I’ve received my machine thursday and put an arch install on it because I wanted to try it out. Honestly, the entire jump from T440-Ubuntu-Gnome40 to Framework-Arch-Gnome41 has been massive. It feels speedy as hell, three fingers swipes are great, I love horizontal workspaces, the install was way, way easier than I had assumed. That being said:

  • ~~GNOME 40 has some stuttering issues due to Panel Self-refresh: Periodic stuttering on fresh gnome.40 wayland install on Arch Linux - #7 by Theodore_Koniszewski ~~ Problem is solved in kernel 5.14.2-1.

I would like to contest this statement. The screen glitching out when moving to the side of the screen at native resolution (2256x1504) were still real. You can either fix them as suggested in the link posted by nrp, or you can change the resolution, either will work (or at least worked for me).

To add onto what @Philipp_D said, I used both the latest stable official kernel and zen which should be around 5.16 if I can remember correctly. The issue still persists on gnome 40 (what i have might be 41) wayland.

Batch 8 laptop arrived in the UK yesterday. Last night I did an Arch install including btrfs on top of Luks, swap file on encrypted partition, and got hibernate working, which I’m pretty pleased with.

One problem I hit: pacstrap complained about the keys on every package. I think it’s because I forgot to set the hardware clock. Just fixing the hardware clock didn’t help and there was rebooting involved too.

The strangest thing was after doing the chroot, at first pacman commands worked, then all of a sudden (in the middle of installing packages) it broke again and went back to saying the keys were invalid. I fixed it by copying /etc/pacman/gnupg from the live ISO (where the output of pacman-key --list-keys looked sensible) to the installation (where the --list-keys output had all keys either invalid or unknown). So I’m not certain it was just the hardware clock that was the problem.

1 Like

fwiw I put up a video of a complete Arch install on the Framework, warts and all. It’s quite long but it has chapter bookmarks.

The bit I’m most proud of is getting hibernate to work with a swap file on btrfs on Luks (this starts at the 1:22:20 timestamp and takes about ten minutes until I test it.

(The video is monetised; not because I’m a “YouTuber” but because I can due to a quirk of fate; so don’t click it if you think I shouldn’t be posting such things here.)


@Rob_Fisher I made the experience that I had to repeatedly retrieve gpg keys at least thrice in total (essentially every time I did any command that complained about keys), even with clock set and all.

$ gpg --keyserver-options auto-key-retrieve --verify archlinux-version-x86_64.iso.sig

SImilarly no clue as to why that was

1 Like

It seems the screen flickering that existed before in GNOME under Wayland with PSR no longer exists with the latest kernel 5.17.1.


I wrote up the steps from my video here. There’s still some setting up to do after doing this, but it gets you quite a long way (certainly all the basics). EDIT: I think the most useful thing here is the combination of LUKS for encryption, btrfs, and working hibernate in a swapfile on the encrypted btrfs filesystem. Documentation for those things is otherwise a bit scattered.

Hi all,

I posted this question here, but just wanted to post its link here as well hoping that fellow Arch Linux users may provide more insight. Briefly, I lost sound and the ability to stream videos to my laptop from YouTube, Twitch, etc. during the last few days, regardless of the browser used. Losing sound means that playing back any mp3 or other audio formats via VLC does not produce sound on speakers or headphones, even though there is visual evidence of VLC doing the job. KDE audio settings indicate Analog Stereo Duplex is used for output but the speaker test again does not produce any sound. Only when I plug in or out the power supply the specific chime is heard, which indicates that the speaker hardware and wiring is actually OK. Kernel is 5.17.7, I am more than happy to provide more specific info as requested.

Edit: Downgraded to kernel 5.17.5-1. VLC playback of an audio file works again! Attempting to play YouTube stream not only fails but also breaks the audio system, the same audio file playback becomes silent after this failed attempt. Moreover, playing a local video file via VLC also breaks the audio system and is silent; however, you can actually see the video file playing, which is different than the streaming scenario. In summary, once a video playback is attempted, local or streamed, the audio drivers(?) break and stop producing speaker/headphone output. I tried this next with kernel-5.17.7 and got the same results. I also noticed that even opening Firefox or Chromium breaks the audio on my laptop during these tests. Yes, if one plays a song the first thing when the laptop boots up, it works. Just pause the song, and launch a browser, either Firefox or Chrome, then resume the audio, you will have no sound, despite the advancing play indicator. How weird is that?

Edit2: This link solved this problem for me. It is basically the wireplumber package not getting along well with pulseaudio, which needs to be replaced with pipewire-pulse. Please take note if you have the same problem. Thanks!


It seems the Framework Laptop is not currently listed in the Laptop page on the Arch Wiki. Does anyone who is using Arch currently want to add it? Laptop/Other - ArchWiki

I don’t know what that particular page is, but the Framework page is located here: Framework Laptop 13 - ArchWiki

(I updated it just yesterday to reflect 3.09 changes, so there’s at least one person maintaining it…)

When creating your account on ArchWiki to edit it, there is a check that only people using Arch. The check is related to the Arch package manager command. But actually, if you run an Arch Linux’s container image at DockerHub on any host OS Linux, Windows, Mac where docker or podman can run, you can use the package manager command and can pass the check, and can create your account for Arch Wiki.

On the Laptop/Other - ArchWiki, what is “Date” column on each table? Is it a first shipped date? Or the laptop’s press-released date? Or the batch 1 pre-order start date? In the case of Framework Laptop first generation, when is the “Date”?

I don’t think there’s a need to add the framework to that page; most other laptops have their own distinct page (and the framework does too, I linked it above).

I found one issue with using external monitors. Given I have the laptop hooked to the monitor for a long time with the lids closed, the ambient light sensor seems to be disabled (monitor-sensor keep returning 0 lux for the sensor) after I disconnect the monitor and start using the internal display. The issue disappears after a reboot. Does anybody have the same issue? If so, is this distro specific?

Hello community !

I use Fedora since 2006 but I wanted to switch for Archlinux for a long time. So I took the opportunity with my new framework.

After several days of trial and error, I finally managed to get suspend-then-hibernate working with a fully encrypted disk. I written down a guide for memory and sharing.

I will update the guide with a few bonuses like : plymouth and automated decryption with an usb drive.


I see Manjaro is compatible so I would assume a base install of Arch would work too.

Anyone come across any issues with Arch?

hi, welcome to the forum.

as of mid 2022 everything works fine on a typical install on the 11th gen, there isn’t a single component that isn’t supported. some have reported some issues here and there (unrelated to arch) but everything works mostly fine.

Been using EndeavourOS (arch derivative) for 7+ months now. No showstoppers at all.

Arch Wiki and other threads on this forum have more details. Search is your friend.

My 12th gen is running really well so far except for occasional GPU crashes.
When it happens the screen freezes and the fans start to ramp up after a bit, unable to switch to tty or anything. Currently using enable_fbc=1 but neither had an impact on this behavior.
I wasn’t able to reproduce it yet, just happened a couple times the last few days.

The dmesg looks like that:

Aug 03 01:58:17.169251 framework kernel: Asynchronous wait on fence 0000:00:02.0:gnome-shell[888]:e752 timed out (hint:intel_atomic_commit_read>
Aug 03 01:58:20.199442 framework kernel: i915 0000:00:02.0: [drm] GPU HANG: ecode 12:1:849ffffb, in gnome-shell [888]
Aug 03 01:58:20.199706 framework kernel: i915 0000:00:02.0: [drm] Resetting chip for stopped heartbeat on rcs0
Aug 03 01:58:20.199800 framework kernel: i915 0000:00:02.0: [drm] gnome-shell[888] context reset due to GPU hang
Aug 03 01:58:20.199883 framework kernel: i915 0000:00:02.0: [drm] GuC firmware i915/adlp_guc_69.0.3.bin version 69.0
Aug 03 01:58:20.199977 framework kernel: i915 0000:00:02.0: [drm] HuC firmware i915/tgl_huc_7.9.3.bin version 7.9
Aug 03 01:58:20.218807 framework kernel: i915 0000:00:02.0: [drm] HuC authenticated
Aug 03 01:58:20.219701 framework kernel: i915 0000:00:02.0: [drm] GuC submission enabled
Aug 03 01:58:20.219877 framework kernel: i915 0000:00:02.0: [drm] GuC SLPC enabled

Does anybody else experience this kind of freezing or can point me in the next direction?

Edit: The same thing just happened casually browsing on firefox and doing some terminal stuff (kitty) but this time it just froze for a second and continued running normal after. I’m seeing lots of usb 3-9: reset full-speed USB device number 2 using xhci_hcd which is the fingerprint sensor but not sure if that’s related.

Having tons of issue with the GPU on my i5-1240p 12th gen as well. Either straight up freezing on gnome like apol1o described, or supper laggy updates when running with my usual xorg/i3 combo, both on modesetting and xf86-video-intel :frowning:

This one fixed it: Periodic stuttering on fresh gnome.40 wayland install on Arch Linux - #6 by William_Light

I needed to turn of panel self-refresh.