Arrow keys won't work when accessing BIOS

I’m working on my Framework (11th gen system) and I’ve been having a problem accessing my BIOS settings: as soon as I get to the first BIOS page, my ‘escape’ and ‘enter’ keys work, but my arrow keys do not (which prevents me from selecting any other option than booting Windows). As soon as Windows boots, the arrow keys work just fine. What is going on here?

I’ve tried using an external USB keyboard (same results), uninstalling/reinstalling the keyboard driver, and updated the BIOS from Insyde 3.07 to 3.10. None of those has fixed the issue. Any suggestions?

Thanks for reading.

1 Like

Same on 12th. Seems like a gigantic problem. I don’t think arrow keys work on BIOS from a USB keyboard pretty much ever. You need to manipulate BIOS to change distros. So hundreds of people have encountered this and done nothing about it? Um?

My best guess is that maybe latest BIOS updates have a fix for the problem, and that this desperately needs to be mentioned in the setup guides. So I’ll try the updates and see.


  • Multiple boot media inserted, e.g. desire to change installed OS.
  • When laptop is booting, immediately when monitor gets black screen, hit F12 to enter BIOS settings, per user guides (e.g. Linux install instructions).
  • Cannot select boot media. Arrow keys do not work. Other keys work fine. Hit F1 to enter help, Esc to return. Still cannot use arrow keys.

Possible Causes/Fixes:

  • I believe this could be a USB issue due to how keyboard is mounted? I don’t think my USB media ever detected on this screen. Only option was to boot from existing install (Ubuntu 22.04 on HD exactly per install guide - yes ubuntu’s shenanigans had me change distros immediately).
  • Not a BIOS expert here, is there a way to “fix” the F12 screen to properly support the board? E.g. load it after USB support?
  • I would think the best BIOS default on a laptop like this is to prefer removable media, but maybe that’s A Big Change in manufacturing.
  • Else, change user guide. F12 is not appropriate. User needs to get to UEFI/firmware config screen to solve boot order per below.

What I did to troubleshoot:

  • Plug in a USB keyboard. No effect. No navigation keys function on this menu (WASD, HJKL, arrow keys, numlock…)
  • Doublecheck boot media. Re-flash per guide (Mint 21 via Rufus). Verify it detects and mounts on laptop OS (Ubuntu 22.04). Media still not detecting on F12 screen, cannot select. Laptop just boots to HD.
  • Instead get to firmware setup via command:
systemctl reboot --firmware-setup
  • Laptop and USB keyboards work fine here, so I can fix boot order as desired. (Example: Go to boot menu and change boot order from Auto to First and set proper boot order in sub-menu. If the sub-menu is confusing - I think you need to use F5/F6 - you could change the order to Last since most users will only ever have HD and optional USB boot media.)
  • Most bootable distros go straight to a boot selector where the keyboard works. No further issue is encountered once you’ve set a “better” default boot order.
  • Can now use bootable media as a workaround for any boot order changes.

F2 will take you into the BIOS. F12 will get you to the boot manager. There’s an issue around quiet boot and quick boot being turned off that causes a freeze when hitting F12 - see here: Cannot load boot menu, laptop freezes - #11 by Quinn_Casey

At the least you should be able to get into the bios using F2, then you can set your boot order there. It’s a little “heavier” than F12 but it may get you going. Nevertheless, your arrow keys should work in the boot manager, too.

Best of luck, hopefully you are able to get things sorted out.

The arrows keys don’t work for me either in the F12 boot manager. F2 allowed my to get to bios, so I’m ok. I’ll have to look at the thread you listed to see if I can get the arrow keys to work in boot manager. I have just received my Framework and have 12th gen.

Same issue here - surprising considering how well the rest of the laptop seems to work for Linux out of the box

Those with non-functional arrow keys on the “Boot Manager” (F12) screen, what BIOS version and CPU generation are you on?

I have this same problem, FW13, 11th gen, bios 3.19