Artix linux on Framework laptop

So far the artix install has worked flawlessly.

I got the terminal install working in a short period of time no major issues.

Currently I am working on fixes for: no computer audio, brightness and audio level keys no longer work(i didnt really expect them to), fingerprint reader compatability. Other than these laptop specific issues everything is working well. No stutters or other weirdness. dwm desktop environment working well.

I will post fixes as I recieve or find them


putting in my SSD with my Artix Install from my old laptop when mine arrives later this week. Have you gotten bluetooth to work?

No bluetooth yet… Still working on it.

As of 9/9 bluetooth works with the linux-zen kernel, its in the standard repos

Installed the Artix-KDE edition and its been great. Bluetooth works and I’ve got the fingerprint reader working as well. I’ve been working on tuning my settings for battery life as of late.

Hey, after installing Artix using the linux LTS kernel I’m having some trouble with the wifi card. I picked the Intel Wi-Fi 6 AX210. After rebooting I don’t see the wlan0 device and all I have is loopback device. Can you help me troubleshoot?

dmesg output

Relevent info seems to be
[ 3.516302] iwlwifi 0000:aa:00.0: Timeout waiting for PNVM load!
[ 3.516304] iwlwifi 0000:aa:00.0: Failed to start RT ucode: -110
[ 3.516308] iwlwifi 0000:aa:00.0: iwl_trans_send_cmd bad state = 0
[ 3.528819] iwlwifi 0000:aa:00.0: Failed to run INIT ucode: -110

crosspost with artix forums

What kernel are you using?

Linux version 5.10.74-1-lts

The AX210 works with some 5.11 kernels, no 5.12 kernels (?), most 5.13 kernels and some 5.14 kernels.

I don’t know much about Artix and how easy it is to upgrade the kernel, but you may want to upgrade the kernel.

@Fraoch installing linux kernel 5.14 worked. I did the following steps:

  1. reboot with live artix linux usb.
  2. connect to wifi:
    wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
    dhcpcd wlan0
  3. ensure wifi is working:
  4. remount disk system and chroot into it
    mount /dev/nvme0n1p3 /mnt
    mount /dev/nvme0n1p1 /mnt/boot
    artix-chroot /mnt
  5. install latest stable linux kernel
    pacman -S linux
  6. (optional) check if kernel, ramdisk and fallback are available in
    ls -lsha /boot
  7. remove lts linux kernel
    pacman -R linux-lts
  8. regenerate grub config
    grub-mkconfig -o /boot/grub/grub.cfg
  9. reboot

then wlan0 was correctly showing up as a device.

1 Like

Great! Glad that resolved it! :grin: