AX210 Wifi Ubuntu 21.04 dropped connection issues

@MikeCH - I’m certainly no expert in this, but looking up the ax620 it doesn’t appear to support 6GHz (the ‘e’ in 6e, if my googling is correct). That’s the issue that I have run into - I can use that band from windows, but not linux. With that said, I’m getting great speeds on the 5GHz wifi 6 band. Is the issue that you are running into the connection speed dropping during sustained transfer? If so, I can test that out and see if I hit the same thing. I haven’t run into it but it’s not a normal scenario for me. Happy to experiment if it will help to narrow down if it is router setting or something that can be configured to work and deliver good results.

Hey, I’m no expert either and also got confused… Now that I’ve looked at it, Indeed the wax620 doesn’t operate 6E but only WiFi 6 (ax) over 5Ghz.

The behaviour I’m facing is that whenever transfers happen that are more bulky (p.ex. watching a video on YT) the connection stalls… Shows as connected still but traffic stops entirely. I have then to force a reconnection and it starts flowing again but after that I don’t even need to be doing traffic… It just randomly stops.

It’s weird because at the log level from either the AP or the laptop itself I don’t see anything that screams where the issue is.

Other devices I have work without a problem (iOS, Android, Windows)… Need to check my other laptops using Linux too as I have a few different WiFi cards around and can try to check what is the behaviour…

Ok, abut 10GB into a 64GB pull onto the laptop from a server in my network, it’s holding at about 30MBps. I did have a dropout around 3GB that lasted for about a minute, during which the transfer slowed considerably, but it picked back up after than and has been more or less steady. Not sure if it was on the server side from needing to read the file from disk, but that’s my guess without digging into things further. So the good news is that the setup seems to be able to sustain sizeable transfers. The next step is to figure out if there’s a setting that can be adjusted in your setup to prevent the issue from occurring.

Completed 64gb download then re-upload. The upload never throttled, and things held steady around 35MBps. This is on Pop!_OS 21.10 and via an Asus GT-AXE11000 access point.

I’m going to check settings on my APs but… I find it weird that for all other machines everything is fine and it’s only the linux (for the time being the FW laptop) that gets all weird.

I’m using endeavour, however I also have Elementary and Kali on the laptop for… Reasons and same behaviour…

Need to grab my other laptops and put linux in a couple of them and test…

Will add more info either later today or tomorrow on this.

Thanks for the tests on your side @lbkNhubert

So I managed to still have some time to dedicate to this lost cause and it is something weird on the FW laptop side…

I’ve booted the same live distro on both an HO Spectre I have (AX201) and the FW laptop to see that the Spectre has absolutely no connectivity issues… Pulling data both from local server as the internet without any constraint.
The FW laptop however… Yeah… Cool story bro! Drops face planted to the ground in less than a minute.

Going to see if I can grab a 201 cheap from local supplier and install it on the FW laptop but… I’m starting to consider selling it as I don’t need another Windows 11 laptop, and it doesn’t work with what I want it to do so.

Based on our communication with the Intel Linux WiFi driver team, their patches for all known AX210 issues are in kernel 5.17. It’s unfortunate that previous versions have assorted issues, but we do expect WiFi and Bluetooth stability to be good starting from 5.17 with the AX210.

6 Likes

Yes it was weird, but I had issues with that AP (a TP-Link) before with my Mac so it was something to investigate.

my connection got flakey over the last few days and i had to manually activate the wlan0 interface. iwctl device list fails to list the device anyore. Any chance the patches can be backported? current kernel with archlinux is 5.15.13 so it will be a while until 5.17 shows.

Yeah just got an AX201 and tested it on the Framework laptop and… behavior’s the exact same actually… Without any apparent reason, under linux (and occasionally on Windows too) the WiFi just gets disconnected, although on the taskbar it still looks like it is connected.
I am now also including in tests that I am doing other AP’s that I have that support WiFi 6 (ax) over 5GHz and 2.4GHz to see the behavior… if it’s the same or if it’s “smoother”.

Must be something I am doing on the AP’s from Netgear… Can’t be the hardware on the FW Laptop… But I do find it weird like hell that everything else on my network doesn’t have an issue with the AP’s and its configuration and the FW laptop SPECIFICALLY (even using the AX201 that I have on another laptop that has no issue at all) has these “losses” of connectivity.

Weird stuff really… really weird…

Right, so for some reason if ax (WiFi 6) is used on Linux in the FW laptop, it stalls connectivity when a lot of stuff comes in (large download at high speed).

So if you’re facing this, the problem is not your AP or configuration (unless it happens the same on other devices - not my case) but instead the ax support on this specific card (AX2** models) and under linux it seems but… from my tests… only on the FW laptop for some reason.

Maybe something’s causing this block to happen on the FW laptop firmware? @nrp or @BeeAPeach / @Bee sorry to flag you here but maybe something worth investigating on the firmware side of things for the laptop itself?

Hope this helps others: for the time being for your connection to be stable use disable_ax=Y on your modules.d configuration for the iwlwifi.

Spoke too soon… Heap of shit. Selling this laptop.

Thanks FW. Awesome stuff right here.

Sorry to hear that you’re continuing to have issues. Can you provide additional details for others to troubleshoot if we encounter the issue?

Same thing as the original poster here in this thread, except that even youtube or another website that goes on streaming video (Plex for instance for the sake of staying internally) kills my connection.

I’ve tested with my AP’s where all my other machines are connected without any issue, and the connection just dies when it goes over 350 mbits… Like a clog that comes in and just stalls the connection. Connection doesn’t go down per say, shows like it’s still connected but no ping, nothing… it just stalls completely.

Tested with a portable AP I have, it works “OK” but once again, as soon as we touch something above 350 mbits… Puft… dead.

Thought it was something about the firmware on Linux so I tested on windows 11 and initially things looked more stable on Windows… but after a few tests it just shows to be the same situation.

Tried with another WiFi card (AX201) which I have on an HP Spectre and… same behavior on the FW laptop…

I’ve even took the liberty to test on the HP Spectre under linux… Works flawlessly! Pumps strong and stable through WiFi 6 without any issue so I’m starting to think that it might be something on the actual FW mainboard that can’t cope with heavy loads…

I am (obviously) quite upset because this has been working before without any problem and now all of a sudden starts to behave like this… removes me all confidence on the device.

Thinking about selling it… if anyone interested in a FW laptop with very low use here in Switzerland or surrounding countries give me a shout in private.

Thanks.

Thanks for the reply. A couple of follow-ups. Was the framework working fine then began to have issues? If so, any guess as to what changed - firmware update, OS update, other? I ran a test on my setup a few days ago and did not run into the issue, so I’m trying to understand what differences there could be that might trigger this. To be clear, I absolutely believe that you have a legitimate problem, I’m just looking to see if we can try to put our heads together to get to the bottom of it and achieve a resolution. If you’ve had enough at this point and just want to move on, I understand. If you want to try to dig in just let me know.

I work in IT for a living so trust me, I’m ok with the questions you’re doing.

Now on to your point of what changed… Only the time of usage of the FW laptop. What do I mean? I started using the FW laptop more consistently as I finished migrating my things over to it and put aside my other laptops (with the exception of the Spectre one… Because it looks gorgeous and I’m a 007 fan).
I’ve actually noticed this issue while doing updates on Endeavour distro… It was happily downloading the binaries when it went “stalled” stopping the download completely.
Initially I though “hmmm… Internet’s out? No failover to 4G? Let me check my router… Nope… All good…” And went on checking access through my phone and it was all good.

I then checked again the FW laptop… Nothing… Connected to WiFi… But silent… dmesg output “normal” and iwconfig throwing back normally the info.

“Maybe something went wrong with WPA3?” so I switched over to another wireless network where it’s WPA2 and… Same… After a while it went bang head on to the wall.

“Oooookay…”

Checked for a possible wireless attack on my networks… Nothing… (Neighbors are old but you never know…)

Went on checking with another OS, different laptop, etc. And surprise… It ONLY happens on the FW laptop.

I even checked wires for the WiFi antena… Hell, I even connected another antenna to the damn thing…

It’s just weird… Like somehow the buffer internally is saturated and starts dropping info coming from the WiFi card somehow.

No updates on firmware side until now… So I am genuinely lost with this one.

I even bought an AX201… Just in case…

Same behaviour, while the ax201 on the Spectre laptop pumps like a champ without a millimeter of hesitation.

1 Like

Fiddling around a bit more. When you experience the drop, do you see anything in the log on your router? When it happens, are you able to ping the router from that machine, or to that machine from a different one?

If you run a test with iperf3, do you see it failing at a particular point? You can limit the bandwidth and see the connection drops once you hit 350. Itwould be interesting to see the test from the framework then from one of the machines that’s not having the issue, ideally using identical OS and wireless hardware.

Also, if you’re able to run a physical cable to the framework, do you have the same loss of connection when testing?

I just ran a 60 second long test to my server and got the following results:
i7 pop 21.10 kernel 5.15.8-76051508-generic 513Mbps sending 135 retries 513Mbps receiving
i5 pop 21.10 kernel 5.15.8-76051508-generic 471Mbps sending/5 retries 470Mbps receiving

Yeah, lot of changes coming to iwlwifi in 5.17:
https://git.kernel.org/pub/scm/linux/kernel/git/netdev/net-next.git/commit/?id=bc11517bc8219314948780570ec92814d14d6602

https://marc.info/?l=linux-netdev&m=164178303717586&w=2

1 Like

Hope they fix this once and for all… I’ll sell my laptop if this doesn’t get solved in the next couple of months.

Hi all, I think I’m having some similar issues on Ubuntu 21.10. I’m not sure that it only happens when the wifi hits 350 or how to test that, but it seems that my wifi slows to a halt and then stops working for ~10 minutes multiple times a day. It’s happening more and more frequently lately too and I’m not sure how to go about fixing it, everything I’ve tried from stack overflow hasn’t really done anything and it’s hard to evaluate if it works without waiting for 1~2 hours for the internet to drop again :frowning: I’m not really sure what logs are useful either.

What is the iwlwifi 5.17 kernel/how to get it? It seems like people are saying that it could be helpful.

I’m currently running 5.17-rc3, and I can unfortunately say that the wifi driver crashes repeatedly under moderate usage. The easiest way for me to repeat this is to simply open firefox, go to the Ubuntu page, and attempt to download the current desktop ISO. It inevitably crashes after about 200MB to 300MB of data has transferred.

I will be trying out some alternative fixes I see floating around, but the wifi not working on Linux is a really big issue, and I feel like it needs higher priority from the Framework team, including documentation on the Knowledgebase.

I had been running the default 5.15 kernel that came with Pop!_OS, and that exhibited the same symptoms. I also tried Fedora and was able to easily reproduce the issue there as well.

Using a USB-C to ethernet adapter has worked flawlessly, apart from being tied to an ethernet cord.

Linux pop-os 5.17.0-051700rc3-generic #202202062130 SMP PREEMPT Sun Feb 6 21:34:50 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux